summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-05-21 04:40:03 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-05-21 04:40:03 +0000
commit4df5119c27223debddbb5170a86400d5c425a9e3 (patch)
tree3a54a06922753c34978a67ffad0776f7eb70e157 /media-sound
parentStable for HPPA (bug #411845). (diff)
downloadgentoo-2-4df5119c27223debddbb5170a86400d5c425a9e3.tar.gz
gentoo-2-4df5119c27223debddbb5170a86400d5c425a9e3.tar.bz2
gentoo-2-4df5119c27223debddbb5170a86400d5c425a9e3.zip
Search for libresid-builder.so instead of libresid-builder.la during ./configure wrt #416619 by Stefan Borschtel
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/moc/ChangeLog10
-rw-r--r--media-sound/moc/files/moc-libresid-builder.so_not_la.patch20
-rw-r--r--media-sound/moc/moc-2.5.0_alpha4_p20120501-r1.ebuild79
3 files changed, 108 insertions, 1 deletions
diff --git a/media-sound/moc/ChangeLog b/media-sound/moc/ChangeLog
index 690151295b70..ae8c4cc5ff9a 100644
--- a/media-sound/moc/ChangeLog
+++ b/media-sound/moc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/moc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/moc/ChangeLog,v 1.99 2012/05/05 08:39:33 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/moc/ChangeLog,v 1.100 2012/05/21 04:40:03 ssuominen Exp $
+
+*moc-2.5.0_alpha4_p20120501-r1 (21 May 2012)
+
+ 21 May 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +moc-2.5.0_alpha4_p20120501-r1.ebuild,
+ +files/moc-libresid-builder.so_not_la.patch:
+ Search for libresid-builder.so instead of libresid-builder.la during
+ ./configure wrt #416619 by Stefan Borschtel
05 May 2012; Michał Górny <mgorny@gentoo.org>
moc-2.5.0_alpha4_p20111211.ebuild, moc-2.5.0_alpha4_p20120501.ebuild:
diff --git a/media-sound/moc/files/moc-libresid-builder.so_not_la.patch b/media-sound/moc/files/moc-libresid-builder.so_not_la.patch
new file mode 100644
index 000000000000..f2f2ada0d955
--- /dev/null
+++ b/media-sound/moc/files/moc-libresid-builder.so_not_la.patch
@@ -0,0 +1,20 @@
+There is absolutely no point in using libtool files of libresid-builder, or even expect them to be present.
+
+http://bugs.gentoo.org/416619
+
+--- decoder_plugins/sidplay2/sidplay2.m4
++++ decoder_plugins/sidplay2/sidplay2.m4
+@@ -19,10 +19,10 @@
+ if test "x$sidutils_OK" = "xyes"; then
+ s2lib=`$PKG_CONFIG --variable=libdir libsidplay2 2>/dev/null`
+ resid_OK="no"
+- AC_CHECK_FILE([$s2lib/libresid-builder.la],
+- [resid_lib="$s2lib/libresid-builder.la"
++ AC_CHECK_FILE([$s2lib/libresid-builder.so],
++ [resid_lib="$s2lib/libresid-builder.so"
+ resid_OK="yes"],
+- [resid_lib="$s2lib/sidplay/builders/libresid-builder.la"
++ [resid_lib="$s2lib/sidplay/builders/libresid-builder.so"
+ AC_CHECK_FILE($resid_lib, [resid_OK="yes"],)])
+ if test "x$resid_OK" = "xyes"; then
+ sidplay2_LDFLAGS="$resid_lib"
diff --git a/media-sound/moc/moc-2.5.0_alpha4_p20120501-r1.ebuild b/media-sound/moc/moc-2.5.0_alpha4_p20120501-r1.ebuild
new file mode 100644
index 000000000000..f72bb798dedd
--- /dev/null
+++ b/media-sound/moc/moc-2.5.0_alpha4_p20120501-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/moc/moc-2.5.0_alpha4_p20120501-r1.ebuild,v 1.1 2012/05/21 04:40:03 ssuominen Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="Music On Console - ncurses interface for playing audio files"
+HOMEPAGE="http://moc.daper.net"
+SRC_URI="http://dev.gentoo.org/~radhermit/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="aac alsa curl debug ffmpeg flac jack libsamplerate mad modplug musepack
+oss sid sndfile speex timidity +unicode vorbis wavpack"
+
+# libltdl from libtool is used at runtime
+RDEPEND=">=sys-devel/libtool-2.2.6b
+ >=sys-libs/db-4
+ sys-libs/ncurses[unicode?]
+ aac? ( media-libs/faad2 )
+ alsa? ( media-libs/alsa-lib )
+ curl? ( net-misc/curl )
+ ffmpeg? ( virtual/ffmpeg )
+ flac? ( media-libs/flac )
+ jack? ( media-sound/jack-audio-connection-kit )
+ libsamplerate? ( media-libs/libsamplerate )
+ mad? ( media-libs/libmad sys-libs/zlib media-libs/libid3tag )
+ modplug? ( media-libs/libmodplug )
+ musepack? ( media-sound/musepack-tools media-libs/taglib )
+ sid? ( >=media-libs/libsidplay-2 )
+ sndfile? ( media-libs/libsndfile )
+ speex? ( media-libs/speex )
+ timidity? ( media-libs/libtimidity media-sound/timidity++ )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ wavpack? ( media-sound/wavpack )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-libresid-builder.so_not_la.patch #416619
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable debug)
+ $(use_with oss)
+ $(use_with alsa)
+ $(use_with jack)
+ $(use_with unicode ncursesw)
+ $(use_with libsamplerate samplerate)
+ $(use_with aac)
+ $(use_with ffmpeg)
+ $(use_with flac)
+ $(use_with modplug)
+ $(use_with mad mp3)
+ --without-rcc
+ $(use_with musepack)
+ $(use_with sid sidplay2)
+ $(use_with sndfile)
+ $(use_with speex)
+ $(use_with timidity)
+ $(use_with vorbis)
+ $(use_with wavpack)
+ $(use_with curl)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS NEWS TODO # The rest is installed by doc_DATA from "${S}"/Makefile.am
+ find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} +
+}