summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2015-08-02 09:46:31 +0000
committerBen de Groot <yngwin@gentoo.org>2015-08-02 09:46:31 +0000
commit61c0e7ef75b4291904c22b1bf0bc8d4d59f4acf0 (patch)
treeac9d78fa29d3de85c0a9ca44f2230a916d6d3638 /media-sound
parentsparc stable wrt bug #551890 (diff)
downloadgentoo-2-61c0e7ef75b4291904c22b1bf0bc8d4d59f4acf0.tar.gz
gentoo-2-61c0e7ef75b4291904c22b1bf0bc8d4d59f4acf0.tar.bz2
gentoo-2-61c0e7ef75b4291904c22b1bf0bc8d4d59f4acf0.zip
Improve python handling (bug #556342)
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x4FDF9CFD2FAC514E!)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/csound/ChangeLog5
-rw-r--r--media-sound/csound/csound-6.05.0.ebuild10
2 files changed, 10 insertions, 5 deletions
diff --git a/media-sound/csound/ChangeLog b/media-sound/csound/ChangeLog
index cc8b2ff5e067..22e8e45c0e69 100644
--- a/media-sound/csound/ChangeLog
+++ b/media-sound/csound/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/csound
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/csound/ChangeLog,v 1.38 2015/07/08 15:12:42 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/csound/ChangeLog,v 1.39 2015/08/02 09:46:31 yngwin Exp $
+
+ 02 Aug 2015; Ben de Groot <yngwin@gentoo.org> csound-6.05.0.ebuild:
+ Improve python handling (bug #556342)
*csound-6.05.0 (08 Jul 2015)
diff --git a/media-sound/csound/csound-6.05.0.ebuild b/media-sound/csound/csound-6.05.0.ebuild
index 999af0194cd0..41acccedd7d8 100644
--- a/media-sound/csound/csound-6.05.0.ebuild
+++ b/media-sound/csound/csound-6.05.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/csound/csound-6.05.0.ebuild,v 1.1 2015/07/08 15:12:42 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/csound/csound-6.05.0.ebuild,v 1.2 2015/08/02 09:46:31 yngwin Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -28,7 +28,6 @@ RDEPEND="
x11-libs/fltk:1[threads?]
dev-cpp/eigen:3
dev-libs/boost
- ${PYTHON_DEPS}
)
curl? ( net-misc/curl )
dssi? (
@@ -70,6 +69,7 @@ DEPEND="${RDEPEND}
)
"
REQUIRED_USE="
+ csoundac? ( || ( lua python ) )
java? ( cxx )
linear? ( double-precision )
lua? ( cxx )
@@ -98,8 +98,10 @@ src_prepare() {
-e '/-O3/d' \
-i CMakeLists.txt || die
- sed -e 's#${REPLACE_ME}#'$(python_get_sitedir)'#' \
- -i CMakeLists.txt || die
+ if use python ; then
+ sed -e 's#${REPLACE_ME}#'$(python_get_sitedir)'#' \
+ -i CMakeLists.txt || die
+ fi
for lang in ${LANGS} ; do
if ! use linguas_${lang} ; then