summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-07-08 08:11:34 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-07-08 08:11:34 +0000
commit829327a6cf057207701ef55ad82e79f4324687f6 (patch)
tree60a7bf33b3a2374fb79c602005b02eccaaa86f68 /media-sound
parentcomment updated (Manifest recommit) (diff)
downloadgentoo-2-829327a6cf057207701ef55ad82e79f4324687f6.tar.gz
gentoo-2-829327a6cf057207701ef55ad82e79f4324687f6.tar.bz2
gentoo-2-829327a6cf057207701ef55ad82e79f4324687f6.zip
Adding cs46xx patch to portage.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.5a.ebuild6
-rw-r--r--media-sound/alsa-driver/files/alsa-driver-1.0.5a-cs46xx-passthrough.patch13
2 files changed, 18 insertions, 1 deletions
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.5a.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.5a.ebuild
index ba9f9d976cc7..9158b13af3b0 100644
--- a/media-sound/alsa-driver/alsa-driver-1.0.5a.ebuild
+++ b/media-sound/alsa-driver/alsa-driver-1.0.5a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.5a.ebuild,v 1.1 2004/06/25 07:53:47 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.5a.ebuild,v 1.2 2004/07/08 08:11:34 eradicator Exp $
inherit kernel-mod flag-o-matic eutils
@@ -42,6 +42,10 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${PN}-1.0.5-devfix.patch
+ # Uncomment to include the cs46xx patch.
+ # Sorry no revision bump because portage 2.0.50 does not allow 1.0.5a-r1 as a version string. 1.0.6 should be out soon...
+ #epatch ${FILESDIR}/${P}-cs46xx-passthrough.patch
+
if kernel-mod_is_2_6_kernel || kernel-mod_is_2_5_kernel; then
FULL_KERNEL_PATH="${ROOT}/usr/src/${KV_DIR}"
diff --git a/media-sound/alsa-driver/files/alsa-driver-1.0.5a-cs46xx-passthrough.patch b/media-sound/alsa-driver/files/alsa-driver-1.0.5a-cs46xx-passthrough.patch
new file mode 100644
index 000000000000..50078e648ddb
--- /dev/null
+++ b/media-sound/alsa-driver/files/alsa-driver-1.0.5a-cs46xx-passthrough.patch
@@ -0,0 +1,13 @@
+--- alsa-driver-1.0.5a/pci/cs46xx/Makefile 2004-04-08 12:38:16.000000000 -0400
++++ alsa-driver-1.0.3/pci/cs46xx/Makefile 2004-07-01 19:18:58.084822112 -0400
+@@ -5,6 +5,10 @@
+ include $(SND_TOPDIR)/toplevel.config
+ include $(SND_TOPDIR)/Makefile.conf
+
++# Hack for new dsp flag
++EXTRA_CFLAGS += -DCONFIG_SND_CS46XX_NEW_DSP=1
++CONFIG_SND_CS46XX_NEW_DSP=y
++
+ include $(SND_TOPDIR)/alsa-kernel/pci/cs46xx/Makefile
+
+ include $(SND_TOPDIR)/Rules.make