summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe McCann <joem@gentoo.org>2007-01-23 03:57:21 +0000
committerJoe McCann <joem@gentoo.org>2007-01-23 03:57:21 +0000
commit95913f2dfd664304c948bd095a1510cff5664626 (patch)
tree19a13dec1af5634898ec76b97e2e7b66a4b56c2e /media-sound
parentpatch the configure.in thanks to code from steven debock and bug # 144154 (diff)
downloadgentoo-2-95913f2dfd664304c948bd095a1510cff5664626.tar.gz
gentoo-2-95913f2dfd664304c948bd095a1510cff5664626.tar.bz2
gentoo-2-95913f2dfd664304c948bd095a1510cff5664626.zip
Remove aac use flag as per bug 159538
(Portage version: 2.1.2_rc4-r7)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/rhythmbox/ChangeLog6
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.9.6.ebuild14
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.9.7.ebuild17
3 files changed, 28 insertions, 9 deletions
diff --git a/media-sound/rhythmbox/ChangeLog b/media-sound/rhythmbox/ChangeLog
index 6147b2df5a4c..1d1386575c7c 100644
--- a/media-sound/rhythmbox/ChangeLog
+++ b/media-sound/rhythmbox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/rhythmbox
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.84 2007/01/17 13:18:06 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.85 2007/01/23 03:57:21 joem Exp $
+
+ 23 Jan 2007; Joe McCann <joem@gentoo.org> rhythmbox-0.9.6.ebuild,
+ rhythmbox-0.9.7.ebuild:
+ Remove aac use flag as per bug 159538
17 Jan 2007; Gustavo Zacarias <gustavoz@gentoo.org>
rhythmbox-0.9.6.ebuild:
diff --git a/media-sound/rhythmbox/rhythmbox-0.9.6.ebuild b/media-sound/rhythmbox/rhythmbox-0.9.6.ebuild
index 9c973c234509..6f0d102ff9eb 100644
--- a/media-sound/rhythmbox/rhythmbox-0.9.6.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-0.9.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.9.6.ebuild,v 1.4 2007/01/17 13:18:06 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.9.6.ebuild,v 1.5 2007/01/23 03:57:21 joem Exp $
inherit gnome2 eutils
@@ -8,7 +8,7 @@ DESCRIPTION="Music management and playback software for GNOME"
HOMEPAGE="http://www.rhythmbox.org/"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ia64 ~ppc sparc ~x86"
-IUSE="vorbis flac aac mad ipod avahi hal howl daap dbus libnotify lirc musicbrainz
+IUSE="vorbis flac mad ipod avahi hal howl daap dbus libnotify lirc musicbrainz
tagwriting python"
#I want tagwriting to be on by default in the future. It is just a local flag
#now because it is still considered experimental by upstream and doesn't work
@@ -39,7 +39,6 @@ RDEPEND=">=x11-libs/gtk+-2.5.4
>=media-plugins/gst-plugins-ogg-0.10 )
mad? ( >=media-plugins/gst-plugins-mad-0.10 )
flac? ( >=media-plugins/gst-plugins-flac-0.10 )
- aac? ( >=media-plugins/gst-plugins-faad-0.10 )
libnotify? ( >=x11-libs/libnotify-0.3.2 )
python? ( >=dev-lang/python-2.4.2
>=dev-python/pygtk-2.6
@@ -101,3 +100,12 @@ src_compile() {
addpredict "$(unset HOME; echo ~)/.gconfd"
gnome2_src_compile
}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ elog "The aac flag has been removed from rhythmbox."
+ elog "This is due to stabilization issues with any gst-bad plugins."
+ elog "Please emerge gst-plugins-bad and gst-plugins-faad to be able to play m4a files"
+ elog"See bug #159538 for more information"
+}
+
diff --git a/media-sound/rhythmbox/rhythmbox-0.9.7.ebuild b/media-sound/rhythmbox/rhythmbox-0.9.7.ebuild
index d7214621b218..796978e8e487 100644
--- a/media-sound/rhythmbox/rhythmbox-0.9.7.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-0.9.7.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.9.7.ebuild,v 1.2 2007/01/14 23:03:42 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.9.7.ebuild,v 1.3 2007/01/23 03:57:21 joem Exp $
inherit gnome2 eutils
DESCRIPTION="Music management and playback software for GNOME"
HOMEPAGE="http://www.rhythmbox.org/"
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
-IUSE="vorbis flac aac mad ipod avahi hal howl daap dbus libnotify lirc musicbrainz
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="vorbis flac mad ipod avahi hal howl daap dbus libnotify lirc musicbrainz
tagwriting python keyring"
#I want tagwriting to be on by default in the future. It is just a local flag
#now because it is still considered experimental by upstream and doesn't work
-#well with all formats
+#well with all formats due to gstreamer limitation.
SLOT="0"
@@ -40,7 +40,6 @@ RDEPEND=">=x11-libs/gtk+-2.6
>=media-plugins/gst-plugins-ogg-0.10 )
mad? ( >=media-plugins/gst-plugins-mad-0.10 )
flac? ( >=media-plugins/gst-plugins-flac-0.10 )
- aac? ( >=media-plugins/gst-plugins-faad-0.10 )
libnotify? ( >=x11-libs/libnotify-0.3.2 )
python? ( >=dev-lang/python-2.4.2
>=dev-python/pygtk-2.8
@@ -104,3 +103,11 @@ src_compile() {
addpredict "$(unset HOME; echo ~)/.gconfd"
gnome2_src_compile
}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ elog "The aac flag has been removed from rhythmbox."
+ elog "This is due to stabilization issues with any gst-bad plugins."
+ elog "Please emerge gst-plugins-bad and gst-plugins-faad to be able to play m4a files"
+ elog"See bug #159538 for more information"
+}