summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomás Touceda <chiiph@gentoo.org>2010-04-28 12:31:12 +0000
committerTomás Touceda <chiiph@gentoo.org>2010-04-28 12:31:12 +0000
commita84c12aa2b7c4eb10065666f6a2b0502c91e580c (patch)
tree01c072c804199c2caec1028c265714f30f906988 /media-sound
parentAdded Netbeans 6.9 beta release (diff)
downloadgentoo-2-a84c12aa2b7c4eb10065666f6a2b0502c91e580c.tar.gz
gentoo-2-a84c12aa2b7c4eb10065666f6a2b0502c91e580c.tar.bz2
gentoo-2-a84c12aa2b7c4eb10065666f6a2b0502c91e580c.zip
Fix dependency problem wrt bug 315471, and improve python related code wrt bug 313961. Thanks to Xarthisius and Arfrever for helping with this two issues
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lilypond/ChangeLog7
-rw-r--r--media-sound/lilypond/lilypond-2.12.3.ebuild18
2 files changed, 19 insertions, 6 deletions
diff --git a/media-sound/lilypond/ChangeLog b/media-sound/lilypond/ChangeLog
index 61120103930f..dc2042e76a0f 100644
--- a/media-sound/lilypond/ChangeLog
+++ b/media-sound/lilypond/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/lilypond
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/ChangeLog,v 1.104 2010/04/13 18:35:47 chiiph Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/ChangeLog,v 1.105 2010/04/28 12:31:12 chiiph Exp $
+
+ 28 Apr 2010; Tomas Touceda <chiiph@gentoo.org> lilypond-2.12.3.ebuild:
+ Fix dependency problem wrt bug 315471, and improve python related code wrt
+ bug 313961. Thanks to Xarthisius and Arfrever for helping with this two
+ issues
*lilypond-2.12.3 (13 Apr 2010)
diff --git a/media-sound/lilypond/lilypond-2.12.3.ebuild b/media-sound/lilypond/lilypond-2.12.3.ebuild
index a78c2d010b05..096aecb4a7a9 100644
--- a/media-sound/lilypond/lilypond-2.12.3.ebuild
+++ b/media-sound/lilypond/lilypond-2.12.3.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-2.12.3.ebuild,v 1.1 2010/04/13 18:35:47 chiiph Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-2.12.3.ebuild,v 1.2 2010/04/28 12:31:12 chiiph Exp $
EAPI="3"
-inherit eutils versionator toolchain-funcs elisp-common flag-o-matic
+PYTHON_DEPEND="2"
+
+inherit eutils versionator toolchain-funcs elisp-common flag-o-matic python
DESCRIPTION="GNU Music Typesetter"
SRC_URI="http://download.linuxaudio.org/lilypond/sources/v$(get_version_component_range 1-2)/${P}.tar.gz"
@@ -16,12 +18,11 @@ KEYWORDS="~alpha ~amd64 ~sparc ~x86"
IUSE="debug emacs profile"
-RDEPEND="
+RDEPEND="|| ( media-fonts/gnu-gs-fonts-std media-fonts/urw-fonts )
>=media-libs/freetype-2
media-libs/fontconfig
>=x11-libs/pango-1.12.3
>=dev-scheme/guile-1.8.2[deprecated,regex]
- >=dev-lang/python-2.4
|| ( >=app-text/ghostscript-gnu-8.15
>=app-text/ghostscript-gpl-8.15 )
emacs? ( virtual/emacs )"
@@ -38,6 +39,10 @@ DEPEND="${RDEPEND}
dev-lang/perl
>=sys-devel/bison-2.0"
+pkg_setup() {
+ python_set_active_version 2
+}
+
src_prepare() {
epatch "${FILESDIR}"/${P}-qa_pyc_fix.patch
}
@@ -49,6 +54,7 @@ src_configure() {
fi
if use profile; then
+ einfo "Stripping -fomit-frame-pointer flag"
strip-flags -fomit-frame-pointer
fi
@@ -78,7 +84,7 @@ src_compile() {
# for our purposes.
RESTRICT=test
-src_install () {
+src_install() {
emake DESTDIR="${D}" vimdir=/usr/share/vim/vimfiles install || die "emake install failed"
# remove elisp files since they are in the wrong directory
@@ -91,6 +97,8 @@ src_install () {
fi
dodoc AUTHORS.txt HACKING NEWS.txt README.txt || die
+
+ python_convert_shebangs -r 2 "${D}"
}
pkg_postinst() {