summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-06-15 08:13:58 +0000
committerZac Medico <zmedico@gentoo.org>2008-06-15 08:13:58 +0000
commit31305ba7754d135058f0700ff132c7ff29571f19 (patch)
tree20af4401a3b9594a69363be126108e203b51c32d /media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.0.ebuild
parentFix quoting, stop using ./configure (#120887) (diff)
downloadgentoo-2-31305ba7754d135058f0700ff132c7ff29571f19.tar.gz
gentoo-2-31305ba7754d135058f0700ff132c7ff29571f19.tar.bz2
gentoo-2-31305ba7754d135058f0700ff132c7ff29571f19.zip
Bug #226505 - For compatibility with phase execution order in
>=portage-2.1.5, call has_version inside pkg_preinst instead of pkg_postinst. (Portage version: 2.2_pre10652/cvs/Linux 2.6.25-0518-x86-64 i686)
Diffstat (limited to 'media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.0.ebuild')
-rw-r--r--media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.0.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.0.ebuild b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.0.ebuild
index aa542eea9ab8..d22dd4f6da29 100644
--- a/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.0.ebuild
+++ b/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.0.ebuild,v 1.4 2007/10/04 12:28:10 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/gentoo-vdr-scripts/gentoo-vdr-scripts-0.4.0.ebuild,v 1.5 2008/06/15 08:13:58 zmedico Exp $
inherit eutils
@@ -65,12 +65,18 @@ pkg_preinst() {
echo ${PLUGIN} >> "${D}"/etc/conf.d/vdr.plugins
done
fi
+
+ has_version "<${CATEGORY}/${PN}-0.3.6"
+ previous_less_than_0_3_6=$?
+
+ has_version "<${CATEGORY}/${PN}-0.3.7"
+ previous_less_than_0_3_7=$?
}
VDRSUDOENTRY="vdr ALL=NOPASSWD:/usr/share/vdr/bin/vdrshutdown-really.sh"
pkg_postinst() {
- if has_version "<media-tv/gentoo-vdr-scripts-0.3.6"; then
+ if [[ $previous_less_than_0_3_6 = 0 ]] ; then
ewarn
ewarn "A shutdown-file has been changed."
ewarn "You really have to execute"
@@ -95,7 +101,7 @@ pkg_postinst() {
elog "or just emerge nvram-wakeup."
fi
- if has_version "<media-tv/gentoo-vdr-scripts-0.3.7"; then
+ if [[ $previous_less_than_0_3_7 = 0 ]] ; then
einfo
einfo "Plugins which should be used are now set via its"
einfo "own config-file called /etc/conf.d/vdr.plugins"