summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-06-13 07:10:25 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-06-13 07:10:25 +0000
commit1273f023da1489395e16f7ee25c9eed0e37a4135 (patch)
tree02d6b9db14bfb1eb05b4573f70dfbe78872e93cf /media-tv/ivtv
parentAdded message about kernel versions in 0.4.2 and marked stable on ppc. (diff)
downloadgentoo-2-1273f023da1489395e16f7ee25c9eed0e37a4135.tar.gz
gentoo-2-1273f023da1489395e16f7ee25c9eed0e37a4135.tar.bz2
gentoo-2-1273f023da1489395e16f7ee25c9eed0e37a4135.zip
Adding 0.4.4 version for people having issueth 0.4.5 & MythTV
(Portage version: 2.1)
Diffstat (limited to 'media-tv/ivtv')
-rw-r--r--media-tv/ivtv/ChangeLog7
-rw-r--r--media-tv/ivtv/files/digest-ivtv-0.4.49
-rw-r--r--media-tv/ivtv/ivtv-0.4.4.ebuild135
3 files changed, 150 insertions, 1 deletions
diff --git a/media-tv/ivtv/ChangeLog b/media-tv/ivtv/ChangeLog
index 2cdf1c36249e..8889efe70113 100644
--- a/media-tv/ivtv/ChangeLog
+++ b/media-tv/ivtv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/ivtv
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.45 2006/06/13 07:07:27 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.46 2006/06/13 07:10:25 cardoe Exp $
+
+*ivtv-0.4.4 (13 Jun 2006)
+
+ 13 Jun 2006; Doug Goldstein <cardoe@gentoo.org> +ivtv-0.4.4.ebuild:
+ Adding 0.4.4 version for people having issues with 0.4.5 & MythTV
13 Jun 2006; Doug Goldstein <cardoe@gentoo.org> ivtv-0.4.2.ebuild:
Added message about kernel versions in 0.4.2 and marked stable on ppc.
diff --git a/media-tv/ivtv/files/digest-ivtv-0.4.4 b/media-tv/ivtv/files/digest-ivtv-0.4.4
new file mode 100644
index 000000000000..85bd8abfa6ce
--- /dev/null
+++ b/media-tv/ivtv/files/digest-ivtv-0.4.4
@@ -0,0 +1,9 @@
+MD5 ec30256b8dae4ee76b2c2c699621b68b ivtv-0.4.4.tar.gz 502468
+RMD160 89ebc5cdcefd339e18c6e24575a6dc0eb3cd1af3 ivtv-0.4.4.tar.gz 502468
+SHA256 b311fc7131f748df048e4672c024fe32b544aff08745f4ac2efe723ab9c0da61 ivtv-0.4.4.tar.gz 502468
+MD5 f48ad2cda962879bc093cc6867dc86d2 pvr_1.18.21.22254_inf.zip 593441
+RMD160 9549dddfddacf6bee3c73def508a2c347c5e25f2 pvr_1.18.21.22254_inf.zip 593441
+SHA256 156c0cfaa2cb3f482b48f95b94a9247690e4ed2d0cb8962a52db8846c683bff1 pvr_1.18.21.22254_inf.zip 593441
+MD5 dc84a41b3b296b856da3d0f9edbb7a08 pvr_2.0.24.23035.zip 281620
+RMD160 fbd439efa5793e9a65fd6fac2093c523cd458027 pvr_2.0.24.23035.zip 281620
+SHA256 2387e7a042342f7b401222aac7f99a19b733fded8118339edd402a58279e5f95 pvr_2.0.24.23035.zip 281620
diff --git a/media-tv/ivtv/ivtv-0.4.4.ebuild b/media-tv/ivtv/ivtv-0.4.4.ebuild
new file mode 100644
index 000000000000..899688e318c5
--- /dev/null
+++ b/media-tv/ivtv/ivtv-0.4.4.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.4.4.ebuild,v 1.1 2006/06/13 07:10:25 cardoe Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="ivtv driver for Hauppauge PVR PCI cards"
+HOMEPAGE="http://www.ivtvdriver.org"
+
+FW_VER_DEC="pvr_1.18.21.22254_inf.zip"
+FW_VER_ENC="pvr_2.0.24.23035.zip"
+#Switched to recommended firmware by driver
+
+SRC_URI="http://dl.ivtvdriver.org/ivtv/archive/0.4.x/${P}.tar.gz
+ ftp://ftp.shspvr.com/download/wintv-pvr_150-500/inf/${FW_VER_ENC}
+ ftp://ftp.shspvr.com/download/wintv-pvr_250-350/inf/${FW_VER_DEC}"
+
+RESTRICT="nomirror"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~ppc"
+
+IUSE=""
+
+BUILD_TARGETS="all"
+BUILD_PARAMS="KDIR=${KERNEL_DIR}"
+CONFIG_CHECK="I2C_ALGOBIT VIDEO_DEV I2C_CHARDEV I2C"
+
+RDEPEND="sys-apps/hotplug"
+DEPEND="app-arch/unzip"
+
+pkg_setup() {
+ MODULE_NAMES="ivtv(extra:${S}/driver)"
+
+ if kernel_is gt 2 6 15; then
+ ewarn "You must use 0.6.x with a 2.6.16 kernel. However the kernel is broken"
+ ewarn "with IVTV for a great number of people. Including the maintainer of"
+ ewarn "IVTV in Gentoo. Your best bet is to use a 2.6.15 kernel"
+ die "This does not work with kernel versions higher then 2.6.15"
+ fi
+
+ if kernel_is le 2 6 14; then
+ MODULE_NAMES="${MODULE_NAMES}
+ msp3400(extra:${S}/driver)
+ saa7115(extra:${S}/driver)
+ tveeprom(extra:${S}/driver)
+ saa7127(extra:${S}/driver)
+ cx25840(extra:${S}/driver)
+ tuner(extra:${S}/driver)
+ wm8775(extra:${S}/driver)
+ tda9887(extra:${S}/driver)
+ cs53l32a(extra:${S}/driver)"
+ else
+ CONFIG_CHECK="${CONFIG_CHECK} VIDEO_DECODER VIDEO_AUDIO_DECODER VIDEO_BT848"
+ fi
+
+ linux_chkconfig_present FB && \
+ MODULE_NAMES="${MODULE_NAMES} ivtv-fb(extra:${S}/driver)"
+
+ linux-mod_pkg_setup
+}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ unpack ${FW_VER_ENC}
+
+ sed -e "s:^VERS26=.*:VERS26=${KV_MAJOR}.${KV_MINOR}:g" \
+ -i ${S}/driver/Makefile || die "sed failed"
+}
+
+src_compile() {
+ cd ${S}/driver
+ linux-mod_src_compile || die "failed to build driver "
+
+ cd ${S}/utils
+ emake || die "failed to build utils "
+}
+
+src_install() {
+ cd ${S}/utils
+ dodir /lib/firmware
+ ./ivtvfwextract.pl "${DISTDIR}"/${FW_VER_DEC} \
+ "${D}"/lib/firmware/v4l-cx2341x-enc.fw \
+ "${D}"/lib/firmware/v4l-cx2341x-dec.fw
+
+ make KERNELDIR="${KERNEL_DIR}" DESTDIR="${D}" PREFIX=/usr install || die "failed to install"
+
+ insinto /lib/firmware
+ newins "${WORKDIR}"/HcwMakoA.ROM v4l-cx25840.fw
+ newins ${S}/v4l-cx2341x-init.mpg v4l-cx2341x-init.mpg
+
+ cd ${S}
+ dodoc README doc/* utils/README.X11
+
+ cd ${S}/driver
+ linux-mod_src_install || die "failed to install modules"
+
+ # Add the aliases
+ insinto /etc/modules.d
+ newins "${FILESDIR}"/ivtv ivtv
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ # The MCE versions of the PVR cards come without remote control because (I
+ # assume) a remote control is included in Windows Media Center Edition. It
+ # is probably a good idea to just say that if your package comes with a
+ # remote then emerge lirc. Lirc should build all drivers anyway.
+ #
+ # einfo "To get the ir remote working, you'll need to emerge lirc"
+ # einfo "with the following set:"
+ # einfo "LIRC_OPTS=\"--with-x --with-driver=hauppauge --with-major=61 "
+ # einfo " --with-port=none --with-irq=none\" emerge lirc"
+ # echo
+ # einfo "You can also add the above LIRC_OPTS line to /etc/make.conf for"
+ # einfo "it to remain there for future updates."
+ # echo
+ # einfo "To use vbi, you'll need a few other things, check README.vbi in the docs dir"
+ # echo
+
+ # Similar checks are performed by the make install in the drivers directory.
+ BADMODS="msp3400 tda9887 tuner tveeprom"
+
+ if [ ${KV_PATCH} -le 14 ]; then
+ for MODNAME in ${BADMODS}; do
+ if [ -f "${ROOT}/lib/modules/${KV_FULL}/kernel/drivers/media/video/${MODNAME}.ko" ] ; then
+ ewarn "You have the ${MODNAME} module that comes with the kernel. It isn't compatible"
+ ewarn "with ivtv. You need to back it up to somewhere else, then run 'update-modules'"
+ ewarn "The file to remove is ${ROOT}/lib/modules/${KV_FULL}/kernel/drivers/media/video/${MODNAME}.ko"
+ echo
+ fi
+ done
+ fi
+}