summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-06-02 21:45:18 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-06-02 21:45:18 +0000
commit10558dd3b31c88d930d6a4bb52bedf2df1172a09 (patch)
treee08a498b1b828b8bb65ad3db287e9aa4c0c90a10 /media-tv/mythtv
parentAdded to ~ppc (Manifest recommit) (diff)
downloadgentoo-2-10558dd3b31c88d930d6a4bb52bedf2df1172a09.tar.gz
gentoo-2-10558dd3b31c88d930d6a4bb52bedf2df1172a09.tar.bz2
gentoo-2-10558dd3b31c88d930d6a4bb52bedf2df1172a09.zip
Apply fixes from #52722 and #52154.
Diffstat (limited to 'media-tv/mythtv')
-rw-r--r--media-tv/mythtv/ChangeLog7
-rw-r--r--media-tv/mythtv/files/mythtv-0.15-directfb.patch19
-rw-r--r--media-tv/mythtv/mythtv-0.15.1.ebuild25
3 files changed, 45 insertions, 6 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index 09b5766f1063..b2d22f88c163 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/mythtv
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.21 2004/06/01 17:08:24 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.22 2004/06/02 21:45:17 aliz Exp $
+
+ 02 Jun 2004; Daniel Ahlberg <aliz@gentoo.org> mythtv-0.15.1.ebuild:
+ + Added check for OpenGL implementation, closing #52722.
+ + Added directfb patch by Scott Alfer <gentoo@salfter.dyndns.org> from #52154.
+ + Depend on either wget (for DataDirect) or xmltv.
*mythtv-0.15.1 (01 Jun 2004)
diff --git a/media-tv/mythtv/files/mythtv-0.15-directfb.patch b/media-tv/mythtv/files/mythtv-0.15-directfb.patch
new file mode 100644
index 000000000000..7f72c06b111a
--- /dev/null
+++ b/media-tv/mythtv/files/mythtv-0.15-directfb.patch
@@ -0,0 +1,19 @@
+*** mythtv-0.15/libs/libmythtv/videoout_directfb.cpp~ Wed May 26 22:50:27 2004
+--- mythtv-0.15/libs/libmythtv/videoout_directfb.cpp Wed May 26 22:50:27 2004
+***************
+*** 337,343 ****
+ desc.flags = DSDESC_CAPS;
+ desc.caps = DSCAPS_PRIMARY;
+ if(data->cardCapabilities.acceleration_mask & DFXL_BLIT)
+! desc.caps = (DFBSurfaceCapabilities)(desc.caps | DSCAPS_DOUBLE);
+ DFBCHECKFAIL(data->dfb->CreateSurface(data->dfb, &desc, &(data->primarySurface)), false);
+ DFBCHECKFAIL(data->primarySurface->Clear(data->primarySurface, 0, 0, 0, 0xff), false);
+ DFBCHECKFAIL(data->primarySurface->Flip(data->primarySurface, 0, DSFLIP_ONSYNC), false);
+--- 337,343 ----
+ desc.flags = DSDESC_CAPS;
+ desc.caps = DSCAPS_PRIMARY;
+ if(data->cardCapabilities.acceleration_mask & DFXL_BLIT)
+! desc.caps = (DFBSurfaceCapabilities)(desc.caps | DSCAPS_FLIPPING);
+ DFBCHECKFAIL(data->dfb->CreateSurface(data->dfb, &desc, &(data->primarySurface)), false);
+ DFBCHECKFAIL(data->primarySurface->Clear(data->primarySurface, 0, 0, 0, 0xff), false);
+ DFBCHECKFAIL(data->primarySurface->Flip(data->primarySurface, 0, DSFLIP_ONSYNC), false);
diff --git a/media-tv/mythtv/mythtv-0.15.1.ebuild b/media-tv/mythtv/mythtv-0.15.1.ebuild
index 517834f0e35d..710689359085 100644
--- a/media-tv/mythtv/mythtv-0.15.1.ebuild
+++ b/media-tv/mythtv/mythtv-0.15.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.15.1.ebuild,v 1.1 2004/06/01 17:08:24 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.15.1.ebuild,v 1.2 2004/06/02 21:45:17 aliz Exp $
-inherit flag-o-matic
+inherit flag-o-matic eutils
DESCRIPTION="Homebrew PVR project."
HOMEPAGE="http://www.mythtv.org/"
@@ -17,7 +17,6 @@ DEPEND=">=media-libs/freetype-2.0
>=media-sound/lame-3.93.1
>=x11-libs/qt-3.1
dev-db/mysql
- >=media-tv/xmltv-0.5.34
alsa? ( >=media-libs/alsa-lib-0.9 )
>=sys-apps/sed-4
arts? ( kde-base/arts )
@@ -26,7 +25,9 @@ DEPEND=">=media-libs/freetype-2.0
lcd? ( app-misc/lcdproc )
lirc? ( app-misc/lirc )
nvidia? ( media-video/nvidia-glx )
- cle266? ( media-libs/libddmpeg )"
+ cle266? ( media-libs/libddmpeg )
+ opengl? ( >=x11-base/opengl-update-1.7 )
+ || ( >=net-misc/wget-1.9.1 >=media-tv/xmltv-0.5.34 )"
RDEPEND="${DEPEND}
!media-tv/mythfrontend"
@@ -38,7 +39,17 @@ pkg_setup() {
eerror "'mysql' to your USE flags, and re-emerge Qt."
die "Qt needs MySQL support"
fi
-
+ if [ `use opengl` ] ; then
+ local gl_implementation="$( opengl-update --get-implementation )"
+ if [ "$gl_implementation" == "xfree" ] || [ "$gl_implementation" == "xorg-x11" ] ; then
+ return 0
+ else
+ eerror "OpenGL implementation must be set to either xfree or xorg-x11 to allow compilation."
+ eerror "to change opengl implemantation use opengl-update <your xserver>."
+ eerror "After mythtv has been merged you can switch back to the preferred implementation.."
+ die "Incompatible OpenGL implementation."
+ fi
+ fi
return 0
}
@@ -48,6 +59,8 @@ src_unpack() {
for i in `grep -lr "usr/local" "${S}"` ; do
sed -e "s:usr/local:usr:g" -i "${i}" || die "sed failed"
done
+
+ use directfb && epatch ${FILESDIR}/mythtv-0.15-directfb.patch
}
src_compile() {
@@ -172,4 +185,6 @@ pkg_postinst() {
einfo " /usr/share/doc/${PF}/README.gz"
einfo " /usr/share/doc/${PF}/UPGRADING.gz"
echo
+ einfo "You need to emerge xmltv manually since it is no longer needed"
+ einfo "if the internal DataDirect implementation is to be used."
}