summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-20 05:00:49 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-20 05:00:49 +0000
commita9892fa5ecdaf1aec78e4a94f4ee1f98454a2b93 (patch)
treec1534489d2d9dfa475edea4ab6be67b989a6e434 /media-tv/tvtime/tvtime-1.0.2.ebuild
parentAdd eclass for XFCE 4.4 and update the 4.2 eclass as needed. (diff)
downloadgentoo-2-a9892fa5ecdaf1aec78e4a94f4ee1f98454a2b93.tar.gz
gentoo-2-a9892fa5ecdaf1aec78e4a94f4ee1f98454a2b93.tar.bz2
gentoo-2-a9892fa5ecdaf1aec78e4a94f4ee1f98454a2b93.zip
Add patch to allow disabling xinerama and add xinerama useflag.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'media-tv/tvtime/tvtime-1.0.2.ebuild')
-rw-r--r--media-tv/tvtime/tvtime-1.0.2.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/media-tv/tvtime/tvtime-1.0.2.ebuild b/media-tv/tvtime/tvtime-1.0.2.ebuild
index a271f3589977..1461cafaf0ec 100644
--- a/media-tv/tvtime/tvtime-1.0.2.ebuild
+++ b/media-tv/tvtime/tvtime-1.0.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/tvtime-1.0.2.ebuild,v 1.2 2006/01/12 17:19:08 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/tvtime-1.0.2.ebuild,v 1.3 2006/04/20 05:00:49 flameeyes Exp $
-inherit eutils
+inherit eutils autotools
DESCRIPTION="High quality television application for use with video capture cards"
HOMEPAGE="http://tvtime.sourceforge.net/"
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="nls"
+IUSE="nls xinerama"
RDEPEND="|| ( ( x11-libs/libSM
x11-libs/libICE
@@ -19,7 +19,7 @@ RDEPEND="|| ( ( x11-libs/libSM
x11-libs/libXext
x11-libs/libXv
x11-libs/libXxf86vm
- x11-libs/libXinerama
+ xinerama? ( x11-libs/libXinerama )
x11-libs/libXtst
x11-libs/libXau
x11-libs/libXdmcp )
@@ -27,7 +27,8 @@ RDEPEND="|| ( ( x11-libs/libSM
>=media-libs/freetype-2
>=sys-libs/zlib-1.1.4
>=media-libs/libpng-1.2
- >=dev-libs/libxml2-2.5.11"
+ >=dev-libs/libxml2-2.5.11
+ nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
@@ -43,10 +44,15 @@ src_unpack() {
# patch to adapt to PIC or __PIC__ for pic support
epatch "${FILESDIR}"/${PN}-pic.patch #74227
+
+ epatch "${FILESDIR}/${P}-xinerama.patch"
+
+ eautoreconf
}
src_compile() {
- econf $(use_enable nls) || die "econf failed"
+ econf $(use_enable nls) \
+ $(use_with xinerama) || die "econf failed"
emake || die "compile problem"
}