summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2009-09-27 22:31:02 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2009-09-27 22:31:02 +0000
commit0f729d03d05456878b0756b687712a653f9c4c85 (patch)
treea8a2a208d16d81fdcba6b6f3e37222a0cbca21bc /media-video/arista/arista-0.9.3-r1.ebuild
parentversion bump (diff)
downloadgentoo-2-0f729d03d05456878b0756b687712a653f9c4c85.tar.gz
gentoo-2-0f729d03d05456878b0756b687712a653f9c4c85.tar.bz2
gentoo-2-0f729d03d05456878b0756b687712a653f9c4c85.zip
Add xvid support by default (used by the Computer, PDA Generic, and DVD profiles in Arista)
(Portage version: 2.2_rc42/cvs/Linux i686)
Diffstat (limited to 'media-video/arista/arista-0.9.3-r1.ebuild')
-rw-r--r--media-video/arista/arista-0.9.3-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-video/arista/arista-0.9.3-r1.ebuild b/media-video/arista/arista-0.9.3-r1.ebuild
new file mode 100644
index 000000000000..0229b4aadf32
--- /dev/null
+++ b/media-video/arista/arista-0.9.3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/arista/arista-0.9.3-r1.ebuild,v 1.1 2009/09/27 22:31:02 ford_prefect Exp $
+
+EAPI=2
+
+inherit distutils
+
+DESCRIPTION="An easy to use multimedia transcoder for the GNOME Desktop"
+HOMEPAGE="http://programmer-art.org/projects/arista-transcoder"
+SRC_URI="http://programmer-art.org/media/releases/arista-transcoder/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+# Making these USE-defaults since encoding for portable devices is a very
+# common use case for Arista. xvid is being added since it's required for
+# DVD ripping
+IUSE="+faac +x264 +xvid"
+
+DEPEND="dev-python/setuptools"
+RDEPEND="dev-lang/python[xml]
+ >=x11-libs/gtk+-2.16
+ >=dev-python/pygtk-2.14
+ dev-python/pygobject
+ dev-python/pycairo
+ dev-python/gconf-python
+ dev-python/dbus-python
+ >=media-libs/gstreamer-0.10.22
+ dev-python/gst-python
+ media-libs/gst-plugins-base:0.10
+ media-libs/gst-plugins-good:0.10
+ media-plugins/gst-plugins-meta:0.10
+ media-plugins/gst-plugins-ffmpeg:0.10
+ faac? ( media-plugins/gst-plugins-faac:0.10 )
+ x264? ( media-plugins/gst-plugins-x264:0.10 )
+ xvid? ( media-plugins/gst-plugins-xvid:0.10 )"
+
+pkg_postinst()
+{
+ einfo "If you find that a format you want is not supported in Arista,"
+ einfo "please make sure that you have the corresponding USE-flag enabled"
+ einfo "media-plugins/gst-plugins-meta"
+}