summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-11 20:21:19 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-11 20:21:19 +0000
commit77bf231a9d0b8bdb6229b63d27380786a27685ae (patch)
tree9eabbfe8044976cffce6bdfb5635fd76496d3bd9 /media-video/arista/arista-0.9.3-r1.ebuild
parentVersion bump (diff)
downloadgentoo-2-77bf231a9d0b8bdb6229b63d27380786a27685ae.tar.gz
gentoo-2-77bf231a9d0b8bdb6229b63d27380786a27685ae.tar.bz2
gentoo-2-77bf231a9d0b8bdb6229b63d27380786a27685ae.zip
Use Python 2 (bug #313983).
(Portage version: 2.2.0_alpha26_p15/cvs/Linux x86_64)
Diffstat (limited to 'media-video/arista/arista-0.9.3-r1.ebuild')
-rw-r--r--media-video/arista/arista-0.9.3-r1.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/media-video/arista/arista-0.9.3-r1.ebuild b/media-video/arista/arista-0.9.3-r1.ebuild
index 5ec9d82d9332..e50c4abc48bc 100644
--- a/media-video/arista/arista-0.9.3-r1.ebuild
+++ b/media-video/arista/arista-0.9.3-r1.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/arista/arista-0.9.3-r1.ebuild,v 1.6 2011/02/01 05:48:04 ford_prefect Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/arista/arista-0.9.3-r1.ebuild,v 1.7 2011/03/11 20:21:19 arfrever Exp $
-EAPI=2
+EAPI="3"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="xml"
inherit distutils
@@ -19,8 +21,7 @@ KEYWORDS="amd64 x86"
IUSE="+faac +xvid"
DEPEND="dev-python/setuptools"
-RDEPEND="dev-lang/python[xml]
- >=x11-libs/gtk+-2.16
+RDEPEND=">=x11-libs/gtk+-2.16
>=dev-python/pygtk-2.14
dev-python/pygobject
dev-python/pycairo
@@ -36,7 +37,14 @@ RDEPEND="dev-lang/python[xml]
faac? ( media-plugins/gst-plugins-faac:0.10 )
xvid? ( media-plugins/gst-plugins-xvid:0.10 )"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
pkg_postinst() {
+ distutils_pkg_postinst
+
einfo "If you find that a format you want is not supported in Arista,"
einfo "please make sure that you have the corresponding USE-flag enabled"
einfo "media-plugins/gst-plugins-meta"