summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-03-16 11:22:50 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-03-16 11:22:50 +0000
commit39877d29d38049489f936ecc736cc4f5b153aa21 (patch)
tree72e21413062449634ab86cae3365a60c09a6cf0f /media-video/avidemux
parentmigration revbump (diff)
downloadgentoo-2-39877d29d38049489f936ecc736cc4f5b153aa21.tar.gz
gentoo-2-39877d29d38049489f936ecc736cc4f5b153aa21.tar.bz2
gentoo-2-39877d29d38049489f936ecc736cc4f5b153aa21.zip
Version bump to 2.6.2 where I revised the way it builds using separated core libraries, should work properly. Removed old versions that had a broken intermediate build system. Removed some unused things, fixed a QA warning and more...
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'media-video/avidemux')
-rw-r--r--media-video/avidemux/ChangeLog11
-rw-r--r--media-video/avidemux/avidemux-2.6.0.ebuild192
-rw-r--r--media-video/avidemux/avidemux-2.6.2.ebuild (renamed from media-video/avidemux/avidemux-2.6.1.ebuild)115
-rw-r--r--media-video/avidemux/metadata.xml1
4 files changed, 34 insertions, 285 deletions
diff --git a/media-video/avidemux/ChangeLog b/media-video/avidemux/ChangeLog
index 3dfa6158c398..315a30fa0f9a 100644
--- a/media-video/avidemux/ChangeLog
+++ b/media-video/avidemux/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-video/avidemux
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/avidemux/ChangeLog,v 1.208 2013/03/11 12:41:18 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/avidemux/ChangeLog,v 1.209 2013/03/16 11:22:50 tomwij Exp $
+
+*avidemux-2.6.2 (16 Mar 2013)
+
+ 16 Mar 2013; Tom Wijsman <TomWij@gentoo.org> +avidemux-2.6.2.ebuild,
+ -avidemux-2.6.0.ebuild, -avidemux-2.6.1.ebuild, metadata.xml:
+ Version bump to 2.6.2 where I revised the way it builds using separated core
+ libraries, should work properly. Removed old versions that had a broken
+ intermediate build system. Removed some unused things, fixed a QA warning and
+ more...
11 Mar 2013; Tom Wijsman <TomWij@gentoo.org> avidemux-2.6.1.ebuild:
Fixed conversion from IUSE flags to cmake arguments to support USE flags that
diff --git a/media-video/avidemux/avidemux-2.6.0.ebuild b/media-video/avidemux/avidemux-2.6.0.ebuild
deleted file mode 100644
index 70b94adfb275..000000000000
--- a/media-video/avidemux/avidemux-2.6.0.ebuild
+++ /dev/null
@@ -1,192 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/avidemux/avidemux-2.6.0.ebuild,v 1.2 2013/03/02 22:06:56 hwoarang Exp $
-
-EAPI=4
-PLOCALES="ca cs de el es fr it ja pt_BR ru sr sr@latin tr"
-inherit cmake-utils eutils flag-o-matic l10n toolchain-funcs
-
-MY_P=${PN}_${PV}
-
-DESCRIPTION="Video editor designed for simple cutting, filtering and encoding tasks"
-HOMEPAGE="http://fixounet.free.fr/avidemux"
-SRC_URI="mirror://sourceforge/${PN}/${PV}/${MY_P}.tar.gz"
-
-# Multiple licenses because of all the bundled stuff
-LICENSE="GPL-2 MIT GPL-1 public-domain PSF-2"
-SLOT="2.6"
-KEYWORDS="~amd64 ~x86"
-IUSE="aften a52 alsa amr debug dts fontconfig gtk jack
- lame libsamplerate mmx nls qt4 sdl vorbis truetype xvid xv oss x264"
-
-RDEPEND="
- virtual/libiconv
- dev-libs/libxml2
- media-libs/libpng
- >=dev-lang/spidermonkey-1.5-r2
- gtk? ( >=x11-libs/gtk+-2.6.0:2 )
- qt4? ( >=dev-qt/qtgui-4.8.3:4 )
- x264? ( media-libs/x264 )
- xvid? ( media-libs/xvid )
- aften? ( media-libs/aften )
- amr? ( media-libs/opencore-amr )
- lame? ( media-sound/lame )
- dts? ( media-libs/libdca )
- vorbis? ( media-libs/libvorbis )
- alsa? ( >=media-libs/alsa-lib-1.0.3b-r2 )
- jack? (
- media-sound/jack-audio-connection-kit
- libsamplerate? ( media-libs/libsamplerate )
- )
- truetype? ( >=media-libs/freetype-2.1.5 )
- fontconfig? ( media-libs/fontconfig )
- sdl? ( media-libs/libsdl )
- xv? ( x11-libs/libXv )
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXrender
-"
-DEPEND="
- $RDEPEND
- oss? ( virtual/os-headers )
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
-"
-S=${WORKDIR}/${MY_P}
-BUILD_S=${WORKDIR}/${P}_build
-
-avidemux_build_process() {
- local BUILDDIR="${1}"
- local SOURCEDIR="${2}"
- local mycmakeargs="${3}"
- EXTRA="${mycmakeargs}"
- BUILDER="Unix Makefiles"
- FAKEROOT_DIR="${S}"/gentoo-install
- SOURCEDIR="${2}"
- mkdir ${BUILDDIR} && cd "${BUILDDIR}"
- einfo "Configuring: ${BUILDDIR}"
- cmake -DFAKEROOT="${FAKEROOT_DIR}" -DAVIDEMUX_SOURCE_DIR="${S}" \
- -DCMAKE_INSTALL_PREFIX="/usr" \
- ${EXTRA} -G "${BUILDER}" ../"${SOURCEDIR}/"
- # for some reason, core needs -j1. That's what they do in their
- # script as well
- if [[ ${BUILDDIR} == "buildCore" ]]; then
- extra_opts="-j1"
- else
- unset extra_opts
- fi
- einfo "Building: ${BUILDDIR}"
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" ${extra_opts}
-
- einfo "Fake install: ${BUILDDIR}"
- # pretend that you installed it somewhere
- emake DESTDIR="${FAKEROOT_DIR}" ${extra_opts} install
-
- cd ..
-}
-
-src_prepare() {
- base_src_prepare
-
- # TODO: convert to l10n.eclass usage
- local lingua= po_files= qt_ts_files= avidemux_ts_files=
- for lingua in ${LINGUAS}; do
- if has ${lingua} ${AVIDEMUX_LANGS}; then
- if [[ -e ${S}/po/${lingua}.po ]]; then
- po_files+=" \${po_subdir}/${lingua}.po"
- fi
- if [[ -e ${S}/po/qt_${lingua}.ts ]]; then
- qt_ts_files+=" \${ts_subdir}/qt_${lingua}.ts"
- fi
- if [[ -e ${S}/po/${PN}_${lingua}.ts ]]; then
- avidemux_ts_files+=" \${ts_subdir}/${PN}_${lingua}.ts"
- fi
- fi
- done
-
- sed -i -e "s!FILE(GLOB po_files .*)!SET(po_files ${po_files})!" \
- "${S}/cmake/Po.cmake" || die "sed failed"
- sed -i -e "s!FILE(GLOB.*qt.*)!SET(ts_files ${qt_ts_files})!" \
- -e "s!FILE(GLOB.*avidemux.*)!SET(ts_files ${avidemux_ts_files})!" \
- "${S}/cmake/Ts.cmake" || die "sed failed"
-
- # Fix icon name -> avidemux-2.6.png
- sed -i -e "/^Icon/ s:${PN}:${PN}-2.6:" ${PN}2.desktop || die
- # the desktop file is broken. It uses avidemux2 instead of avidemux3
- # so it will actually launch avidemux-2.5 if it is installed
- sed -i -e "/^Exec/ s:${PN}2:${PN}3:" ${PN}2.desktop || die
- # Now rename to not collide with 2.5
- mv ${PN}2.desktop ${PN}-2.6.desktop
- # fix major issues in desktop files wrt bugs #291453, #316599, #430500
- # duplicate desktop file
- cp ${PN}-2.6.desktop ${PN}-2.6-gtk.desktop || die
- # the desktop file is broken. It uses avidemux2 instead of avidemux3
- # so it will actually launch avidemux-2.5 if it is installed
- sed -i -re '/^Exec/ s:(avidemux3_)gtk:\1qt4:' ${PN}-2.6.desktop || die
-}
-
-src_configure() {
- true;
-}
-
-src_compile() {
- # add lax vector typing for PowerPC
- if use ppc || use ppc64; then
- append-cflags -flax-vector-conversions
- fi
- # bug 432322
- use x86 && replace-flags -O0 -O1
-
- local x mycmakeargs
- # default args
- use debug \
- && POSTFIX="_debug" \
- && mycmakeargs+="-DVERBOSE=1 -DCMAKE_BUILD_TYPE=Debug"
-
- mycmakeargs="
- $(for x in ${IUSE}; do cmake-utils_use $x; done)
- $(cmake-utils_use dts LIBDCA)
- $(cmake-utils_use truetype FREETYPE2)
- $(cmake-utils_use nls GETTEXT)
- $(cmake-utils_use xv XVIDEO)
- $(cmake-utils_use amr OPENCORE_AMRWB)
- $(cmake-utils_use amr OPENCORE_AMRNB)
- "
-
- # Lets try to do all the s**t that bootStrap.bash is
- # trying to do
- use qt4 && with_qt4=1
- use gtk && with_gtk=1
-
- avidemux_build_process buildCore avidemux_core${POSTFIX} "${mycmakeargs}"
- avidemux_build_process buildCli avidemux/cli${POSTFIX} "${mycmakeargs}"
- mycmakeargs+="-DPLUGIN_UI=COMMON "
- avidemux_build_process buildPluginsCommon avidemux_plugins${POSTFIX} "${mycmakeargs}"
- mycmakeargs+="-DPLUGIN_UI=CLI "
- avidemux_build_process buildPluginsCLI avidemux_plugins${POSTFIX} "${mycmakeargs}"
-
- if use qt4; then
- avidemux_build_process buildQt4 avidemux/qt4${POSTFIX} "${mycmakeargs}"
- mycmakeargs+="-DPLUGIN_UI=QT4 "
- avidemux_build_process buildPluginsQt4 avidemux_plugins${POSTFIX} "${mycmakeargs}"
- fi
- if use gtk; then
- avidemux_build_process buildGtk avidemux/gtk${POSTFIX} "${mycmakeargs}"
- mycmakeargs+="-DPLUGIN_UI=GTK "
- avidemux_build_process buildPluginsGtk avidemux_plugins${POSTFIX} "${mycmakeargs}"
- fi
-}
-
-src_install() {
- # everything is installed(?) in ${S}/gentoo-install.
- # Move it to ${D}.
- insinto /
- doins -r "${S}"/gentoo-install/*
- # Mark executables with +x
- find "${ED}"/usr/bin -exec chmod a+x {} \;
-
- newicon ${PN}_icon.png ${PN}-2.6.png
- use gtk && domenu ${PN}-2.6-gtk.desktop
- use qt4 && domenu ${PN}-2.6.desktop
- dodoc AUTHORS README
-}
diff --git a/media-video/avidemux/avidemux-2.6.1.ebuild b/media-video/avidemux/avidemux-2.6.2.ebuild
index 40c59a0e3d98..2dd906742255 100644
--- a/media-video/avidemux/avidemux-2.6.1.ebuild
+++ b/media-video/avidemux/avidemux-2.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/avidemux/avidemux-2.6.1.ebuild,v 1.5 2013/03/11 12:41:18 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/avidemux/avidemux-2.6.2.ebuild,v 1.1 2013/03/16 11:22:50 tomwij Exp $
EAPI="5"
@@ -10,90 +10,36 @@ inherit cmake-utils eutils flag-o-matic l10n toolchain-funcs
SLOT="2.6"
MY_P="${PN}_${PV}"
-DESCRIPTION="Video editor designed for simple cutting, filtering and encoding tasks"
+DESCRIPTION="Video editor designed for simple cutting, filtering and encoding tasks."
HOMEPAGE="http://fixounet.free.fr/${PN}"
SRC_URI="mirror://sourceforge/${PN}/${PV}/${MY_P}.tar.gz"
# Multiple licenses because of all the bundled stuff.
LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
KEYWORDS="~amd64 ~x86"
-IUSE="aften a52 alsa amr debug dts fontconfig gtk jack lame libsamplerate mmx oss nls qt4 sdl -system-ffmpeg vorbis truetype xvid x264 xv"
-
-RDEPEND="
- >=dev-lang/spidermonkey-1.5-r2
- dev-libs/libxml2
- media-libs/libpng
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXrender
- virtual/libiconv
- aften? ( media-libs/aften )
- alsa? ( >=media-libs/alsa-lib-1.0.3b-r2 )
- amr? ( media-libs/opencore-amr )
- dts? ( media-libs/libdca )
- fontconfig? ( media-libs/fontconfig )
+IUSE="aften a52 alsa amr debug dts fontconfig gtk jack lame libsamplerate mmx oss nls qt4 sdl vorbis truetype xvid x264 xv"
+
+# TODO: Figure out which dependencies can be moved out of avidemux-core into here.
+RDEPEND="=media-libs/avidemux-core-${PV}[aften?,a52?,alsa?,amr?,dts?,fontconfig?,jack?,lame?,libsamplerate?,mmx?,oss?,nls?,sdl?,vorbis?,truetype?,xvid?,x264?,xv?]
gtk? ( >=x11-libs/gtk+-2.6.0:2 )
- jack? (
- media-sound/jack-audio-connection-kit
- libsamplerate? ( media-libs/libsamplerate )
- )
- lame? ( media-sound/lame )
- qt4? ( >=dev-qt/qtgui-4.8.3:4 )
- sdl? ( media-libs/libsdl )
- system-ffmpeg? ( >=media-video/ffmpeg-1.0[aac,cpudetection,mp3,theora] )
- truetype? ( >=media-libs/freetype-2.1.5 )
- x264? ( media-libs/x264 )
- xv? ( x11-libs/libXv )
- xvid? ( media-libs/xvid )
- vorbis? ( media-libs/libvorbis )
-"
-DEPEND="
- $RDEPEND
- oss? ( virtual/os-headers )
- nls? ( sys-devel/gettext )
- virtual/pkgconfig
-"
+ qt4? ( >=dev-qt/qtgui-4.8.3:4 )"
+DEPEND="$RDEPEND"
S="${WORKDIR}/${MY_P}"
-BUILD_S="${WORKDIR}/${P}_build"
-PROCESSES="buildCore:avidemux_core${POSTFIX}
- buildCli:avidemux/cli${POSTFIX}
- buildPluginsCommon:avidemux_plugins${POSTFIX}
- buildPluginsCLI:avidemux_plugins${POSTFIX}"
+PROCESSES="buildCli:avidemux/cli
+ buildPluginsCommon:avidemux_plugins
+ buildPluginsCLI:avidemux_plugins"
-use qt4 && PROCESSES+=" buildQt4:avidemux/qt4${POSTFIX}
- buildPluginsQt4:avidemux_plugins${POSTFIX}"
+use qt4 && PROCESSES+=" buildQt4:avidemux/qt4
+ buildPluginsQt4:avidemux_plugins"
-use gtk && PROCESSES+=" buildGtk:avidemux/gtk${POSTFIX}
- buildPluginsGtk:avidemux_plugins${POSTFIX}"
+use gtk && PROCESSES+=" buildGtk:avidemux/gtk
+ buildPluginsGtk:avidemux_plugins"
src_prepare() {
base_src_prepare
- # TODO: convert to l10n.eclass usage
- local lingua= po_files= qt_ts_files= avidemux_ts_files=
- for lingua in ${LINGUAS}; do
- if has ${lingua} ${AVIDEMUX_LANGS}; then
- if [[ -e ${S}/po/${lingua}.po ]]; then
- po_files+=" \${po_subdir}/${lingua}.po"
- fi
- if [[ -e ${S}/po/qt_${lingua}.ts ]]; then
- qt_ts_files+=" \${ts_subdir}/qt_${lingua}.ts"
- fi
- if [[ -e ${S}/po/${PN}_${lingua}.ts ]]; then
- avidemux_ts_files+=" \${ts_subdir}/${PN}_${lingua}.ts"
- fi
- fi
- done
-
- sed -i -e "s!FILE(GLOB po_files .*)!SET(po_files ${po_files})!" \
- "${S}/cmake/Po.cmake" || die "po_files sed failed"
-
- sed -i -e "s!FILE(GLOB.*qt.*)!SET(ts_files ${qt_ts_files})!" \
- -e "s!FILE(GLOB.*avidemux.*)!SET(ts_files ${avidemux_ts_files})!" \
- "${S}/cmake/Ts.cmake" || die "ts_files sed failed"
-
# Fix icon name -> avidemux-2.6.png
sed -i -e "/^Icon/ s:${PN}:${PN}-2.6:" ${PN}2.desktop || die "Icon name fix failed."
@@ -112,13 +58,9 @@ src_prepare() {
# so it will actually launch avidemux-2.5 if it is installed.
sed -i -re '/^Exec/ s:(avidemux3_)gtk:\1qt4:' ${PN}-2.6.desktop || die "Desktop file fix failed."
- if use system-ffmpeg ; then
- rm -rf cmake/admFFmpeg* cmake/ffmpeg* avidemux_core/ffmpeg_package buildCore/ffmpeg || die "Failed to remove ffmpeg."
-
- sed -i -e 's/include(admFFmpegUtil)//g' avidemux/commonCmakeApplication.cmake || die "Failed to remove ffmpeg."
- sed -i -e '/registerFFmpeg/d' avidemux/commonCmakeApplication.cmake || die "Failed to remove ffmpeg."
- sed -i -e 's/include(admFFmpegBuild)//g' avidemux_core/CMakeLists.txt || die "Failed to remove ffmpeg."
- fi
+ # Fix QA warnings that complain a trailing ; is missing and Application is deprecated.
+ sed -i -e 's/Application;AudioVideo/AudioVideo;/g' ${PN}-2.6.desktop
+ sed -i -e 's/Application;AudioVideo/AudioVideo;/g' ${PN}-2.6-gtk.desktop
}
src_configure() {
@@ -139,9 +81,8 @@ src_configure() {
SOURCE="${PROCESS%%:*}"
DEST="${PROCESS#*:}"
- cd "${S}" || die "Can't enter source folder."
- mkdir "${SOURCE}" || die "Can't create build folder."
- cd "${SOURCE}" || die "Can't enter build folder."
+ mkdir "${S}"/${SOURCE} || die "Can't create build folder."
+ cd "${S}"/${SOURCE} || die "Can't enter build folder."
if [[ "${SOURCE}" == "buildPluginsCommon" ]] ; then
plugin_ui="-DPLUGIN_UI=COMMON"
@@ -155,7 +96,7 @@ src_configure() {
cmake -DAVIDEMUX_SOURCE_DIR="${S}" \
-DCMAKE_INSTALL_PREFIX="/usr" \
- ${mycmakeargs} ${plugin_ui} -G "Unix Makefiles" ../"${DEST}/"
+ ${mycmakeargs} ${plugin_ui} -G "Unix Makefiles" ../"${DEST}${POSTFIX}/" || die "cmake failed."
done
}
@@ -172,13 +113,7 @@ src_compile() {
SOURCE="${PROCESS%%:*}"
cd "${S}/${SOURCE}" || die "Can't enter build folder."
-
- if [[ "${SOURCE}" == "buildCore" ]] ; then
- # TODO: Report this upstream, seems to be within ffmpeg code.
- emake -j1 CC="$(tc-getCC)" CXX="$(tc-getCXX)"
- else
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)"
- fi
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)"
done
}
@@ -187,10 +122,8 @@ src_install() {
SOURCE="${PROCESS%%:*}"
cd "${S}/${SOURCE}" || die "Can't enter build folder."
-
- if [[ "${SOURCE}" == "buildCore" ]] ; then
- # TODO: Report this upstream, seems to be within ffmpeg code.
- emake DESTDIR="${ED}" -j1 install
+ if [[ "${SOURCE}" == "buildPluginsCLI" || "${SOURCE}" == "buildPluginsQt4" || "${SOURCE}" == "buildPluginsGtk" ]] ; then
+ emake DESTDIR="${ED}" preinstall
else
emake DESTDIR="${ED}" install
fi
diff --git a/media-video/avidemux/metadata.xml b/media-video/avidemux/metadata.xml
index 8002939d58ff..f4aa850387b7 100644
--- a/media-video/avidemux/metadata.xml
+++ b/media-video/avidemux/metadata.xml
@@ -9,7 +9,6 @@
<use>
<flag name="aften">Enable A/52 (AC-3) audio encoder support</flag>
<flag name="amr">Enable Adaptive Multi-Rate format support via <pkg>media-libs/opencore-amr</pkg></flag>
- <flag name="system-ffmpeg">Use the ffmpeg provided by the system.</flag>
<flag name="vpx">Enable VP8 codec support via <pkg>media-libs/libvpx</pkg></flag>
</use>
</pkgmetadata>