summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-04-29 03:57:12 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-04-29 03:57:12 +0000
commite92c7928d9b156aaedfb2c8b53a36f761b8731e4 (patch)
treed466edcfb7ffaa4e0476c165cbe0a2bb7af65a6a /media-video/avifile
parentunmasked directfb (diff)
downloadgentoo-2-e92c7928d9b156aaedfb2c8b53a36f761b8731e4.tar.gz
gentoo-2-e92c7928d9b156aaedfb2c8b53a36f761b8731e4.tar.bz2
gentoo-2-e92c7928d9b156aaedfb2c8b53a36f761b8731e4.zip
should be --without-qt instead of --disable-qt
Diffstat (limited to 'media-video/avifile')
-rw-r--r--media-video/avifile/ChangeLog11
-rw-r--r--media-video/avifile/avifile-0.7.3.20020419-r1.ebuild87
-rw-r--r--media-video/avifile/files/digest-avifile-0.7.3.20020419-r11
3 files changed, 98 insertions, 1 deletions
diff --git a/media-video/avifile/ChangeLog b/media-video/avifile/ChangeLog
index 099a5dd926f5..643135d2ce4a 100644
--- a/media-video/avifile/ChangeLog
+++ b/media-video/avifile/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-video/avifile
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/ChangeLog,v 1.10 2002/04/24 21:09:12 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/ChangeLog,v 1.11 2002/04/29 03:57:12 mkennedy Exp $
+
+*avifile-0.7.3.20020419-r1 (28 Apr 2002)
+
+ 28 Apr 2002; Matthew Kennedy <mkennedy@gentoo.org>
+ avifile-0.7.3.20020419-r1.ebuild, ChangeLog,
+ files/digest-avifile-0.7.3.20020419-r1 :
+
+ Should be --without-qt instead of --disable-qt (only users without
+ qt installed will see this produce a fatal error).
avifile-0.7.3.20020419 (24 Apr 2002)
diff --git a/media-video/avifile/avifile-0.7.3.20020419-r1.ebuild b/media-video/avifile/avifile-0.7.3.20020419-r1.ebuild
new file mode 100644
index 000000000000..35902843d9bf
--- /dev/null
+++ b/media-video/avifile/avifile-0.7.3.20020419-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/avifile-0.7.3.20020419-r1.ebuild,v 1.1 2002/04/29 03:57:12 mkennedy Exp $
+
+MY_P=${P/.200/-200}
+MY_S=${P/avifile-/avifile}
+MY_S=${MY_S/.3.200/-200}
+S=${WORKDIR}/${MY_S}
+DESCRIPTION="Library for AVI-Files"
+SRC_URI="http://avifile.sourceforge.net/${MY_P}.tgz"
+HOMEPAGE="http://avifile.sourceforge.net/"
+
+DEPEND=">=media-libs/divx4linux-20011025
+ media-libs/jpeg
+ media-libs/win32codecs
+ qt? ( x11-libs/qt )
+ nas? ( >=media-libs/nas-1.4.2 )
+ sdl? ( >=media-libs/libsdl-1.2.2 )
+ oggvorbis? ( media-libs/libvorbis )"
+
+
+src_compile() {
+
+ einfo "${S}"
+
+ local myconf
+ local kdepre
+
+ use mmx && myconf="--enable-x86opt"
+ use sse && myconf="--enable-x86opt"
+ use 3dnow && myconf="--enable-x86opt"
+
+ use qt \
+ && myconf="${myconf} --with-qt-dir=${QTDIR}" \
+ || myconf="${myconf} --without-qt"
+
+ use kde \
+ && myconf="${myconf} --enable-kde" \
+ || myconf="${myconf} --disable-kde"
+
+ use sdl \
+ && myconf="${myconf} --enable-sdl" \
+ || myconf="${myconf} --disable-sdl --disable-sdltest"
+
+ use nas && LDFLAGS="-L/usr/X11R6/lib -lXt"
+
+ use oggvorbis \
+ && myconf="${myconf} --enable-vorbis" \
+ || myconf="${myconf} --disable-vorbis --disable-oggtest --disable-vorbistest"
+
+ use kde \
+ && ( \
+ myconf="${myconf} --enable-kde" \
+ && LDFLAGS="${LDFLAGS} -L${KDEDIR}/lib" \
+ && myconf="${myconf} --with-extra-libraries=${KDEDIR}" \
+ ) || (
+ myconf="${myconf} --disable-kde" \
+ && LDFLAGS="${LDFLAGS}"
+ )
+
+
+ export CFLAGS=${CFLAGS/-O?/-O2}
+ export LDFLAGS
+ ./configure --prefix=/usr \
+ --host=${CHOST} \
+ --enable-quiet \
+ --disable-tsc \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install () {
+
+ dodir /usr/lib /usr/bin
+ use avi && dodir /usr/lib/win32
+
+ make prefix=${D}/usr install || die
+
+ cd ${S}
+ dodoc COPYING README
+ cd doc
+ dodoc CREDITS EXCEPTIONS FreeBSD LICENSING TODO
+ dodoc VIDEO-PERFORMANCE WARNINGS
+}
+
diff --git a/media-video/avifile/files/digest-avifile-0.7.3.20020419-r1 b/media-video/avifile/files/digest-avifile-0.7.3.20020419-r1
new file mode 100644
index 000000000000..093792c524e3
--- /dev/null
+++ b/media-video/avifile/files/digest-avifile-0.7.3.20020419-r1
@@ -0,0 +1 @@
+MD5 a7a1084621ad2702280a9c8796f7850d avifile-0.7.3-20020419.tgz 2145961