summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-08-17 06:33:10 +0000
committerTim Harder <radhermit@gentoo.org>2011-08-17 06:33:10 +0000
commit02e7e57084414a5e4ef7c7bbc7dcfda4694269ef (patch)
tree7c07e56515b89124422187cb5bccd24bfab9d7ee /media-video/clive
parentVersion bump (diff)
downloadgentoo-2-02e7e57084414a5e4ef7c7bbc7dcfda4694269ef.tar.gz
gentoo-2-02e7e57084414a5e4ef7c7bbc7dcfda4694269ef.tar.bz2
gentoo-2-02e7e57084414a5e4ef7c7bbc7dcfda4694269ef.zip
Version bump. Use substrings instead of versionator eclass and bump to EAPI 4.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'media-video/clive')
-rw-r--r--media-video/clive/ChangeLog8
-rw-r--r--media-video/clive/clive-2.2.26.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/media-video/clive/ChangeLog b/media-video/clive/ChangeLog
index d611f5a6af66..59e27dd9a388 100644
--- a/media-video/clive/ChangeLog
+++ b/media-video/clive/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/clive
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.69 2011/05/04 17:15:58 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.70 2011/08/17 06:33:10 radhermit Exp $
+
+*clive-2.2.26 (17 Aug 2011)
+
+ 17 Aug 2011; Tim Harder <radhermit@gentoo.org> +clive-2.2.26.ebuild:
+ Version bump. Use substrings instead of versionator eclass and bump to EAPI
+ 4.
*clive-2.2.25 (04 May 2011)
diff --git a/media-video/clive/clive-2.2.26.ebuild b/media-video/clive/clive-2.2.26.ebuild
new file mode 100644
index 000000000000..d68c26784406
--- /dev/null
+++ b/media-video/clive/clive-2.2.26.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/clive-2.2.26.ebuild,v 1.1 2011/08/17 06:33:10 radhermit Exp $
+
+EAPI=4
+
+inherit perl-app
+
+DESCRIPTION="Command line tool for extracting videos from various websites"
+HOMEPAGE="http://clive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PV:0:3}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="clipboard pager password test"
+
+RDEPEND=">=dev-perl/BerkeleyDB-0.34
+ >=dev-perl/Config-Tiny-2.12
+ >=virtual/perl-Digest-SHA-5.47
+ >=dev-perl/HTML-TokeParser-Simple-2.37
+ >=dev-perl/Class-Singleton-1.4
+ >=dev-perl/WWW-Curl-4.05
+ >=dev-perl/XML-Simple-2.18
+ >=dev-perl/Getopt-ArgvFile-1.11
+ dev-perl/URI
+ virtual/perl-Getopt-Long
+ virtual/perl-File-Spec
+ clipboard? ( >=dev-perl/Clipboard-0.09 )
+ pager? ( >=dev-perl/IO-Pager-0.05 )
+ password? ( >=dev-perl/Expect-1.21 )"
+DEPEND="test? ( dev-perl/Test-Pod
+ ${RDEPEND} )"
+
+SRC_TEST=do
+mydoc="NEWS"
+
+src_test() {
+ if [ -z "${I_WANT_CLIVE_HOSTS_TESTS}" ] ; then
+ elog "If you wish to run the full testsuite of ${PN}"
+ elog "Please set the variable 'I_WANT_CLIVE_HOSTS_TESTS' variable"
+ elog "Note that the tests try to download some videos from various websites"
+ elog "and thus may randomly fail depending on the site's status."
+ export NO_INTERNET=1
+ fi
+ perl-module_src_test
+}