summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-08-30 17:00:11 +0000
committerSamuli Suominen <drac@gentoo.org>2007-08-30 17:00:11 +0000
commit378a55b458910307e18f541183743975255a6738 (patch)
tree19a4adf996dbc2b03d6e313876dddb80b24c11fb /media-video/kaffeine/files
parentCompilation fix for python versions other than 2.4 (diff)
downloadgentoo-2-378a55b458910307e18f541183743975255a6738.tar.gz
gentoo-2-378a55b458910307e18f541183743975255a6738.tar.bz2
gentoo-2-378a55b458910307e18f541183743975255a6738.zip
Punt unused version. Remove USE gstreamer from another. GStreamer 0.8 is going away.
(Portage version: 2.1.3.7)
Diffstat (limited to 'media-video/kaffeine/files')
-rw-r--r--media-video/kaffeine/files/digest-kaffeine-0.7.1-r23
-rw-r--r--media-video/kaffeine/files/kaffeine-0.7.1-input-http.patch92
-rw-r--r--media-video/kaffeine/files/kaffeine-0.7.1-respectflags.patch22
-rw-r--r--media-video/kaffeine/files/kaffeine-0.7.1-systemproto.patch11
-rw-r--r--media-video/kaffeine/files/kaffeine-0.7.1-xinerama.patch22
5 files changed, 0 insertions, 150 deletions
diff --git a/media-video/kaffeine/files/digest-kaffeine-0.7.1-r2 b/media-video/kaffeine/files/digest-kaffeine-0.7.1-r2
deleted file mode 100644
index 21e82a1a8d49..000000000000
--- a/media-video/kaffeine/files/digest-kaffeine-0.7.1-r2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 afde61516eb8f6cf2c3bf085a22ef427 kaffeine-0.7.1.tar.bz2 2276747
-RMD160 b609bc47dd7cc11753c016bf0da3214f54fa8df0 kaffeine-0.7.1.tar.bz2 2276747
-SHA256 7e2611ba4fb4cc5b6a1802250a5c404b22cca434ce1d3bbe83088f6189bfa145 kaffeine-0.7.1.tar.bz2 2276747
diff --git a/media-video/kaffeine/files/kaffeine-0.7.1-input-http.patch b/media-video/kaffeine/files/kaffeine-0.7.1-input-http.patch
deleted file mode 100644
index 796d07c18a4e..000000000000
--- a/media-video/kaffeine/files/kaffeine-0.7.1-input-http.patch
+++ /dev/null
@@ -1,92 +0,0 @@
-Index: kaffeine/kaffeine/player-parts/http.c
-===================================================================
---- kaffeine/kaffeine/player-parts/http.c (revision 521094)
-+++ kaffeine/kaffeine/player-parts/http.c (working copy)
-@@ -308,7 +308,7 @@ static http_t *http_open (const char *mr
-
- http_t *this;
- char *proxy;
-- int done,len,linenum;
-+ int done,len,linenum,buflen;
- char mime_type[BUFSIZE+1];
-
- this = malloc (sizeof (http_t));
-@@ -362,13 +362,13 @@ static http_t *http_open (const char *mr
- {
- char buf[256];
-
-- sprintf (buf, "http: opening >/%s< on host >%s<",
-+ snprintf (buf, sizeof(buf), "http: opening >/%s< on host >%s<",
- this->filename, this->host);
-
- if (proxy != NULL)
-- sprintf(buf, "%s via proxy >%s<", buf, this->proxyhost);
-+ snprintf(buf, sizeof(buf), "%s via proxy >%s<", buf, this->proxyhost);
-
-- sprintf(buf, "%s\n", buf);
-+ snprintf(buf, sizeof(buf), "%s\n", buf);
-
- printf (buf);
- }
-@@ -389,35 +389,42 @@ static http_t *http_open (const char *mr
-
- if (proxy != NULL)
- if (this->port != DEFAULT_HTTP_PORT)
-- sprintf (this->buf, "GET http://%s:%d/%s HTTP/1.0\015\012",
-- this->host, this->port, this->filename);
-+ snprintf (this->buf, BUFSIZE, "GET http://%s:%d/%s HTTP/1.0\015\012",
-+ this->host, this->port, this->filename);
- else
-- sprintf (this->buf, "GET http://%s/%s HTTP/1.0\015\012",
-- this->host, this->filename);
-+ snprintf (this->buf, BUFSIZE, "GET http://%s/%s HTTP/1.0\015\012",
-+ this->host, this->filename);
- else
-- sprintf (this->buf, "GET /%s HTTP/1.0\015\012", this->filename);
-+ snprintf (this->buf, BUFSIZE, "GET /%s HTTP/1.0\015\012", this->filename);
-
-+ buflen = strlen(this->buf);
- if (this->port != DEFAULT_HTTP_PORT)
-- sprintf (this->buf + strlen(this->buf), "Host: %s:%d\015\012",
-- this->host, this->port);
-+ snprintf (this->buf + buflen, BUFSIZE - buflen, "Host: %s:%d\015\012",
-+ this->host, this->port);
- else
-- sprintf (this->buf + strlen(this->buf), "Host: %s\015\012",
-- this->host);
-+ snprintf (this->buf + buflen, BUFSIZE - buflen, "Host: %s\015\012",
-+ this->host);
-
-- if (this->proxyuser != NULL)
-- sprintf (this->buf + strlen(this->buf), "Proxy-Authorization: Basic %s\015\012",
-- this->proxyauth);
-+ buflen = strlen(this->buf);
-+ if (this->proxyuser != NULL) {
-+ snprintf (this->buf + buflen, BUFSIZE - buflen, "Proxy-Authorization: Basic %s\015\012",
-+ this->proxyauth);
-+ buflen = strlen(this->buf);
-+ }
-
-- if (this->user != NULL)
-- sprintf (this->buf + strlen(this->buf), "Authorization: Basic %s\015\012",
-- this->auth);
-+ if (this->user != NULL) {
-+ snprintf (this->buf + buflen, BUFSIZE - buflen, "Authorization: Basic %s\015\012",
-+ this->auth);
-+ buflen = strlen(this->buf);
-+ }
-
-- sprintf (this->buf + strlen(this->buf), "User-Agent: xine/%s\015\012",
-+ snprintf (this->buf + buflen, BUFSIZE - buflen, "User-Agent: xine/%s\015\012",
- VERSION);
-
-- strcat (this->buf, "Accept: */*\015\012");
--
-- strcat (this->buf, "\015\012");
-+ buflen = strlen(this->buf);
-+ snprintf (this->buf + buflen, BUFSIZE - buflen, "Accept: */*\015\012");
-+ buflen = strlen(this->buf);
-+ snprintf (this->buf + buflen, BUFSIZE - buflen, "\015\012");
-
- if (write (this->fh, this->buf, strlen(this->buf)) != (ssize_t)strlen(this->buf)) {
- free (this);
diff --git a/media-video/kaffeine/files/kaffeine-0.7.1-respectflags.patch b/media-video/kaffeine/files/kaffeine-0.7.1-respectflags.patch
deleted file mode 100644
index 91037f61eaae..000000000000
--- a/media-video/kaffeine/files/kaffeine-0.7.1-respectflags.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: kaffeine-0.7.1/configure.in.in
-===================================================================
---- kaffeine-0.7.1.orig/configure.in.in
-+++ kaffeine-0.7.1/configure.in.in
-@@ -13,7 +13,7 @@ AC_ARG_WITH(xinit-workaround,
-
- dnl ----- Checks for X11 extensions -----
- ac_save_ldflags="$LDFLAGS"
--LDFLAGS="$X_LDFLAGS"
-+LDFLAGS="${LDFLAGS} $X_LDFLAGS"
-
- dnl ---------------------------------------------
- dnl Check for Xtest-Extension
-@@ -36,6 +36,8 @@ AC_CHECK_LIB(Xinerama, XineramaQueryExte
- $X_LIBS $X_PRE_LIBS -lXext $X_EXTRA_LIBS)
- AM_CONDITIONAL(HAVE_XINERAMA, test x$ac_have_xinerama = "xyes")
-
-+LDFLAGS="${ac_save_ldflags}"
-+
- dnl ---------------------------------------------
- dnl Check for xine-lib
- dnl ---------------------------------------------
diff --git a/media-video/kaffeine/files/kaffeine-0.7.1-systemproto.patch b/media-video/kaffeine/files/kaffeine-0.7.1-systemproto.patch
deleted file mode 100644
index c97da5b4ea96..000000000000
--- a/media-video/kaffeine/files/kaffeine-0.7.1-systemproto.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- kaffeine-0.7.1/kaffeine/kaffeineapp.cpp.orig 2005-08-28 16:19:27.000000000 +0100
-+++ kaffeine-0.7.1/kaffeine/kaffeineapp.cpp 2006-01-03 15:29:02.436692994 +0000
-@@ -95,7 +95,7 @@
- QString device = args->getOption("device");
- if (device == "default")
- device = QString::null;
-- else if (device.startsWith("media:/"))
-+ else if (device.startsWith("media:/") || device.startsWith("system:/"))
- {
- KURL devicePath(device);
- DCOPRef mediamanager("kded","mediamanager");
diff --git a/media-video/kaffeine/files/kaffeine-0.7.1-xinerama.patch b/media-video/kaffeine/files/kaffeine-0.7.1-xinerama.patch
deleted file mode 100644
index 9fc37002f9d1..000000000000
--- a/media-video/kaffeine/files/kaffeine-0.7.1-xinerama.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: kaffeine/configure.in.in
-===================================================================
---- kaffeine/configure.in.in (revision 497089)
-+++ kaffeine/configure.in.in (working copy)
-@@ -26,11 +26,16 @@
- dnl
- dnl Checks for Xinerama extension
- dnl
--AC_CHECK_LIB(Xinerama, XineramaQueryExtension,
-+AC_ARG_WITH([xinerama],
-+ AS_HELP_STRING([--without-xinerama], [Disable xinerama support (defaut: check)]))
-+
-+if test "x$with_xinerama" != "xno"; then
-+ AC_CHECK_LIB(Xinerama, XineramaQueryExtension,
- X_PRE_LIBS="$X_PRE_LIBS -lXinerama"
- AC_DEFINE(HAVE_XINERAMA,,[Define this if you have libXinerama installed])
- ac_have_xinerama="yes",,
- $X_LIBS $X_PRE_LIBS -lXext $X_EXTRA_LIBS)
-+fi
- AM_CONDITIONAL(HAVE_XINERAMA, test x$ac_have_xinerama = "xyes")
-
- dnl ---------------------------------------------