summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-04 13:23:00 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-04 13:23:00 +0000
commitc7fa3a0cd793fb644baa36d4bd72f9317a8802f1 (patch)
tree5a85bd08d04e72f9b1715e087d50e8c0cc899527 /media-video/kaffeine/kaffeine-0.7.1-r2.ebuild
parentversion bump (diff)
downloadgentoo-2-c7fa3a0cd793fb644baa36d4bd72f9317a8802f1.tar.gz
gentoo-2-c7fa3a0cd793fb644baa36d4bd72f9317a8802f1.tar.bz2
gentoo-2-c7fa3a0cd793fb644baa36d4bd72f9317a8802f1.zip
Add kaffeine with a fix for HTTP input.
(Portage version: 2.1_pre7-r4)
Diffstat (limited to 'media-video/kaffeine/kaffeine-0.7.1-r2.ebuild')
-rw-r--r--media-video/kaffeine/kaffeine-0.7.1-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-video/kaffeine/kaffeine-0.7.1-r2.ebuild b/media-video/kaffeine/kaffeine-0.7.1-r2.ebuild
new file mode 100644
index 000000000000..6ecf8c75a136
--- /dev/null
+++ b/media-video/kaffeine/kaffeine-0.7.1-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/kaffeine/kaffeine-0.7.1-r2.ebuild,v 1.1 2006/04/04 13:23:00 flameeyes Exp $
+
+inherit eutils kde
+
+DESCRIPTION="Media player for KDE using xine and gstreamer backends."
+HOMEPAGE="http://kaffeine.sourceforge.net/"
+SRC_URI="mirror://sourceforge/kaffeine/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86"
+IUSE="dvb gstreamer xinerama"
+
+RDEPEND="|| ( x11-base/xorg-server
+ >=x11-base/xorg-x11-6.8.0-r4 )
+ >=media-libs/xine-lib-1
+ gstreamer? ( =media-libs/gstreamer-0.8*
+ =media-libs/gst-plugins-0.8* )
+ xinerama? ( || ( x11-libs/libXinerama virtual/x11 ) )"
+
+DEPEND="${RDEPEND}
+ xinerama? ( || ( x11-proto/xineramaproto virtual/x11 ) )
+ dvb? ( >=sys-kernel/linux-headers-2.6 )
+ dev-util/pkgconfig"
+
+# the dependency on xorg-x11 is meant to avoid bug #59746
+
+PATCHES="${FILESDIR}/${P}-systemproto.patch
+ ${FILESDIR}/${P}-xinerama.patch
+ ${FILESDIR}/${P}-respectflags.patch
+ ${FILESDIR}/${P}-input-http.patch"
+
+need-kde 3.2
+
+src_compile() {
+ rm ${S}/configure
+
+ myconf="${myconf}
+ $(use_with xinerama)
+ $(use_with dvb)
+ $(use_with gstreamer)"
+
+ kde_src_compile
+}