summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Gurr <tgurr@gentoo.org>2008-01-22 06:23:20 +0000
committerTimo Gurr <tgurr@gentoo.org>2008-01-22 06:23:20 +0000
commitb5f26b3aaa4d4e7b99f9587fde9cb59cb2d03bc2 (patch)
tree566dd3d89e7b08a651b58c80b25f3128737cf13d /media-video/kaffeine/kaffeine-0.8.6.ebuild
parentFix compilation with gcc 4.2, bug #206388 (diff)
downloadgentoo-2-b5f26b3aaa4d4e7b99f9587fde9cb59cb2d03bc2.tar.gz
gentoo-2-b5f26b3aaa4d4e7b99f9587fde9cb59cb2d03bc2.tar.bz2
gentoo-2-b5f26b3aaa4d4e7b99f9587fde9cb59cb2d03bc2.zip
Add kaffeine-0.8.6.ebuild, version bump.
(Portage version: 2.1.4)
Diffstat (limited to 'media-video/kaffeine/kaffeine-0.8.6.ebuild')
-rw-r--r--media-video/kaffeine/kaffeine-0.8.6.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/media-video/kaffeine/kaffeine-0.8.6.ebuild b/media-video/kaffeine/kaffeine-0.8.6.ebuild
new file mode 100644
index 000000000000..0ac5b5d6cd0a
--- /dev/null
+++ b/media-video/kaffeine/kaffeine-0.8.6.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/kaffeine/kaffeine-0.8.6.ebuild,v 1.1 2008/01/22 06:23:19 tgurr Exp $
+
+inherit eutils kde flag-o-matic
+
+DESCRIPTION="Media player for KDE using xine and gstreamer backends."
+HOMEPAGE="http://kaffeine.sourceforge.net/"
+SRC_URI="mirror://sourceforge/kaffeine/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="dvb gstreamer xinerama vorbis encode kdehiddenvisibility xcb"
+
+RDEPEND=">=media-libs/xine-lib-1.1.9
+ xcb? ( >=x11-libs/libxcb-1.0 )
+ gstreamer? ( =media-libs/gstreamer-0.10*
+ =media-plugins/gst-plugins-xvideo-0.10* )
+ media-sound/cdparanoia
+ encode? ( media-sound/lame )
+ vorbis? ( media-libs/libvorbis )
+ x11-libs/libXtst"
+
+DEPEND="${RDEPEND}
+ dvb? ( media-tv/linuxtv-dvb-headers )"
+
+need-kde 3.5.4
+
+pkg_setup() {
+ if use xcb && ! built_with_use --missing false media-libs/xine-lib xcb; then
+ eerror "To enable the xcb useflag on this package you need"
+ eerror "the useflag xcb enabled on media-libs/xine-lib."
+ eerror "Please emerge media-libs/xine-lib again with the xcb useflag"
+ eerror "enabled."
+ die "Missing xcb useflag on media-libs/xine-lib."
+ fi
+}
+
+src_unpack() {
+ kde_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/kaffeine-0.8.5-respectcflags.patch
+ rm -f "${S}"/configure
+}
+
+src_compile() {
+ # see bug #143168
+ replace-flags -O3 -O2
+
+ # workaround bug #198973
+ local save_CXXFLAGS="${CXXFLAGS}"
+ append-flags -std=gnu89
+ export CXXFLAGS="${save_CXXFLAGS}"
+
+ local myconf="${myconf}
+ $(use_with xinerama)
+ $(use_with dvb)
+ $(use_with gstreamer)
+ $(use_with vorbis oggvorbis)
+ $(use_with xcb)
+ $(use_with encode lame)"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+
+ # fix localization, bug #199909
+ for mofile in "${D}"/usr/share/locale/*/LC_MESSAGES/${P}.mo ; do
+ mv -f ${mofile} ${mofile/${P}.mo/${PN}.mo} \
+ || die "fixing mo files failed"
+ done
+
+ # remove this, as kdelibs 3.5.4 provides it
+ rm -f "${D}"/usr/share/mimelnk/application/x-mplayer2.desktop
+}