summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-04-25 05:03:28 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-04-25 05:03:28 +0000
commit6d6ec73cb3367bdb086d4c66763d48ce1bdd989e (patch)
tree783be4a1a1e9c8546f765aebb82988e63839bede /media-video/noad
parentDEPEND on <texinfo-5.0 (bug #466730) (diff)
downloadgentoo-2-6d6ec73cb3367bdb086d4c66763d48ce1bdd989e.tar.gz
gentoo-2-6d6ec73cb3367bdb086d4c66763d48ce1bdd989e.tar.bz2
gentoo-2-6d6ec73cb3367bdb086d4c66763d48ce1bdd989e.zip
Fix building with media-gfx/imagemagick >= 6.8 wrt #467134. Fix building with recent media-video/ffmpeg (missing -lavutil linkage)
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-video/noad')
-rw-r--r--media-video/noad/ChangeLog6
-rw-r--r--media-video/noad/noad-0.7.3-r1.ebuild27
2 files changed, 23 insertions, 10 deletions
diff --git a/media-video/noad/ChangeLog b/media-video/noad/ChangeLog
index c404188f2da1..da72febee72d 100644
--- a/media-video/noad/ChangeLog
+++ b/media-video/noad/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/noad
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/noad/ChangeLog,v 1.56 2013/04/04 10:49:11 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/noad/ChangeLog,v 1.57 2013/04/25 05:03:28 ssuominen Exp $
+
+ 25 Apr 2013; Samuli Suominen <ssuominen@gentoo.org> noad-0.7.3-r1.ebuild:
+ Fix building with media-gfx/imagemagick >= 6.8 wrt #467134. Fix building with
+ recent media-video/ffmpeg (missing -lavutil linkage)
04 Apr 2013; Alexis Ballier <aballier@gentoo.org>
+files/patches-0.7.x/noad-0.7.3-ffmpeg_detection.diff:
diff --git a/media-video/noad/noad-0.7.3-r1.ebuild b/media-video/noad/noad-0.7.3-r1.ebuild
index 83363fd61577..c2afe50313c5 100644
--- a/media-video/noad/noad-0.7.3-r1.ebuild
+++ b/media-video/noad/noad-0.7.3-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/noad/noad-0.7.3-r1.ebuild,v 1.1 2013/03/29 09:41:14 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/noad/noad-0.7.3-r1.ebuild,v 1.2 2013/04/25 05:03:28 ssuominen Exp $
EAPI=5
-inherit autotools eutils
+inherit autotools eutils toolchain-funcs
DESCRIPTION="Mark commercial Breaks in VDR records"
HOMEPAGE="http://noad.heliohost.org/"
@@ -12,13 +12,14 @@ SRC_URI="http://noad.heliohost.org/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="ffmpeg imagemagick"
+IUSE="ffmpeg"
-DEPEND="media-libs/libmpeg2:=
+RDEPEND="media-gfx/imagemagick:=
+ media-libs/libmpeg2:=
ffmpeg? ( virtual/ffmpeg )
- imagemagick? ( media-gfx/imagemagick:= )
!media-plugins/vdr-markad"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
src_prepare() {
EPATCH_FORCE=yes EPATCH_SUFFIX=diff EPATCH_SOURCE="${FILESDIR}"/patches-${PV%.*}.x epatch
@@ -29,26 +30,34 @@ src_prepare() {
sed -i -e '/CXXFLAGS.*O3/d' configure.ac || die #426746
+ sed -i \
+ -e "s:-lMagick++:$($(tc-getPKG_CONFIG) --libs-only-l Magick++):" \
+ Makefile.am || die #467134
+
# FIXME: --with-tools, markpics will compile but showindex won't!
sed -i \
-e '/^noinst_PROGRAMS/s:@TOOLSRC@::' \
-e '/^EXTRA_PROGRAMS/s:showindex::' \
Makefile.am || die
+ # ld: audiotools.o: undefined reference to symbol 'av_free@@LIBAVUTIL_51'
+ if use ffmpeg; then
+ sed -i -e 's:-lavcodec:& -lavutil:' configure.ac || die
+ fi
+
eautoreconf
}
src_configure() {
econf \
- $(use_with imagemagick magick) \
+ --with-magick \
--with-mpeginclude=/usr/include/mpeg2dec \
--with-tools \
$(usex ffmpeg '--with-ffmpeg --with-ffmpeginclude=/usr/include' '')
}
src_install() {
- dobin noad # showindex
- use imagemagick && dobin markpics
+ dobin noad markpics # showindex
dodoc README INSTALL
# example scripts are installed as dokumentation