summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2014-10-22 13:30:44 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2014-10-22 13:30:44 +0000
commita936f13ca7906c4ac0de0dbba44f33810b6e9381 (patch)
treec93a52195b73379a8146fbfc6ab5355a8fe13222 /media-video/noad
parentVersion bump. (diff)
downloadgentoo-2-a936f13ca7906c4ac0de0dbba44f33810b6e9381.tar.gz
gentoo-2-a936f13ca7906c4ac0de0dbba44f33810b6e9381.tar.bz2
gentoo-2-a936f13ca7906c4ac0de0dbba44f33810b6e9381.zip
fixed compile libav-9
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 34C2808A)
Diffstat (limited to 'media-video/noad')
-rw-r--r--media-video/noad/ChangeLog12
-rw-r--r--media-video/noad/files/patches-0.8.x/noad-0.8.6-libav9.diff106
-rw-r--r--media-video/noad/metadata.xml3
-rw-r--r--media-video/noad/noad-0.8.6-r1.ebuild78
4 files changed, 198 insertions, 1 deletions
diff --git a/media-video/noad/ChangeLog b/media-video/noad/ChangeLog
index 19fb61d32e2f..361572557eec 100644
--- a/media-video/noad/ChangeLog
+++ b/media-video/noad/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for media-video/noad
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/noad/ChangeLog,v 1.61 2014/06/15 17:30:37 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/noad/ChangeLog,v 1.62 2014/10/22 13:30:44 hd_brummy Exp $
+
+ 22 Oct 2014; Joerg Bornkessel <hd_brummy@gentoo.org> +noad-0.8.6-r1.ebuild,
+ +files/patches-0.8.x/noad-0.8.6-libav9.diff, metadata.xml:
+ fixed compile libav-9
+
+*noad-0.8.6-r1 (22 Oct 2014)
+
+ 22 Oct 2014; Joerg Bornkessel <hd_brummy@gentoo.org> +noad-0.8.6-r1.ebuild,
+ +files/patches-0.8.x/noad-0.8.6-libav9.diff:
+ fixed compile libav-9
*noad-0.8.6 (15 Jun 2014)
diff --git a/media-video/noad/files/patches-0.8.x/noad-0.8.6-libav9.diff b/media-video/noad/files/patches-0.8.x/noad-0.8.6-libav9.diff
new file mode 100644
index 000000000000..a9b6c89d9f8c
--- /dev/null
+++ b/media-video/noad/files/patches-0.8.x/noad-0.8.6-libav9.diff
@@ -0,0 +1,106 @@
+compile fix noad-0.8.6
+testet with libav-9 ffmpeg-2.2.9
+Signed-of-by: Joerg Bornkessel <hd_brummy@gentoo.o> (22 Oct 2014)
+diff -Naur noad-0.8.6.orig/audiotools.cpp noad-0.8.6/audiotools.cpp
+--- noad-0.8.6.orig/audiotools.cpp 2014-10-22 14:26:57.809249955 +0200
++++ noad-0.8.6/audiotools.cpp 2014-10-22 14:28:06.830249955 +0200
+@@ -50,9 +50,9 @@
+ uint8_t *outbuf=NULL;
+ AVCodec *codec=NULL;
+ AVCodecContext *codecContext= NULL;
+-#if LIBAVCODEC_VERSION_MAJOR > 54
++//#if LIBAVCODEC_VERSION_MAJOR > 54
+ AVDictionary *avDictionary = NULL; // "create" an empty dictionary
+-#endif
++//#endif
+ int64_t basepts=0;
+ int64_t audiobasepts=0;
+ //int64_t audiopts=0;
+@@ -108,13 +108,13 @@
+ codecContext = avcodec_alloc_context3(codec);
+ #endif
+
+-#if LIBAVCODEC_VERSION_MAJOR > 54
++//#if LIBAVCODEC_VERSION_MAJOR > 54
+ /* open it */
+ if (avcodec_open2(codecContext, codec, &avDictionary) < 0)
+-#else
++//#else
+ /* open it */
+- if (avcodec_open(codecContext, codec) < 0)
+-#endif
++// if (avcodec_open(codecContext, codec) < 0)
++//#endif
+ {
+ fprintf(stderr, "could not open codec\n");
+ }
+@@ -129,9 +129,9 @@
+ {
+ free(outbuf);
+ avcodec_close(codecContext);
+-#if LIBAVCODEC_VERSION_MAJOR > 54
++//#if LIBAVCODEC_VERSION_MAJOR > 54
+ av_dict_free(&avDictionary);
+-#endif
++//#endif
+ av_free(codecContext);
+ av_codec_initialised = false;
+ }
+diff -Naur noad-0.8.6.orig/ffmpeg_decoder.cpp noad-0.8.6/ffmpeg_decoder.cpp
+--- noad-0.8.6.orig/ffmpeg_decoder.cpp 2014-10-22 14:26:57.808249955 +0200
++++ noad-0.8.6/ffmpeg_decoder.cpp 2014-10-22 14:38:26.366249955 +0200
+@@ -184,7 +184,7 @@
+
+ // Retrieve stream information
+ resetDecoder();
+- int openCode2 = av_find_stream_info(pFormatCtx);
++ int openCode2 = avformat_find_stream_info(pFormatCtx, NULL);
+ if(openCode2<0)
+ return -1; // Couldn't find stream information
+
+@@ -222,13 +222,13 @@
+ if(pCodec->capabilities & CODEC_CAP_TRUNCATED)
+ pCodecCtx->flags|=CODEC_FLAG_TRUNCATED;
+
+-#if LIBAVCODEC_VERSION_MAJOR > 54
++//#if LIBAVCODEC_VERSION_MAJOR > 54
+ // Open codec
+ if(avcodec_open2(pCodecCtx, pCodec,&avDictionary) < 0)
+-#else
++//#else
+ // Open codec
+- if(avcodec_open(pCodecCtx, pCodec)<0)
+-#endif
++// if(avcodec_open(pCodecCtx, pCodec)<0)
++//#endif
+ return -1; // Could not open codec
+
+
+@@ -270,10 +270,10 @@
+ pIOContext = NULL;
+ }
+ #endif
+-#if LIBAVCODEC_VERSION_MAJOR > 54
++//#if LIBAVCODEC_VERSION_MAJOR > 54
+ av_dict_free(&avDictionary);
+ avDictionary = NULL;
+-#endif
++//#endif
+ return 0;
+ }
+
+diff -Naur noad-0.8.6.orig/ffmpeg_decoder.h noad-0.8.6/ffmpeg_decoder.h
+--- noad-0.8.6.orig/ffmpeg_decoder.h 2014-10-22 14:26:57.807249955 +0200
++++ noad-0.8.6/ffmpeg_decoder.h 2014-10-22 14:36:27.213249955 +0200
+@@ -22,9 +22,9 @@
+ int i, videoStream;
+ AVCodecContext *pCodecCtx;
+ AVCodec *pCodec;
+-#if LIBAVCODEC_VERSION_MAJOR > 54
++//#if LIBAVCODEC_VERSION_MAJOR > 54
+ AVDictionary *avDictionary;
+-#endif
++//#endif
+ AVFrame *pFrame;
+
+ public:
diff --git a/media-video/noad/metadata.xml b/media-video/noad/metadata.xml
index 6e5aae722ea7..5c64a44cf7c5 100644
--- a/media-video/noad/metadata.xml
+++ b/media-video/noad/metadata.xml
@@ -6,6 +6,9 @@
<email>vdr@gentoo.org</email>
<name>Gentoo VDR Project</name>
</maintainer>
+ <use>
+ <flag name="libmpeg2">Support for libmpeg2 library</flag>
+ </use>
<longdescription lang="en">
Mark commercial Breaks in VDR records.
</longdescription>
diff --git a/media-video/noad/noad-0.8.6-r1.ebuild b/media-video/noad/noad-0.8.6-r1.ebuild
new file mode 100644
index 000000000000..87aa1c854f60
--- /dev/null
+++ b/media-video/noad/noad-0.8.6-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/noad/noad-0.8.6-r1.ebuild,v 1.1 2014/10/22 13:30:44 hd_brummy Exp $
+
+EAPI=5
+inherit autotools eutils toolchain-funcs confutils
+
+DESCRIPTION="Mark commercial breaks in VDR recordings"
+HOMEPAGE="http://noad.net23.net/"
+SRC_URI="http://noad.net23.net/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ffmpeg imagemagick libmpeg2"
+
+RDEPEND="
+ libmpeg2? ( media-libs/libmpeg2:= )
+ ffmpeg? ( virtual/ffmpeg )
+ imagemagick? ( media-gfx/imagemagick )
+ !media-plugins/vdr-markad"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i -e 's:2001:6419:' svdrpc.cpp main.cpp || die
+
+ # tested libav-9, ffmepg-2.2.9
+ epatch "${FILESDIR}/patches-0.8.x/${P}-libav9.diff"
+
+ eautoreconf
+}
+
+src_configure() {
+ confutils_require_any ffmpeg libmpeg2
+ econf \
+ $(usex imagemagick '--with-magick') \
+ $(usex ffmpeg '' '--without-ffmpeg') \
+ $(usex libmpeg2 '' '--without-libmpeg2') \
+ --with-tools
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" # see bug #469810
+}
+
+src_install() {
+ dobin noad showindex checkMarks
+ use imagemagick && dobin markpics
+
+ dodoc README INSTALL
+ # example scripts are installed as dokumentation
+ dodoc allnewnoad allnoad allnoadnice clearlogos noadcall.sh noadifnew stat2html statupd
+
+ newconfd "${FILESDIR}"/confd_vdraddon.noad vdraddon.noad
+
+ insinto /usr/share/vdr/record
+ doins "${FILESDIR}"/record-50-noad.sh
+
+ insinto /usr/share/vdr/shutdown
+ doins "${FILESDIR}"/pre-shutdown-15-noad.sh
+
+ insinto /etc/vdr/reccmds
+ doins "${FILESDIR}"/reccmds.noad.conf
+
+ exeinto /usr/share/vdr/bin
+ doexe "${FILESDIR}"/noad-reccmd
+}
+
+pkg_postinst() {
+ elog
+ elog "To integrate noad in VDR you should do this:"
+ elog
+ elog "start and set Parameter in /etc/conf.d/vdraddon.noad"
+ elog
+ elog "Note: You can use here all parameters for noad,"
+ elog "please look in the documentation of noad."
+}