summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-03-11 19:43:04 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-03-11 19:43:04 +0000
commit3a956818959ab38e773c3426678877c2aa07ccde (patch)
tree5178aec71de96a57a2b2855209933738f0c259b9 /media-video/nvidia-kernel/files
parentstable on x86,amd64 (diff)
downloadgentoo-2-3a956818959ab38e773c3426678877c2aa07ccde.tar.gz
gentoo-2-3a956818959ab38e773c3426678877c2aa07ccde.tar.bz2
gentoo-2-3a956818959ab38e773c3426678877c2aa07ccde.zip
Update version.
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-video/nvidia-kernel/files')
-rw-r--r--media-video/nvidia-kernel/files/1.0.7167/NVIDIA_kernel-1.0-7167-amd64-shutup-warnings.patch12
-rw-r--r--media-video/nvidia-kernel/files/1.0.7167/NVIDIA_kernel-1.0-7167-conftest-koutput-includes.patch22
-rw-r--r--media-video/nvidia-kernel/files/1.0.7167/NVIDIA_kernel-1.0-7167-disable-preempt-on-smp_processor_id.patch18
-rw-r--r--media-video/nvidia-kernel/files/1.0.7167/NVIDIA_kernel-1.0-7167-x86-shutup-warnings.patch12
-rw-r--r--media-video/nvidia-kernel/files/digest-nvidia-kernel-1.0.71672
5 files changed, 66 insertions, 0 deletions
diff --git a/media-video/nvidia-kernel/files/1.0.7167/NVIDIA_kernel-1.0-7167-amd64-shutup-warnings.patch b/media-video/nvidia-kernel/files/1.0.7167/NVIDIA_kernel-1.0-7167-amd64-shutup-warnings.patch
new file mode 100644
index 000000000000..bd75515c50c8
--- /dev/null
+++ b/media-video/nvidia-kernel/files/1.0.7167/NVIDIA_kernel-1.0-7167-amd64-shutup-warnings.patch
@@ -0,0 +1,12 @@
+diff -urpN nv.orig/Makefile.kbuild nv/Makefile.kbuild
+--- nv.orig/Makefile.kbuild 2004-11-09 20:27:54.012160376 +0200
++++ nv/Makefile.kbuild 2004-11-09 20:52:59.256328480 +0200
+@@ -73,7 +73,7 @@ endif
+ #
+
+ EXTRA_CFLAGS += -I$(src)
+-EXTRA_CFLAGS += -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpointer-arith -Wno-multichar -Werror -O -fno-common -mno-red-zone -MD $(DEFINES) $(INCLUDES) -Wsign-compare -Wno-cast-qual -Wno-error
++EXTRA_CFLAGS += -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wno-multichar -Werror -O -fno-common -mno-red-zone -MD $(DEFINES) $(INCLUDES) -Wsign-compare -Wno-cast-qual -Wno-error
+
+ #
+ # We rely on these two definitions below; if they aren't set, we set them to
diff --git a/media-video/nvidia-kernel/files/1.0.7167/NVIDIA_kernel-1.0-7167-conftest-koutput-includes.patch b/media-video/nvidia-kernel/files/1.0.7167/NVIDIA_kernel-1.0-7167-conftest-koutput-includes.patch
new file mode 100644
index 000000000000..ad408f3ec7ff
--- /dev/null
+++ b/media-video/nvidia-kernel/files/1.0.7167/NVIDIA_kernel-1.0-7167-conftest-koutput-includes.patch
@@ -0,0 +1,22 @@
+--- 1/conftest.sh 2004-11-07 12:20:02.776660256 +1100
++++ 2/conftest.sh 2004-11-07 12:23:32.432787680 +1100
+@@ -17,7 +17,7 @@
+
+ if [ "$OUTPUT" != "$SOURCES" ]; then
+ CFLAGS="$CFLAGS -I$OUTPUT/include2 -I$OUTPUT/include \
+--I$HEADERS -I$HEADERS/asm/mach-default"
++-I$HEADERS -I$OUTPUT/include2/asm/mach-default"
+ else
+ CFLAGS="$CFLAGS -I$HEADERS -I$HEADERS/asm/mach-default"
+ fi
+@@ -260,8 +260,8 @@
+ echo "installed on your system. If you specified a separate";
+ echo "output directory using either the \"KBUILD_OUTPUT\" or";
+ echo "the \"O\" KBUILD parameter, make sure to specify this";
+- echo "directory with the SYSOUT environment variable or with";
+- echo "the appropriate nvidia-installer command line option.";
++ echo "directorys _PARENT_ with the KBUILD_OUTPUT_PREFIX";
++ echo "environment variable, (or see /etc/env.d/05kernel)";
+ echo "";
+ if [ "$VERBOSE" = "full_output" ]; then
+ echo "*** Unable to determine the target kernel version. ***";
diff --git a/media-video/nvidia-kernel/files/1.0.7167/NVIDIA_kernel-1.0-7167-disable-preempt-on-smp_processor_id.patch b/media-video/nvidia-kernel/files/1.0.7167/NVIDIA_kernel-1.0-7167-disable-preempt-on-smp_processor_id.patch
new file mode 100644
index 000000000000..a8246e5516ac
--- /dev/null
+++ b/media-video/nvidia-kernel/files/1.0.7167/NVIDIA_kernel-1.0-7167-disable-preempt-on-smp_processor_id.patch
@@ -0,0 +1,18 @@
+--- nv.orig/nv.c 2004-12-27 11:38:13.298374416 +1100
++++ nv/nv.c 2004-12-27 11:42:48.876480176 +1100
+@@ -2814,6 +2814,7 @@
+ int cpu;
+
+ nvl = NV_GET_NVL_FROM_NV_STATE(nv);
++ preempt_disable();
+ cpu = get_cpu();
+
+ if (nvl->rm_lock_cpu == cpu)
+@@ -2829,6 +2830,7 @@
+
+ nvl->rm_lock_cpu = smp_processor_id();
+ nvl->rm_lock_count = 1;
++ preempt_enable();
+ }
+
+ void NV_API_CALL nv_unlock_rm(
diff --git a/media-video/nvidia-kernel/files/1.0.7167/NVIDIA_kernel-1.0-7167-x86-shutup-warnings.patch b/media-video/nvidia-kernel/files/1.0.7167/NVIDIA_kernel-1.0-7167-x86-shutup-warnings.patch
new file mode 100644
index 000000000000..a82a147f2658
--- /dev/null
+++ b/media-video/nvidia-kernel/files/1.0.7167/NVIDIA_kernel-1.0-7167-x86-shutup-warnings.patch
@@ -0,0 +1,12 @@
+diff -urpN nv.orig/Makefile.kbuild nv/Makefile.kbuild
+--- nv.orig/Makefile.kbuild 2004-11-09 20:27:54.012160376 +0200
++++ nv/Makefile.kbuild 2004-11-09 20:52:59.256328480 +0200
+@@ -73,7 +73,7 @@ endif
+ #
+
+ EXTRA_CFLAGS += -I$(src)
+-EXTRA_CFLAGS += -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpointer-arith -Wno-multichar -Werror -O -fno-common -MD $(DEFINES) $(INCLUDES) -Wsign-compare -Wno-cast-qual -Wno-error
++EXTRA_CFLAGS += -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wno-multichar -Werror -O -fno-common -MD $(DEFINES) $(INCLUDES) -Wsign-compare -Wno-cast-qual -Wno-error
+
+ #
+ # We rely on these two definitions below; if they aren't set, we set them to
diff --git a/media-video/nvidia-kernel/files/digest-nvidia-kernel-1.0.7167 b/media-video/nvidia-kernel/files/digest-nvidia-kernel-1.0.7167
new file mode 100644
index 000000000000..691dc4a42ce3
--- /dev/null
+++ b/media-video/nvidia-kernel/files/digest-nvidia-kernel-1.0.7167
@@ -0,0 +1,2 @@
+MD5 d88d606873be255e8c4926961a1f09bf NVIDIA-Linux-x86-1.0-7167-pkg1.run 9427444
+MD5 a0433d841c41862af266300b589c12a7 NVIDIA-Linux-x86_64-1.0-7167-pkg2.run 8709382