summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimone Gotti <motaboy@gentoo.org>2004-11-29 10:10:58 +0000
committerSimone Gotti <motaboy@gentoo.org>2004-11-29 10:10:58 +0000
commitc8d2f3d5ef9fb6735bb12288255c758962b68fdf (patch)
tree1326677027f3304a6b8bf2ffad4a27f7b6766863 /media-video/okle
parentcleanup (Manifest recommit) (diff)
downloadgentoo-2-c8d2f3d5ef9fb6735bb12288255c758962b68fdf.tar.gz
gentoo-2-c8d2f3d5ef9fb6735bb12288255c758962b68fdf.tar.bz2
gentoo-2-c8d2f3d5ef9fb6735bb12288255c758962b68fdf.zip
Added a patch to the configure script to honor the arts USE flag. Fixes bug #72786.
Diffstat (limited to 'media-video/okle')
-rw-r--r--media-video/okle/ChangeLog7
-rw-r--r--media-video/okle/files/okle-0.4-configure-arts.patch141
-rw-r--r--media-video/okle/okle-0.4.ebuild12
3 files changed, 156 insertions, 4 deletions
diff --git a/media-video/okle/ChangeLog b/media-video/okle/ChangeLog
index 828943a839c9..b0b694ab8f48 100644
--- a/media-video/okle/ChangeLog
+++ b/media-video/okle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/okle
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/okle/ChangeLog,v 1.5 2004/07/03 21:46:56 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/okle/ChangeLog,v 1.6 2004/11/29 10:10:58 motaboy Exp $
+
+ 29 Nov 2004; Simone Gotti <motaboy@gentoo.org>
+ +files/okle-0.4-configure-arts.patch, okle-0.4.ebuild:
+ Added a patch to the configure script to honor the arts USE flag. Fixes bug
+ #72786.
03 Jul 2004; Carsten Lohrke <carlo@gentoo.org> okle-0.4.ebuild:
QA: need-kde after R/DEPEND
diff --git a/media-video/okle/files/okle-0.4-configure-arts.patch b/media-video/okle/files/okle-0.4-configure-arts.patch
new file mode 100644
index 000000000000..9a89bcd64786
--- /dev/null
+++ b/media-video/okle/files/okle-0.4-configure-arts.patch
@@ -0,0 +1,141 @@
+--- configure.orig 2004-11-29 10:59:41.703797136 +0000
++++ configure 2004-11-29 11:00:33.975850576 +0000
+@@ -25132,138 +25132,6 @@
+ fi
+
+
+- echo "$as_me:$LINENO: checking for mcopidl" >&5
+-echo $ECHO_N "checking for mcopidl... $ECHO_C" >&6
+- if test -n "$MCOPIDL"; then
+- kde_cv_path="$MCOPIDL";
+- else
+- kde_cache=`echo mcopidl | sed 'y%./+-%__p_%'`
+-
+- if eval "test \"\${kde_cv_path_$kde_cache+set}\" = set"; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+-
+- kde_cv_path="NONE"
+- dirs="$kde_default_bindirs"
+- kde_save_IFS=$IFS
+- IFS=':'
+- for dir in $PATH; do
+- dirs="$dirs $dir"
+- done
+- IFS=$kde_save_IFS
+-
+- for dir in $dirs; do
+- if test -x "$dir/mcopidl"; then
+- if test -n ""
+- then
+- evalstr="$dir/mcopidl 2>&1 "
+- if eval $evalstr; then
+- kde_cv_path="$dir/mcopidl"
+- break
+- fi
+- else
+- kde_cv_path="$dir/mcopidl"
+- break
+- fi
+- fi
+- done
+-
+- eval "kde_cv_path_$kde_cache=$kde_cv_path"
+-
+-
+-fi
+-
+-
+- eval "kde_cv_path=\"`echo '$kde_cv_path_'$kde_cache`\""
+-
+- fi
+-
+- if test -z "$kde_cv_path" || test "$kde_cv_path" = NONE; then
+- echo "$as_me:$LINENO: result: not found" >&5
+-echo "${ECHO_T}not found" >&6
+-
+- { { echo "$as_me:$LINENO: error: The important program mcopidl was not found!
+-Please check whether you installed aRts correctly.
+-" >&5
+-echo "$as_me: error: The important program mcopidl was not found!
+-Please check whether you installed aRts correctly.
+-" >&2;}
+- { (exit 1); exit 1; }; }
+-
+- else
+- echo "$as_me:$LINENO: result: $kde_cv_path" >&5
+-echo "${ECHO_T}$kde_cv_path" >&6
+- MCOPIDL=$kde_cv_path
+-
+- fi
+-
+-
+- echo "$as_me:$LINENO: checking for artsc-config" >&5
+-echo $ECHO_N "checking for artsc-config... $ECHO_C" >&6
+- if test -n "$ARTSCCONFIG"; then
+- kde_cv_path="$ARTSCCONFIG";
+- else
+- kde_cache=`echo artsc-config | sed 'y%./+-%__p_%'`
+-
+- if eval "test \"\${kde_cv_path_$kde_cache+set}\" = set"; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+-
+- kde_cv_path="NONE"
+- dirs="$kde_default_bindirs"
+- kde_save_IFS=$IFS
+- IFS=':'
+- for dir in $PATH; do
+- dirs="$dirs $dir"
+- done
+- IFS=$kde_save_IFS
+-
+- for dir in $dirs; do
+- if test -x "$dir/artsc-config"; then
+- if test -n ""
+- then
+- evalstr="$dir/artsc-config 2>&1 "
+- if eval $evalstr; then
+- kde_cv_path="$dir/artsc-config"
+- break
+- fi
+- else
+- kde_cv_path="$dir/artsc-config"
+- break
+- fi
+- fi
+- done
+-
+- eval "kde_cv_path_$kde_cache=$kde_cv_path"
+-
+-
+-fi
+-
+-
+- eval "kde_cv_path=\"`echo '$kde_cv_path_'$kde_cache`\""
+-
+- fi
+-
+- if test -z "$kde_cv_path" || test "$kde_cv_path" = NONE; then
+- echo "$as_me:$LINENO: result: not found" >&5
+-echo "${ECHO_T}not found" >&6
+-
+- { { echo "$as_me:$LINENO: error: The important program artsc-config was not found!
+-Please check whether you installed aRts correctly.
+-" >&5
+-echo "$as_me: error: The important program artsc-config was not found!
+-Please check whether you installed aRts correctly.
+-" >&2;}
+- { (exit 1); exit 1; }; }
+-
+- else
+- echo "$as_me:$LINENO: result: $kde_cv_path" >&5
+-echo "${ECHO_T}$kde_cv_path" >&6
+- ARTSCCONFIG=$kde_cv_path
+-
+- fi
+-
+-
+ echo "$as_me:$LINENO: checking for kde-config" >&5
+ echo $ECHO_N "checking for kde-config... $ECHO_C" >&6
+ if test -n "$KDECONFIG"; then
diff --git a/media-video/okle/okle-0.4.ebuild b/media-video/okle/okle-0.4.ebuild
index cfb0573d3f16..694053abe2c9 100644
--- a/media-video/okle/okle-0.4.ebuild
+++ b/media-video/okle/okle-0.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/okle/okle-0.4.ebuild,v 1.5 2004/07/03 21:46:56 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/okle/okle-0.4.ebuild,v 1.6 2004/11/29 10:10:58 motaboy Exp $
-inherit kde
+inherit kde eutils
DESCRIPTION="oKle is a KDE frontend to the Ogle DVD player."
HOMEPAGE="http://okle.sourceforge.net/"
@@ -14,4 +14,10 @@ KEYWORDS="~x86 ~ppc"
IUSE=""
DEPEND=">=media-video/ogle-0.9.2"
-need-kde 3 \ No newline at end of file
+need-kde 3
+
+src_unpack() {
+ kde_src_unpack
+
+ use arts || epatch ${FILESDIR}/${P}-configure-arts.patch
+} \ No newline at end of file