summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2005-05-15 00:17:52 +0000
committerSteve Arnold <nerdboy@gentoo.org>2005-05-15 00:17:52 +0000
commit762af4a604ba8fc52a8a47db290132e0f927e161 (patch)
tree599c75ed2d0ae894111e191992b6132b612fa318 /media-video/sonic-snap/sonic-snap-1.5.ebuild
parentalpha stable (diff)
downloadgentoo-2-762af4a604ba8fc52a8a47db290132e0f927e161.tar.gz
gentoo-2-762af4a604ba8fc52a8a47db290132e0f927e161.tar.bz2
gentoo-2-762af4a604ba8fc52a8a47db290132e0f927e161.zip
new cam ebuild to work with sn9c102 driver
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-video/sonic-snap/sonic-snap-1.5.ebuild')
-rw-r--r--media-video/sonic-snap/sonic-snap-1.5.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/media-video/sonic-snap/sonic-snap-1.5.ebuild b/media-video/sonic-snap/sonic-snap-1.5.ebuild
new file mode 100644
index 000000000000..d530c68d8eb2
--- /dev/null
+++ b/media-video/sonic-snap/sonic-snap-1.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/sonic-snap/sonic-snap-1.5.ebuild,v 1.1 2005/05/15 00:17:51 nerdboy Exp $
+
+inherit eutils linux-info
+
+DESCRIPTION="Webcam app for sn9c10x based camera controllers (with optional MPEG4 support)"
+HOMEPAGE="http://stolk.org/sonic-snap/"
+SRC_URI="http://stolk.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="mpeg"
+
+DEPEND=" >=x11-libs/fltk-1.1.0_rc6
+ mpeg? ( >=media-libs/libfame-0.9.1 )
+ sys-libs/zlib
+ virtual/libc
+ virtual/x11"
+
+CONFIG_CHECK="USB_SN9C102"
+ERROR_USB_SN9C102="Please make sure Device Drivers -> USB Support -> SN9C10x \
+PC Camera Controller support, and Device Drivers -> Video For Linux support \
+are enabled as modules in your kernel."
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use mpeg && sed -i -e "s?USE_FAME=0?USE_FAME=1?g" Makefile
+}
+
+src_compile() {
+ make || die '"make" failed.'
+}
+
+src_install() {
+ dodir /usr/bin
+ make DESTDIR=${D} install || die '"make install" failed.'
+ #einstall || die "einstall failed"
+
+ dodoc ChangeLog README
+ doman debian/sonic-snap.1
+}
+
+pkg_postinst() {
+
+ ewarn ""
+ einfo "This application has found the sn9c10x driver (sn9c102.ko)"
+ einfo "enabled in the USB section of your kernel config. Also,"
+ einfo "this driver is V4L v2 only, so V4L v1 apps will not work."
+ einfo "Finally, only a few image sensors are supported, eg, PAS106B"
+ einfo "so (check dmesg or /var/log/messages for USB device info when"
+ einfo "you plug the cam in)."
+ einfo ""
+ einfo "Now try sonic-snap-gui /dev/videoX (where X is 0, 1 , etc)."
+ ewarn ""
+}