summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-08-03 20:16:15 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-08-03 20:16:15 +0000
commitdb22909757b60bd0714770b0bce4c90e14ea4c74 (patch)
tree26e07dd4932feb636cef30d58466e77fcdb1a9fa /media-video/subtitleripper/subtitleripper-0.3.4-r4.ebuild
parentOld. (diff)
downloadgentoo-2-db22909757b60bd0714770b0bce4c90e14ea4c74.tar.gz
gentoo-2-db22909757b60bd0714770b0bce4c90e14ea4c74.tar.bz2
gentoo-2-db22909757b60bd0714770b0bce4c90e14ea4c74.zip
Respect CC and LDFLAGS wrt bug #331105
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-video/subtitleripper/subtitleripper-0.3.4-r4.ebuild')
-rw-r--r--media-video/subtitleripper/subtitleripper-0.3.4-r4.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-video/subtitleripper/subtitleripper-0.3.4-r4.ebuild b/media-video/subtitleripper/subtitleripper-0.3.4-r4.ebuild
new file mode 100644
index 000000000000..31a6e7408c11
--- /dev/null
+++ b/media-video/subtitleripper/subtitleripper-0.3.4-r4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleripper/subtitleripper-0.3.4-r4.ebuild,v 1.1 2010/08/03 20:16:15 hwoarang Exp $
+
+inherit versionator eutils toolchain-funcs
+
+MY_PV="$(replace_version_separator 2 "-")"
+
+DESCRIPTION="DVD Subtitle Ripper for Linux"
+HOMEPAGE="http://subtitleripper.sourceforge.net/"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tgz"
+SLOT="0"
+IUSE=""
+RDEPEND=">=media-libs/netpbm-10.41.0
+ media-libs/libpng
+ sys-libs/zlib
+ >=app-text/gocr-0.39"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # PPM library is libnetppm
+ sed -i -e "s:ppm:netpbm:g" Makefile
+ # fix for bug 210435
+ sed -i -e "s:#include <ppm.h>:#include <netpbm/ppm.h>:g" spudec.c subtitle2pgm.c
+ # we will install the gocrfilters into /usr/share/subtitleripper
+ sed -i -e 's:~/sourceforge/subtitleripper/src/:/usr/share/subtitleripper:' pgm2txt
+
+ epatch "${FILESDIR}/${P}-linkingorder.patch"
+ epatch "${FILESDIR}"/${P}-libpng.patch
+ epatch "${FILESDIR}"/${P}-glibc210.patch
+ # respect CC and LDFLAGS
+ sed -i -e "s:CC =.*:CC = $(tc-getCC):" \
+ -e "/^CFLAGS/s: = :& ${CFLAGS} :" "${S}"/Makefile
+ epatch "${FILESDIR}"/${P}-respect-ldflags.patch
+}
+
+src_install () {
+ dobin pgm2txt srttool subtitle2pgm subtitle2vobsub vobsub2pgm
+
+ insinto /usr/share/subtitleripper
+ doins gocrfilter_*.sed
+
+ dodoc ChangeLog README*
+}