summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-01-19 15:25:04 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-01-19 15:25:04 +0000
commitb2a0209fb9b286dce5d305035cde8cf5d686892e (patch)
tree4814cb841d8f56363e02aa8497c52f70dbb9ccf5 /media-video/transcode
parentAdded mips to keywords (diff)
downloadgentoo-2-b2a0209fb9b286dce5d305035cde8cf5d686892e.tar.gz
gentoo-2-b2a0209fb9b286dce5d305035cde8cf5d686892e.tar.bz2
gentoo-2-b2a0209fb9b286dce5d305035cde8cf5d686892e.zip
Version bumped
Diffstat (limited to 'media-video/transcode')
-rw-r--r--media-video/transcode/ChangeLog7
-rw-r--r--media-video/transcode/files/digest-transcode-0.6.3.200212191
-rw-r--r--media-video/transcode/files/ogg.patch11
-rw-r--r--media-video/transcode/files/transcode-0.6.0_pre4.diff11
-rw-r--r--media-video/transcode/transcode-0.6.3.20021219.ebuild127
5 files changed, 145 insertions, 12 deletions
diff --git a/media-video/transcode/ChangeLog b/media-video/transcode/ChangeLog
index 084c5f22a34a..65566d343058 100644
--- a/media-video/transcode/ChangeLog
+++ b/media-video/transcode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/transcode
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/ChangeLog,v 1.19 2003/01/19 00:44:52 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/ChangeLog,v 1.20 2003/01/19 15:25:04 mholzer Exp $
+
+transcode-0.6.3.20021219 (19 Jan 2003)
+
+ 19 Jan 2003; Martin Holzer <mholzer@gentoo.org> transcode-0.6.3.20021219.ebuild files/digest-transcode-0.6.3.20021219 ChangeLog :
+ Version bumped. Now works without avifile !!!. Closes #12471
18 Jan 2003; Martin Holzer <mholzer@gentoo.org>
Big commit cause avifile.0.7.25 breaks all transcode packages
diff --git a/media-video/transcode/files/digest-transcode-0.6.3.20021219 b/media-video/transcode/files/digest-transcode-0.6.3.20021219
new file mode 100644
index 000000000000..ee307b245804
--- /dev/null
+++ b/media-video/transcode/files/digest-transcode-0.6.3.20021219
@@ -0,0 +1 @@
+MD5 26e9f8769bea4c22917a7ea1b79d5449 transcode-0.6.3.20021219.tar.gz 2415186
diff --git a/media-video/transcode/files/ogg.patch b/media-video/transcode/files/ogg.patch
new file mode 100644
index 000000000000..fadf57097a69
--- /dev/null
+++ b/media-video/transcode/files/ogg.patch
@@ -0,0 +1,11 @@
+--- export/export_ogg.c.org 2003-01-26 21:12:17.000000000 +0000
++++ export/export_ogg.c 2003-01-26 21:12:42.000000000 +0000
+@@ -37,7 +37,7 @@
+ static int capability_flag=TC_CAP_PCM;
+ static FILE *pFile = NULL;
+
+-int p_write (char *buf, size_t len)
++static int p_write (char *buf, size_t len)
+ {
+ size_t n = 0;
+ size_t r = 0;
diff --git a/media-video/transcode/files/transcode-0.6.0_pre4.diff b/media-video/transcode/files/transcode-0.6.0_pre4.diff
deleted file mode 100644
index 9f827e42df33..000000000000
--- a/media-video/transcode/files/transcode-0.6.0_pre4.diff
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ur transcode-0.6.0pre4.orig/import/af6_decore.cpp transcode-0.6.0pre4/import/af6_decore.cpp
---- transcode-0.6.0pre4.orig/import/af6_decore.cpp Tue Mar 26 15:40:31 2002
-+++ transcode-0.6.0pre4/import/af6_decore.cpp Fri May 3 22:30:24 2002
-@@ -42,7 +42,6 @@
- #include <avifile/creators.h>
- #include <iostream>
-
--using namespace std;
- using namespace Creators;
-
- #ifdef __cplusplus
diff --git a/media-video/transcode/transcode-0.6.3.20021219.ebuild b/media-video/transcode/transcode-0.6.3.20021219.ebuild
new file mode 100644
index 000000000000..d50e8e79b33b
--- /dev/null
+++ b/media-video/transcode/transcode-0.6.3.20021219.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/transcode-0.6.3.20021219.ebuild,v 1.1 2003/01/19 15:25:04 mholzer Exp $
+
+IUSE="sdl mmx mpeg sse dvd encode X quicktime avi"
+
+inherit libtool
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="video stream processing tool"
+SRC_URI="http://www.theorie.physik.uni-goettingen.de/~ostreich/transcode/pre/${MY_P}.tar.gz"
+HOMEPAGE="http://www.theorie.physik.uni-goettingen.de/~ostreich/transcode"
+
+# Note: transcode can use pretty much any media-related package ever written as
+# a plugin. An exhaustive dep list would make me add about 20-30 packages to
+# portage. perhaps another time :-)
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=media-libs/a52dec-0.7.3
+ >=media-libs/libdv-0.9.5
+ >=dev-lang/nasm-0.98.34
+ X? ( virtual/x11 )
+ avi? ( <=media-video/avifile-0.7.22
+ >=media-video/avifile-0.7.4 )
+ dvd? ( media-libs/libdvdread )
+ mpeg? ( media-libs/libmpeg3 )
+ encode? ( >=media-sound/lame-3.89 )
+ sdl? ( media-libs/libsdl )
+ quicktime? ( media-libs/quicktime4linux )
+ >=media-video/mplayer-0.90_pre10
+ =media-libs/netpbm-9.12*"
+
+# >=media-video/mplayer-0.90_pre10
+# Most people will want to view their video so
+# I have made mplayer the default as that is what
+# many will use anyway. Due to API changes transcode will
+# now fail to build if an earlier version of mplayer is
+# installed.
+# 2002-11-22 Transcode now requires nasm.
+
+# Dont want to build without these currently
+# dvd? ( media-libs/libdvdread )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/ogg.patch
+
+}
+
+src_compile() {
+
+ # fix invalid paths in .la files of plugins
+ elibtoolize
+
+ local myconf=""
+
+ use mmx \
+ && myconf="${myconf} --enable-mmx"
+ use mmx || ( use 3dnow || use sse ) \
+ || myconf="${myconf} --disable-mmx"
+ # Dont disable mmx if 3dnow or sse are requested.
+
+ use sse \
+ && myconf="${myconf} --enable-sse" \
+ || myconf="${myconf} --disable-sse"
+
+ use avi \
+ && myconf="${myconf} --with-avifile-mods --enable-avifile6" \
+ || myconf="${myconf} --without-avifile-mods --disable-avifile6"
+
+# use dvd \
+# && myconf="${myconf} --with-dvdread" \
+# || myconf="${myconf} --without-dvdread"
+
+# Dont currently want to build without these
+ myconf="${myconf} --with-dvdread"
+
+ use encode \
+ && myconf="${myconf} --with-lame" \
+ || myconf="${myconf} --without-lame"
+
+ use mpeg \
+ && myconf="${myconf} --with-libmpeg3" \
+ || myconf="${myconf} --without-libmpeg3"
+
+ use quicktime \
+ || myconf="${myconf} --without-qt --without-openqt"
+
+ use X \
+ && myconf="${myconf} --enable-x" \
+ || myconf="${myconf} --disable-x"
+
+ # Use the MPlayer libpostproc if present
+ [ -f ${ROOT}/usr/lib/libpostproc.a ] && \
+ [ -f ${ROOT}/usr/include/postprocess.h ] && \
+ myconf="${myconf} --with-libpostproc-builddir=${ROOT}/usr/lib"
+
+ econf ${myconf} || die
+
+ # Do not use emake !!
+ make all || die
+
+ # subrip stuff
+ cd contrib/subrip
+ make || die
+}
+
+src_install () {
+
+ make \
+ DESTDIR=${D} \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog README TODO
+
+ # subrip stuff
+ cd contrib/subrip
+ dobin pgm2txt srttool subtitle2pgm subtitle2vobsub
+ einfo ""
+ einfo "This ebuild uses subtitles !!!"
+ einfo ""
+}
+