summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-05-20 00:01:43 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-05-20 00:01:43 +0000
commit7a6c2fb842ca8f65c16d8f4137e05aada9149f88 (patch)
tree43204a08b43083d875af3e31325a84e7911d7585 /media-video/vcdimager
parentFixes #2805 - Expat Dependency (diff)
downloadgentoo-2-7a6c2fb842ca8f65c16d8f4137e05aada9149f88.tar.gz
gentoo-2-7a6c2fb842ca8f65c16d8f4137e05aada9149f88.tar.bz2
gentoo-2-7a6c2fb842ca8f65c16d8f4137e05aada9149f88.zip
New package
Diffstat (limited to 'media-video/vcdimager')
-rw-r--r--media-video/vcdimager/ChangeLog13
-rw-r--r--media-video/vcdimager/files/digest-vcdimager-0.7.121
-rw-r--r--media-video/vcdimager/vcdimager-0.7.12.ebuild44
3 files changed, 58 insertions, 0 deletions
diff --git a/media-video/vcdimager/ChangeLog b/media-video/vcdimager/ChangeLog
new file mode 100644
index 000000000000..e601f90ced06
--- /dev/null
+++ b/media-video/vcdimager/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for media-video/vcdimager
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/media-video/vcdimager/ChangeLog,v 1.1 2002/05/20 00:01:43 rphillips Exp $
+
+*vcdimager-0.7.12 (19 May 2002)
+
+ 19 May 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/media-video/vcdimager/files/digest-vcdimager-0.7.12 b/media-video/vcdimager/files/digest-vcdimager-0.7.12
new file mode 100644
index 000000000000..29eea1479a1a
--- /dev/null
+++ b/media-video/vcdimager/files/digest-vcdimager-0.7.12
@@ -0,0 +1 @@
+MD5 c1ec3525acc0254cd48ab3da0dd4b5e7 vcdimager-0.7.12.tar.gz 520829
diff --git a/media-video/vcdimager/vcdimager-0.7.12.ebuild b/media-video/vcdimager/vcdimager-0.7.12.ebuild
new file mode 100644
index 000000000000..2dd0e8ae4230
--- /dev/null
+++ b/media-video/vcdimager/vcdimager-0.7.12.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Matthew Turk <m-turk@nwu.edu>
+# $Header: /var/cvsroot/gentoo-x86/media-video/vcdimager/vcdimager-0.7.12.ebuild,v 1.1 2002/05/20 00:01:43 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU VCDimager"
+SRC_URI="http://www.vcdimager.org/pub/vcdimager/vcdimager-0.7_UNSTABLE/${P}.tar.gz"
+HOMEPAGE="http://www.vcdimager.org"
+LICENSE="GPL"
+
+# Ideally this would also include help2man, but it's not yet in portage.
+DEPENDS="xml2 ? ( >= dev-libs/libxml2-2.3.8 )"
+
+src_compile() {
+
+ local myopts
+
+ # We disable the xmltest because the configure script includes differently
+ # than the actual XML-frontend C files.
+
+ use xml2 \
+ && myopts="${myopts} --with-xml-prefix=/usr --disable-xmltest" \
+ || myopts="${myopts} --without-xml-frontend"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myopts} \
+ || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+}
+