summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-07 17:21:07 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-07 17:21:07 +0000
commitc124b361758cffceff694a32fc5467d8b13ff587 (patch)
tree4e1cc64b47851e83df21569fb964a85381391a71 /media-video/w3cam
parentDrop virtual/libc dependency, update to modular X, allow building with gcc4, ... (diff)
downloadgentoo-2-c124b361758cffceff694a32fc5467d8b13ff587.tar.gz
gentoo-2-c124b361758cffceff694a32fc5467d8b13ff587.tar.bz2
gentoo-2-c124b361758cffceff694a32fc5467d8b13ff587.zip
Don't use test, use [[ ]], and use econf instead of ./configure. Drop virtual/libc dependency.
(Portage version: 2.1_pre5-r4)
Diffstat (limited to 'media-video/w3cam')
-rw-r--r--media-video/w3cam/ChangeLog9
-rw-r--r--media-video/w3cam/metadata.xml2
-rw-r--r--media-video/w3cam/w3cam-0.7.2.ebuild17
3 files changed, 14 insertions, 14 deletions
diff --git a/media-video/w3cam/ChangeLog b/media-video/w3cam/ChangeLog
index 9b00bd6a79b4..7b136bc003ca 100644
--- a/media-video/w3cam/ChangeLog
+++ b/media-video/w3cam/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/w3cam
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/w3cam/ChangeLog,v 1.8 2005/09/03 23:19:20 flameeyes Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/w3cam/ChangeLog,v 1.9 2006/03/07 17:21:07 flameeyes Exp $
+
+ 07 Mar 2006; Diego Pettenò <flameeyes@gentoo.org> metadata.xml,
+ w3cam-0.7.2.ebuild:
+ Don't use test, use [[ ]], and use econf instead of ./configure. Drop
+ virtual/libc dependency.
03 Sep 2005; Diego Pettenò <flameeyes@gentoo.org> w3cam-0.7.2.ebuild:
Don't install COPYING file.
diff --git a/media-video/w3cam/metadata.xml b/media-video/w3cam/metadata.xml
index 5dd37336ce32..1860653b08c9 100644
--- a/media-video/w3cam/metadata.xml
+++ b/media-video/w3cam/metadata.xml
@@ -4,6 +4,6 @@
<herd>video</herd>
<herd>media-tv</herd>
<maintainer>
- <email>media-video@gentoo.org</email>
+<email>media-video@gentoo.org</email>
</maintainer>
</pkgmetadata>
diff --git a/media-video/w3cam/w3cam-0.7.2.ebuild b/media-video/w3cam/w3cam-0.7.2.ebuild
index f78a9956cdf8..d16cda1e60cc 100644
--- a/media-video/w3cam/w3cam-0.7.2.ebuild
+++ b/media-video/w3cam/w3cam-0.7.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/w3cam/w3cam-0.7.2.ebuild,v 1.10 2005/09/03 23:19:20 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/w3cam/w3cam-0.7.2.ebuild,v 1.11 2006/03/07 17:21:07 flameeyes Exp $
#
# You can set the default device that vidcat and w3camd use by setting
@@ -19,8 +19,7 @@ SLOT="0"
KEYWORDS="~ppc x86"
IUSE="truetype"
-DEPEND="virtual/libc
- sys-libs/zlib
+DEPEND="sys-libs/zlib
media-libs/jpeg
media-libs/libpng
truetype? ( media-libs/freetype )"
@@ -28,17 +27,13 @@ DEPEND="virtual/libc
src_compile() {
local myconf
- test -n "${W3CAM_DEVICE}" && \
+ [[ -n "${W3CAM_DEVICE}" ]] && \
myconf="${myconf} --with-device=${W3CAM_DEVICE}"
use truetype && \
myconf="${myconf} --with-ttf-inc=/usr/include/freetype"
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --mandir=/usr/share/man/man1 \
- ${myconf} || die "./configure failed"
+ econf ${myconf} || die "econf failed"
emake || die
}
@@ -46,7 +41,7 @@ src_install() {
dobin vidcat w3camd/w3camd
doman vidcat.1
dodoc ChangeLog.txt FAQ.txt README SAMPLES TODO.txt \
- index.html w3cam.css w3cam.cgi w3cam.cgi.scf
+ index.html w3cam.css w3cam.cgi w3cam.cgi.scf
docinto samples
dodoc samples/*
docinto w3camd