summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Brabec <utx@gentoo.org>2003-08-27 16:45:50 +0000
committerStanislav Brabec <utx@gentoo.org>2003-08-27 16:45:50 +0000
commit95da4fba75bd5ebdf8e3aaa1b5ccab5481a784ff (patch)
treeb4d3f8ffde7a26451c979d2a202cb2287aa80351 /media-video/xvattr/xvattr-1.3-r1.ebuild
parentadded gtk USE flag (diff)
downloadgentoo-2-95da4fba75bd5ebdf8e3aaa1b5ccab5481a784ff.tar.gz
gentoo-2-95da4fba75bd5ebdf8e3aaa1b5ccab5481a784ff.tar.bz2
gentoo-2-95da4fba75bd5ebdf8e3aaa1b5ccab5481a784ff.zip
added gtk USE flag
Diffstat (limited to 'media-video/xvattr/xvattr-1.3-r1.ebuild')
-rw-r--r--media-video/xvattr/xvattr-1.3-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-video/xvattr/xvattr-1.3-r1.ebuild b/media-video/xvattr/xvattr-1.3-r1.ebuild
new file mode 100644
index 000000000000..7b1793a4a605
--- /dev/null
+++ b/media-video/xvattr/xvattr-1.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/xvattr/xvattr-1.3-r1.ebuild,v 1.1 2003/08/27 16:45:45 utx Exp $
+
+DESCRIPTION="X11 XVideo Querying/Setting Tool from Ogle project"
+SRC_URI="http://www.dtek.chalmers.se/groups/dvd/dist/${P}.tar.gz"
+HOMEPAGE="http://www.dtek.chalmers.se/groups/dvd/"
+SLOT=0
+LICENSE="GPL-2"
+KEYWORDS="x86"
+IUSE="gtk"
+DEPEND="x11-base/xfree
+ gtk? ( =x11-libs/gtk+-1.2*
+ =dev-libs/glib-1.2* )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ # If no gtk then modify the necessary parts so that gtk isn't needed anymore
+ if [ -z `use gtk` ]
+ then
+ cd ${S}
+ rm Makefile.in
+ cp Makefile.am Makefile.am.orig
+ sed -e "s/bin_PROGRAMS = xvattr gxvattr/bin_PROGRAMS = xvattr/" -e "s/gxvattr_SOURCES = gxvattr.c//" -e "s/CFLAGS = @GTK_CFLAGS@//" -e "s/gxvattr_LDADD = @GTK_LIBS@ \$(X_LIBS) \$(X_PRE_LIBS) \$(X_EXTRA_LIBS) -lX11 -lXext//" Makefile.am.orig >Makefile.am
+ rm Makefile.am.orig
+
+ cp configure.in configure.in.orig
+ sed -e "s/dnl check for gtk//" -e "s/AM_PATH_GTK//" configure.in.orig >configure.in
+ rm configure.in.orig
+ automake
+ autoconf
+ fi
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS ChangeLog COPYING NEWS README
+}