summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-02-03 22:19:24 +0000
committerChris White <chriswhite@gentoo.org>2005-02-03 22:19:24 +0000
commit4c92c6a1d27b8bbf2b748abd4d1cfadf6c225833 (patch)
tree6cc06e01aa0e9b94c3cb7ee84cf887a25d6cff6b /media-video
parentAdd compile fix (from Azarah) (diff)
downloadgentoo-2-4c92c6a1d27b8bbf2b748abd4d1cfadf6c225833.tar.gz
gentoo-2-4c92c6a1d27b8bbf2b748abd4d1cfadf6c225833.tar.bz2
gentoo-2-4c92c6a1d27b8bbf2b748abd4d1cfadf6c225833.zip
Re-enabled sse2 as people with x86's say it works ok. Enabled new ecpu_check-ing functionality.
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mplayer/ChangeLog7
-rw-r--r--media-video/mplayer/mplayer-1.0_pre5-r5.ebuild12
-rw-r--r--media-video/mplayer/mplayer-1.0_pre6.ebuild13
3 files changed, 26 insertions, 6 deletions
diff --git a/media-video/mplayer/ChangeLog b/media-video/mplayer/ChangeLog
index 31d2736b81af..c82024d92362 100644
--- a/media-video/mplayer/ChangeLog
+++ b/media-video/mplayer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/mplayer
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.264 2005/01/30 08:48:29 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.265 2005/02/03 22:19:24 chriswhite Exp $
+
+ 04 Feb 2005; Chris White <chriswhite@gentoo.org> mplayer-1.0_pre5-r5.ebuild,
+ mplayer-1.0_pre6.ebuild:
+ Re-enabled sse2 as people with x86's say it works ok. Enabled new
+ ecpu_check-ing functionality.
30 Jan 2005; Chris White <chriswhite@gentoo.org>
+files/mplayer-avi_crash.patch, mplayer-1.0_pre5-r5.ebuild,
diff --git a/media-video/mplayer/mplayer-1.0_pre5-r5.ebuild b/media-video/mplayer/mplayer-1.0_pre5-r5.ebuild
index 1eb6161ef1f6..7d05a98cfb00 100644
--- a/media-video/mplayer/mplayer-1.0_pre5-r5.ebuild
+++ b/media-video/mplayer/mplayer-1.0_pre5-r5.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0_pre5-r5.ebuild,v 1.18 2005/01/30 08:48:29 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0_pre5-r5.ebuild,v 1.19 2005/02/03 22:19:24 chriswhite Exp $
inherit eutils flag-o-matic kernel-mod
RESTRICT="nostrip"
-IUSE="3dfx 3dnow 3dnowex aalib alsa altivec arts bidi debug divx4linux doc dvb cdparanoia directfb dvd dvdread edl encode esd fbcon gif ggi gtk i8x0 ipv6 jack joystick jpeg libcaca lirc live lzo mad matroska matrox mpeg mmx mmx2 mythtv nas network nls nvidia oggvorbis opengl oss png real rtc samba sdl sse svga tga theora truetype v4l v4l2 X xanim xinerama xmms xv xvid xvmc"
+IUSE="3dfx 3dnow 3dnowex aalib alsa altivec arts bidi debug divx4linux doc dvb cdparanoia directfb dvd dvdread edl encode esd fbcon gif ggi gtk i8x0 ipv6 jack joystick jpeg libcaca lirc live lzo mad matroska matrox mpeg mmx mmx2 mythtv nas network nls nvidia oggvorbis opengl oss png real rtc samba sdl sse sse2 svga tga theora truetype v4l v4l2 X xanim xinerama xmms xv xvid xvmc"
BLUV=1.4
SVGV=1.9.17
@@ -228,6 +228,13 @@ src_compile() {
export LINGUAS="en ${LINGUAS}"
fi
+ # check cpu flags
+ if use x86
+ then
+ CPU_FLAGS=( mmx mmx2 sse sse2 )
+ ecpu_check CPU_FLAGS
+ fi
+
# let's play the filtration game! MPlayer hates on all!
strip-flags
@@ -382,6 +389,7 @@ src_compile() {
myconf="${myconf} $(use_enable 3dnow)"
myconf="${myconf} $(use_enable 3dnowex)";
myconf="${myconf} $(use_enable sse)"
+ myconf="${myconf} $(use_enable sse2)"
myconf="${myconf} $(use_enable mmx)"
myconf="${myconf} $(use_enable mmx2)"
myconf="${myconf} $(use_enable 3dnow)"
diff --git a/media-video/mplayer/mplayer-1.0_pre6.ebuild b/media-video/mplayer/mplayer-1.0_pre6.ebuild
index 85c04729a296..183c22429476 100644
--- a/media-video/mplayer/mplayer-1.0_pre6.ebuild
+++ b/media-video/mplayer/mplayer-1.0_pre6.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0_pre6.ebuild,v 1.21 2005/01/30 08:48:29 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0_pre6.ebuild,v 1.22 2005/02/03 22:19:24 chriswhite Exp $
inherit eutils flag-o-matic kernel-mod
RESTRICT="nostrip"
IUSE="3dfx 3dnow 3dnowex aalib alsa altivec arts bidi debug divx4linux doc dts
-dvb cdparanoia directfb dvd dv dvdread edl encode esd fbcon gif ggi gtk i8x0 ipv6 jack joystick jpeg libcaca lirc live lzo mad matroska matrox mpeg mmx mmx2 mythtv nas nls nvidia oggvorbis opengl oss png real rtc samba sdl sse svga tga theora truetype v4l v4l2 X xanim xinerama xmms xv xvid xvmc"
+dvb cdparanoia directfb dvd dv dvdread edl encode esd fbcon gif ggi gtk i8x0 ipv6 jack joystick jpeg libcaca lirc live lzo mad matroska matrox mpeg mmx mmx2 mythtv nas nls nvidia oggvorbis opengl oss png real rtc samba sdl sse sse2 svga tga theora truetype v4l v4l2 X xanim xinerama xmms xv xvid xvmc"
BLUV=1.4
SVGV=1.9.17
@@ -200,6 +200,13 @@ src_compile() {
export LINGUAS="en ${LINGUAS}"
fi
+ # check cpu flags
+ if use x86
+ then
+ CPU_FLAGS=(mmx mmx2 sse sse2)
+ ecpu_check CPU_FLAGS
+ fi
+
# let's play the filtration game! MPlayer hates on all!
strip-flags
@@ -365,6 +372,7 @@ src_compile() {
myconf="${myconf} $(use_enable 3dnow)"
myconf="${myconf} $(use_enable 3dnowex)";
myconf="${myconf} $(use_enable sse)"
+ myconf="${myconf} $(use_enable sse2)"
myconf="${myconf} $(use_enable mmx)"
myconf="${myconf} $(use_enable mmx2)"
myconf="${myconf} $(use_enable debug)"
@@ -425,7 +433,6 @@ src_compile() {
--enable-network --enable-ftp \
--with-reallibdir=${REALLIBDIR} \
--with-x11incdir=/usr/X11R6/include \
- --disable-sse2 \
${myconf} || die
einfo "Make"