summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-06-12 07:57:18 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-06-12 07:57:18 +0000
commit72e02a9edf9309dbcb19f6065dce1de77683d9ee (patch)
tree82fec41250e46aa17f57c1aa42d24bb8a887e1e3 /media-video
parentuse slot dep for qt; clean old ebuild (diff)
downloadgentoo-2-72e02a9edf9309dbcb19f6065dce1de77683d9ee.tar.gz
gentoo-2-72e02a9edf9309dbcb19f6065dce1de77683d9ee.tar.bz2
gentoo-2-72e02a9edf9309dbcb19f6065dce1de77683d9ee.zip
version bump
(Portage version: 2.1.5.4)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/clive/ChangeLog7
-rw-r--r--media-video/clive/clive-0.4.15.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/media-video/clive/ChangeLog b/media-video/clive/ChangeLog
index eafaeb40806e..bec6622524eb 100644
--- a/media-video/clive/ChangeLog
+++ b/media-video/clive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/clive
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.23 2008/05/27 06:50:53 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.24 2008/06/12 07:57:18 aballier Exp $
+
+*clive-0.4.15 (12 Jun 2008)
+
+ 12 Jun 2008; Alexis Ballier <aballier@gentoo.org> +clive-0.4.15.ebuild:
+ version bump
*clive-0.4.14 (27 May 2008)
diff --git a/media-video/clive/clive-0.4.15.ebuild b/media-video/clive/clive-0.4.15.ebuild
new file mode 100644
index 000000000000..34e89b078276
--- /dev/null
+++ b/media-video/clive/clive-0.4.15.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/clive-0.4.15.ebuild,v 1.1 2008/06/12 07:57:18 aballier Exp $
+
+# We inherit distutils to get the pkg_* functions for byte compiling python
+inherit versionator distutils
+
+DESCRIPTION="Command line tool for extracting videos from Youtube, Google Video, Dailymotion, Guba (free) and Stage6 websites"
+HOMEPAGE="http://home.gna.org/clive/"
+SRC_URI="http://dl.gna.org/clive/$(get_version_component_range 1-2 ${PV})/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/python-2.4
+ >=dev-libs/newt-0.51
+ >=dev-python/urlgrabber-3.1.0
+ >=dev-python/feedparser-4.1"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ # with-lib means compile its own
+ econf $(use_with doc) \
+ --without-newt \
+ --without-feedparser \
+ --without-urlgrabber
+ emake || die "emake failed"
+ if use doc; then
+ emake dox || die "failed to create the documentation"
+ fi
+}
+
+src_install() {
+ emake py_compile=true DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog README
+ use doc && dohtml dox/html/*
+}