summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-11-01 13:50:53 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-11-01 13:50:53 +0000
commit841059a1d09953778b49f40cdf23beda520c3a9c (patch)
treebd4b62fd724a6684512106d7a356e71aea06f0e3 /media-video
parentqdevelop was bumped and its issues were fixed, removing mask/cancelling remov... (diff)
downloadgentoo-2-841059a1d09953778b49f40cdf23beda520c3a9c.tar.gz
gentoo-2-841059a1d09953778b49f40cdf23beda520c3a9c.tar.bz2
gentoo-2-841059a1d09953778b49f40cdf23beda520c3a9c.zip
Fix mga videocard check per bug #341171. Add missing options per bug #334793.
(Portage version: 2.2_rc98/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mplayer/ChangeLog6
-rw-r--r--media-video/mplayer/metadata.xml2
-rw-r--r--media-video/mplayer/mplayer-9999.ebuild44
3 files changed, 31 insertions, 21 deletions
diff --git a/media-video/mplayer/ChangeLog b/media-video/mplayer/ChangeLog
index f56371328b2d..02a30c3c4471 100644
--- a/media-video/mplayer/ChangeLog
+++ b/media-video/mplayer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/mplayer
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.763 2010/10/10 19:43:25 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.764 2010/11/01 13:50:53 scarabeus Exp $
+
+ 01 Nov 2010; Tomáš Chvátal <scarabeus@gentoo.org> mplayer-9999.ebuild,
+ metadata.xml:
+ Fix mga videocard check per bug #341171. Add missing options per bug #334793.
10 Oct 2010; Tomáš Chvátal <scarabeus@gentoo.org> mplayer-9999.ebuild,
metadata.xml:
diff --git a/media-video/mplayer/metadata.xml b/media-video/mplayer/metadata.xml
index f958a2b9391c..92cdcbc8b42c 100644
--- a/media-video/mplayer/metadata.xml
+++ b/media-video/mplayer/metadata.xml
@@ -23,10 +23,12 @@
<flag name="faac">Use external faac library for AAC encoding</flag>
<flag name="faad">Use external faad library for AAC decoding</flag>
<flag name="gmplayer">Build gmplayer, a GTK+ MPlayer gui (UNSUPPORTED)</flag>
+ <flag name="libmpeg2">Build support for mpeg2 over media-libs/libmpeg2 rather than using ffmpeg.</flag>
<flag name="live">Enables live.com streaming media support</flag>
<flag name="md5sum">Enables md5sum video output</flag>
<flag name="mmxext">Enables mmx2 support</flag>
<flag name="mng">MNG input support</flag>
+ <flag name="mpg123">Enable support for mp3 decoding over media-sound/mpg123.</flag>
<flag name="network">Enables network streaming support</flag>
<flag name="nut">Enables support for the NUT container format</flag>
<flag name="osdmenu">Enables support for on-screen display (OSD) menus</flag>
diff --git a/media-video/mplayer/mplayer-9999.ebuild b/media-video/mplayer/mplayer-9999.ebuild
index b1aa74bdc8ca..2e1f8ffe1c4b 100644
--- a/media-video/mplayer/mplayer-9999.ebuild
+++ b/media-video/mplayer/mplayer-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-9999.ebuild,v 1.82 2010/10/10 23:31:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-9999.ebuild,v 1.83 2010/11/01 13:50:53 scarabeus Exp $
EAPI=3
@@ -16,11 +16,12 @@ IUSE="3dnow 3dnowext +a52 aalib +alsa altivec aqua +ass bidi bindist bl bluray
bs2b +cddb +cdio cdparanoia cpudetection custom-cpuopts debug dga +dirac
directfb doc +dts +dv dvb +dvd +dvdnav dxr3 +enca +encode esd +faac +faad fbcon
ftp gif ggi gsm +iconv ipv6 jack joystick jpeg jpeg2k kernel_linux ladspa
-libcaca lirc +live lzo mad md5sum +mmx mmxext mng +mp3 nas +network nut openal
-amr +opengl +osdmenu oss png pnm pulseaudio pvr +quicktime radio +rar +real +rtc
-rtmp samba +shm +schroedinger sdl +speex sse sse2 ssse3 tga +theora +tremor
-+truetype +toolame +twolame +unicode v4l v4l2 vdpau vidix +vorbis vpx
-win32codecs +X +x264 xanim xinerama +xscreensaver +xv +xvid xvmc zoran"
+libcaca libmpeg2 lirc +live lzo mad md5sum +mmx mmxext mng +mp3 mpg123 nas
++network nut openal amr +opengl +osdmenu oss png pnm pulseaudio pvr +quicktime
+radio +rar +real +rtc rtmp samba +shm +schroedinger sdl +speex sse sse2 ssse3
+tga +theora +tremor +truetype +toolame +twolame +unicode v4l v4l2 vdpau vidix
++vorbis vpx win32codecs +X +x264 xanim xinerama +xscreensaver +xv +xvid xvmc
+zoran"
[[ ${PV} == *9999* ]] && IUSE+=" external-ffmpeg"
VIDEO_CARDS="s3virge mga tdfx vesa"
@@ -96,6 +97,10 @@ RDEPEND+="
dts? ( media-libs/libdca )
dv? ( media-libs/libdv )
dvb? ( media-tv/linuxtv-dvb-headers )
+ dvd? (
+ >=media-libs/libdvdread-4.1.3
+ dvdnav? ( >=media-libs/libdvdnav-4.1.3 )
+ )
encode? (
!twolame? ( toolame? ( media-sound/toolame ) )
twolame? ( media-sound/twolame )
@@ -115,11 +120,13 @@ RDEPEND+="
jpeg2k? ( media-libs/openjpeg )
ladspa? ( media-libs/ladspa-sdk )
libcaca? ( media-libs/libcaca )
+ libmpeg2? ( media-libs/libmpeg2 )
lirc? ( app-misc/lirc )
live? ( media-plugins/live )
lzo? ( >=dev-libs/lzo-2 )
mad? ( media-libs/libmad )
mng? ( media-libs/libmng )
+ mpg123? ( media-sound/mpg123 )
nas? ( media-libs/nas )
nut? ( >=media-libs/libnut-661 )
openal? ( media-libs/openal )
@@ -310,8 +317,8 @@ src_configure() {
# dvdread - accessing a DVD
# dvdnav - navigation of menus
#
- # internal dvdread and dvdnav use flags enable internal
- # versions of the libraries, which are snapshots of the fork.
+ # use external libdvdcss, dvdread and dvdnav
+ myconf+=" --disable-dvdread-internal --disable-libdvdcss-internal"
if use dvd; then
use dvdnav || myconf+=" --disable-dvdnav"
@@ -319,8 +326,6 @@ src_configure() {
myconf+="
--disable-dvdnav
--disable-dvdread
- --disable-dvdread-internal
- --disable-libdvdcss-internal
"
fi
@@ -382,7 +387,7 @@ src_configure() {
##########
myconf+=" --disable-musepack" # Use internal musepack codecs for SV7 and SV8 support
myconf+=" --disable-faad-internal" # always use system media-libs/faad2
- myconf+=" --disable-libmpeg2-internal" # always use system version
+ myconf+=" --disable-libmpeg2-internal" # always use system media-libs/libmpeg2
use dirac || myconf+=" --disable-libdirac-lavc"
use dts || myconf+=" --disable-libdca"
if ! use mp3; then
@@ -401,7 +406,7 @@ src_configure() {
# https://bugs.gentoo.org/show_bug.cgi?id=299405#c6
{ use amr && use !bindist ; } || myconf+=" --disable-libopencore_amrnb --disable-libopencore_amrwb"
- uses="faad gif jpeg live mad mng png pnm speex tga theora xanim"
+ uses="faad gif jpeg libmpeg2 live mad mng mpg123 png pnm speex tga theora xanim"
for i in ${uses}; do
use ${i} || myconf+=" --disable-${i}"
done
@@ -478,7 +483,7 @@ src_configure() {
use libcaca || myconf+=" --disable-caca"
use zoran || myconf+=" --disable-zr"
- if ! use kernel_linux && ! use video_cards_mga; then
+ if ! use kernel_linux || ! use video_cards_mga; then
myconf+=" --disable-mga --disable-xmga"
fi
@@ -605,7 +610,6 @@ src_configure() {
myconf+="
--enable-macosx-finder
--enable-macosx-bundle
- --enable-libdvdcss-internal
"
fi
@@ -616,12 +620,12 @@ src_configure() {
use external-ffmpeg && myconf+=" --disable-ffmpeg_a"
fi
- myconf="--cc=$(tc-getCC) \
- --host-cc=$(tc-getBUILD_CC) \
- --prefix=${EPREFIX}/usr \
- --confdir=${EPREFIX}/etc/mplayer \
- --datadir=${EPREFIX}/usr/share/mplayer \
- --libdir=${EPREFIX}/usr/$(get_libdir) \
+ myconf="--cc=$(tc-getCC)
+ --host-cc=$(tc-getBUILD_CC)
+ --prefix=${EPREFIX}/usr
+ --confdir=${EPREFIX}/etc/mplayer
+ --datadir=${EPREFIX}/usr/share/mplayer
+ --libdir=${EPREFIX}/usr/$(get_libdir)
${myconf}"
CFLAGS="${CFLAGS}" ./configure ${myconf} || die "configure died"