summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-09-21 15:21:46 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-09-21 15:21:46 +0000
commit84bf1edb2d5f9ef999804fe7c536d64b5ccfb3c6 (patch)
tree74f9f8f28f0bdd4519142bf8ee99bb761a85deed /media-video
parentx86 stable, thanks JD, bug 383407 (diff)
downloadgentoo-2-84bf1edb2d5f9ef999804fe7c536d64b5ccfb3c6.tar.gz
gentoo-2-84bf1edb2d5f9ef999804fe7c536d64b5ccfb3c6.tar.bz2
gentoo-2-84bf1edb2d5f9ef999804fe7c536d64b5ccfb3c6.zip
add cdio useflag
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ChangeLog6
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild12
-rw-r--r--media-video/ffmpeg/metadata.xml1
3 files changed, 13 insertions, 6 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index ea32564f6fa7..ec8ab4e53a4a 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.455 2011/09/17 16:48:57 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.456 2011/09/21 15:21:46 aballier Exp $
+
+ 21 Sep 2011; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild,
+ metadata.xml:
+ add cdio useflag
17 Sep 2011; Raúl Porcel <armin76@gentoo.org> ffmpeg-0.7.4.ebuild:
alpha/ia64/sparc stable wrt #382301
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 6001a6babb3c..23c426cd42f5 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.53 2011/09/06 18:02:14 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.54 2011/09/21 15:21:46 aballier Exp $
EAPI="4"
@@ -29,10 +29,10 @@ if [ "${PV#9999}" = "${PV}" ] ; then
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
fi
IUSE="
- aac alsa amr bindist +bzip2 celt cpudetection debug dirac doc +encode faac
- frei0r gsm +hardcoded-tables ieee1394 jack jpeg2k mp3 network openal oss pic
- qt-faststart rtmp schroedinger sdl speex static-libs test theora threads
- truetype v4l v4l2 vaapi vdpau vorbis vpx X x264 xvid +zlib
+ aac alsa amr bindist +bzip2 cdio celt cpudetection debug dirac doc +encode
+ faac frei0r gsm +hardcoded-tables ieee1394 jack jpeg2k mp3 network openal
+ oss pic qt-faststart rtmp schroedinger sdl speex static-libs test theora
+ threads truetype v4l v4l2 vaapi vdpau vorbis vpx X x264 xvid +zlib
"
# String for CPU features in the useflag[:configure_option] form
@@ -47,6 +47,7 @@ RDEPEND="
alsa? ( media-libs/alsa-lib )
amr? ( media-libs/opencore-amr )
bzip2? ( app-arch/bzip2 )
+ cdio? ( dev-libs/libcdio )
celt? ( >=media-libs/celt-0.11.1 )
dirac? ( media-video/dirac )
encode? (
@@ -131,6 +132,7 @@ src_configure() {
fi
# libavdevice options
+ use cdio && myconf="${myconf} --enable-libcdio"
use ieee1394 && myconf="${myconf} --enable-libdc1394"
use openal && myconf="${myconf} --enable-openal"
# Indevs
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index 74cfe07c49c3..a9c5be50711a 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -13,6 +13,7 @@
</flag>
<flag name="amr">Enables Adaptive Multi-Rate Audio support</flag>
<flag name="avx">Adds support for Advanced Vector Extensions instructions (Intel Sandy Bridge, AMD Bulldozer and later chips)</flag>
+ <flag name="cdio">Enables audio CD grabbing with <pkg>dev-libs/libcdio</pkg>.</flag>
<flag name="celt">Adds Xiph CELT/Opus audio decoding support via <pkg>media-libs/celt</pkg></flag>
<flag name="cpudetection">Enables runtime CPU detection (useful for bindist, compatibility on other CPUs)</flag>
<flag name="dirac">Enable Dirac video support (an advanced royalty-free video compression format) via the reference library: dirac.</flag>