summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2010-02-14 12:44:56 +0000
committerHanno Böck <hanno@gentoo.org>2010-02-14 12:44:56 +0000
commitfc63e52d1b20da8bb16e3a8d9aca05ff51b1661a (patch)
tree018c10b3e32cdbba45cb8ffd0d4814c4e19d1875 /media-video
parentversion bump, with static-libs USE-flag (diff)
downloadgentoo-2-fc63e52d1b20da8bb16e3a8d9aca05ff51b1661a.tar.gz
gentoo-2-fc63e52d1b20da8bb16e3a8d9aca05ff51b1661a.tar.bz2
gentoo-2-fc63e52d1b20da8bb16e3a8d9aca05ff51b1661a.zip
cclive bump
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/cclive/ChangeLog7
-rw-r--r--media-video/cclive/cclive-0.6.1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/media-video/cclive/ChangeLog b/media-video/cclive/ChangeLog
index 7e6665631f0f..040bea652ea4 100644
--- a/media-video/cclive/ChangeLog
+++ b/media-video/cclive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/cclive
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cclive/ChangeLog,v 1.14 2010/02/06 13:26:17 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cclive/ChangeLog,v 1.15 2010/02/14 12:44:56 hanno Exp $
+
+*cclive-0.6.1 (14 Feb 2010)
+
+ 14 Feb 2010; Hanno Boeck <hanno@gentoo.org> +cclive-0.6.1.ebuild:
+ Version bump.
06 Feb 2010; Markos Chandras <hwoarang@gentoo.org> cclive-0.5.3.ebuild:
Stable on amd64 wrt bug #287175
diff --git a/media-video/cclive/cclive-0.6.1.ebuild b/media-video/cclive/cclive-0.6.1.ebuild
new file mode 100644
index 000000000000..ddfd407e7ac1
--- /dev/null
+++ b/media-video/cclive/cclive-0.6.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/cclive/cclive-0.6.1.ebuild,v 1.1 2010/02/14 12:44:56 hanno Exp $
+
+EAPI=2
+
+DESCRIPTION="Command line tool for extracting videos from various websites"
+HOMEPAGE="http://code.google.com/p/cclive/"
+SRC_URI="http://cclive.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test offensive"
+
+RDEPEND="media-libs/quvi"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --with-man \
+ $(use_enable test tests)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+}
+
+src_test() {
+ local value
+
+ ewarn "Tests require internet connection in order to work."
+
+ use offensive && value="true" || value="false"
+ ADULT_OK="${value}" emake check || die "emake test failed"
+}