summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-02-01 20:57:14 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-02-01 20:57:14 +0000
commitba075f3d08d8f6ece3806bd3a00fe574195f1fce (patch)
tree5eff2220d0a61a00570f43de04594ef936489961 /net-analyzer/FlowScan
parentcleanup (diff)
downloadgentoo-2-ba075f3d08d8f6ece3806bd3a00fe574195f1fce.tar.gz
gentoo-2-ba075f3d08d8f6ece3806bd3a00fe574195f1fce.tar.bz2
gentoo-2-ba075f3d08d8f6ece3806bd3a00fe574195f1fce.zip
fix exec bit
(Portage version: 2.1.2-r1)
Diffstat (limited to 'net-analyzer/FlowScan')
-rw-r--r--net-analyzer/FlowScan/ChangeLog5
-rwxr-xr-xnet-analyzer/FlowScan/files/flowscan.init17
2 files changed, 21 insertions, 1 deletions
diff --git a/net-analyzer/FlowScan/ChangeLog b/net-analyzer/FlowScan/ChangeLog
index e80f94e3f503..7a2b188b89dd 100644
--- a/net-analyzer/FlowScan/ChangeLog
+++ b/net-analyzer/FlowScan/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/FlowScan
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/FlowScan/ChangeLog,v 1.8 2007/02/01 20:56:27 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/FlowScan/ChangeLog,v 1.9 2007/02/01 20:57:14 jokey Exp $
+
+ 01 Feb 2007; Markus Ullmann <jokey@gentoo.org> +files/flowscan.init:
+ fix exec bit
01 Feb 2007; Markus Ullmann <jokey@gentoo.org> -files/flowscan.init,
-FlowScan-1.006.ebuild, -FlowScan-1.006-r1.ebuild:
diff --git a/net-analyzer/FlowScan/files/flowscan.init b/net-analyzer/FlowScan/files/flowscan.init
new file mode 100755
index 000000000000..42b7ccaf3d05
--- /dev/null
+++ b/net-analyzer/FlowScan/files/flowscan.init
@@ -0,0 +1,17 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting flowscan processing"
+ cd /var/lib/flows ; start-stop-daemon --start --quiet -c flows:flows --exec bin/flowscan \
+ -p /var/run/flows/flowscan.pid -m -b >> /var/log/flowscan 2>&1 </dev/null & >/dev/null
+}
+
+stop() {
+ start-stop-daemon --stop --quiet -p /var/run/flows/flowscan.pid
+}