summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-11-05 02:58:44 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-11-05 02:58:44 +0000
commita943d3541041347ff382c286a9ea023254e1abcc (patch)
tree6b6808fb95d67617ecd754686129c223f9872b56 /net-analyzer/bwmon/bwmon-1.3-r2.ebuild
parentversion bump (diff)
downloadgentoo-2-a943d3541041347ff382c286a9ea023254e1abcc.tar.gz
gentoo-2-a943d3541041347ff382c286a9ea023254e1abcc.tar.bz2
gentoo-2-a943d3541041347ff382c286a9ea023254e1abcc.zip
Fix overflow identified by Vicente Olivert Riera in bug #441420; use a patch instead of a chain of seds for the makefile changes, which also saves us from using flag-o-matic.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'net-analyzer/bwmon/bwmon-1.3-r2.ebuild')
-rw-r--r--net-analyzer/bwmon/bwmon-1.3-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-analyzer/bwmon/bwmon-1.3-r2.ebuild b/net-analyzer/bwmon/bwmon-1.3-r2.ebuild
new file mode 100644
index 000000000000..70bcf33f8b06
--- /dev/null
+++ b/net-analyzer/bwmon/bwmon-1.3-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bwmon/bwmon-1.3-r2.ebuild,v 1.1 2012/11/05 02:58:44 flameeyes Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Simple ncurses bandwidth monitor"
+HOMEPAGE="http://bwmon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="GPL-2 public-domain"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ # Fix a typo in help wrt bug #263326
+ epatch "${FILESDIR}"/${P}-typo-fix.patch
+ epatch "${FILESDIR}"/${P}-overflow.patch
+}
+
+src_compile() {
+ emake -Csrc CC="$(tc-getCC)"
+}
+
+src_install () {
+ dobin ${PN}
+ dodoc README
+}