summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-06-03 04:11:05 +0000
committerRick Farina <zerochaos@gentoo.org>2013-06-03 04:11:05 +0000
commit2a712a1b3b9f93f516b04e2845d42912b0b18ba7 (patch)
tree0e8479c113250689dbf3624d263cb3b1df39151f /net-analyzer/cloudshark
parentBump (diff)
downloadgentoo-2-2a712a1b3b9f93f516b04e2845d42912b0b18ba7.tar.gz
gentoo-2-2a712a1b3b9f93f516b04e2845d42912b0b18ba7.tar.bz2
gentoo-2-2a712a1b3b9f93f516b04e2845d42912b0b18ba7.zip
cloudshark initial commit
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'net-analyzer/cloudshark')
-rw-r--r--net-analyzer/cloudshark/ChangeLog9
-rw-r--r--net-analyzer/cloudshark/cloudshark-1.0.2.174.ebuild49
-rw-r--r--net-analyzer/cloudshark/files/cs_log_dir.patch13
-rw-r--r--net-analyzer/cloudshark/metadata.xml12
4 files changed, 83 insertions, 0 deletions
diff --git a/net-analyzer/cloudshark/ChangeLog b/net-analyzer/cloudshark/ChangeLog
new file mode 100644
index 000000000000..f6e8f93447bb
--- /dev/null
+++ b/net-analyzer/cloudshark/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-analyzer/cloudshark
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cloudshark/ChangeLog,v 1.1 2013/06/03 04:11:05 zerochaos Exp $
+
+*cloudshark-1.0.2.174 (03 Jun 2013)
+
+ 03 Jun 2013; Rick Farina <zerochaos@gentoo.org> +cloudshark-1.0.2.174.ebuild,
+ +files/cs_log_dir.patch, +metadata.xml:
+ cloudshark initial commit
diff --git a/net-analyzer/cloudshark/cloudshark-1.0.2.174.ebuild b/net-analyzer/cloudshark/cloudshark-1.0.2.174.ebuild
new file mode 100644
index 000000000000..137e58845fa6
--- /dev/null
+++ b/net-analyzer/cloudshark/cloudshark-1.0.2.174.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cloudshark/cloudshark-1.0.2.174.ebuild,v 1.1 2013/06/03 04:11:05 zerochaos Exp $
+
+EAPI=5
+
+inherit eutils multilib
+
+SV="1.0.2-174"
+
+DESCRIPTION="Instantly Upload Your WIRESHARK CAPTURES to CloudShark."
+HOMEPAGE="http://appliance.cloudshark.org/plug-ins-wireshark.html"
+SRC_URI="http://appliance.cloudshark.org/downloads/${PN}-plugin-${SV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+PDEPEND="net-analyzer/wireshark:=[lua]
+ net-misc/curl"
+
+S="${WORKDIR}/${PN}-${SV}"
+
+get_PV() { local pv=$(best_version $1); pv=${pv#$1-}; pv=${pv%-r*}; pv=${pv//_}; echo ${pv}; }
+
+src_prepare() {
+ #cloudshark isn't meant to be installed systemwide, most of this is caused by that fact
+ epatch "${FILESDIR}"/cs_log_dir.patch
+
+ sed -i "s#%s/cloudshark_init.lua#/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)/cloudshark_init.lua#" cloudshark.lua
+ #the echo line seemed a cleaner solution but it causes errors, looks like it expects windows paths only
+ #echo "CLOUDSHARK_CABUNDLE = /usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)/curl-ca-bundle.crt" >> cloudshark_init.default
+ sed -i "s#%s/curl-ca-bundle.crt#/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)/curl-ca-bundle.crt#" cloudshark.lua
+
+ #stuff to fix cloudshark_init.default to be more sane
+ #sed -i 's#CLOUDSHARK_TSHARK = "n"#CLOUDSHARK_TSHARK = "y"#' cloudshark_init.default (tshark support doesn't seem to work)
+}
+
+src_test() {
+ [ "md5sum install-unix" -ne "405cb4dd526bf5261bbb56714baa67f0 install-unix" ] && die "install instructions have changed"
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)
+ doins cloudshark.lua json.lua version.lua curl-ca-bundle.crt
+ newins cloudshark_init.default cloudshark_init.lua
+ dodoc CLOUDSHARK_README.txt
+}
diff --git a/net-analyzer/cloudshark/files/cs_log_dir.patch b/net-analyzer/cloudshark/files/cs_log_dir.patch
new file mode 100644
index 000000000000..9b0424e3cd44
--- /dev/null
+++ b/net-analyzer/cloudshark/files/cs_log_dir.patch
@@ -0,0 +1,13 @@
+diff -Naur cloudshark-1.0.2-174-orig/cloudshark.lua cloudshark-1.0.2-174/cloudshark.lua
+--- cloudshark-1.0.2-174-orig/cloudshark.lua 2013-06-03 00:00:46.669223099 -0400
++++ cloudshark-1.0.2-174/cloudshark.lua 2013-06-03 00:01:31.493224300 -0400
+@@ -180,7 +180,8 @@
+ --
+
+ function cs_log_dir()
+- return persconffile_path('plugins/cloudshark')
++ local log_dir = "/tmp"
++ return log_dir
+ end
+
+ --
diff --git a/net-analyzer/cloudshark/metadata.xml b/net-analyzer/cloudshark/metadata.xml
new file mode 100644
index 000000000000..8c85303e2d1e
--- /dev/null
+++ b/net-analyzer/cloudshark/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>zerochaos@gentoo.org</email>
+<name>Rick Farina</name>
+</maintainer>
+<herd>netmon</herd>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+