summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-10-26 09:39:26 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-10-26 09:39:26 +0000
commitb6cc01dae65f4a55e4d4eae5be3943b8b0c9b98d (patch)
treec5a744edb17a9e107afad8c09a9500e47a061d8a /net-analyzer/echoping
parentFix description (diff)
downloadgentoo-2-b6cc01dae65f4a55e4d4eae5be3943b8b0c9b98d.tar.gz
gentoo-2-b6cc01dae65f4a55e4d4eae5be3943b8b0c9b98d.tar.bz2
gentoo-2-b6cc01dae65f4a55e4d4eae5be3943b8b0c9b98d.zip
Revision bump: EAPI 4, use default src_install, proper handling of 'ssl' and 'gnutls' USE flags
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-analyzer/echoping')
-rw-r--r--net-analyzer/echoping/ChangeLog8
-rw-r--r--net-analyzer/echoping/echoping-6.0.2-r2.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/net-analyzer/echoping/ChangeLog b/net-analyzer/echoping/ChangeLog
index 0eb99685a2d1..a34be316c150 100644
--- a/net-analyzer/echoping/ChangeLog
+++ b/net-analyzer/echoping/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/echoping
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/echoping/ChangeLog,v 1.25 2012/10/26 09:36:11 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/echoping/ChangeLog,v 1.26 2012/10/26 09:39:26 pinkbyte Exp $
+
+*echoping-6.0.2-r2 (26 Oct 2012)
+
+ 26 Oct 2012; Sergey Popov <pinkbyte@gentoo.org> +echoping-6.0.2-r2.ebuild:
+ Revision bump: EAPI 4, use default src_install, proper handling of 'ssl' and
+ 'gnutls' USE flags
26 Oct 2012; Sergey Popov <pinkbyte@gentoo.org> echoping-6.0.2-r1.ebuild:
Fix description
diff --git a/net-analyzer/echoping/echoping-6.0.2-r2.ebuild b/net-analyzer/echoping/echoping-6.0.2-r2.ebuild
new file mode 100644
index 000000000000..2889cf7eae26
--- /dev/null
+++ b/net-analyzer/echoping/echoping-6.0.2-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/echoping/echoping-6.0.2-r2.ebuild,v 1.1 2012/10/26 09:39:26 pinkbyte Exp $
+
+EAPI="4"
+
+inherit eutils autotools
+
+DESCRIPTION="Small program to test performances of remote servers"
+HOMEPAGE="http://echoping.sourceforge.net/"
+SRC_URI="mirror://sourceforge/echoping/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnutls http icp idn priority smtp ssl tos postgres ldap"
+RESTRICT="test"
+
+RDEPEND="idn? ( net-dns/libidn )
+ postgres? ( dev-db/postgresql-base )
+ ldap? ( net-nds/openldap )
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.0.17 )
+ !gnutls? ( >=dev-libs/openssl-0.9.7d )
+ )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2"
+
+REQUIRED_USE="gnutls? ( ssl )"
+
+DOCS=( README AUTHORS ChangeLog DETAILS NEWS TODO )
+
+src_prepare() {
+ # bug 279525:
+ epatch "${FILESDIR}/${P}-gnutls.patch"
+
+ epatch "${FILESDIR}/${P}-fix_implicit_declarations.patch"
+
+ rm -f ltmain.sh
+ cp /usr/share/libtool/config/ltmain.sh .
+ local i
+ for i in . plugins/ plugins/*/; do
+ pushd "${i}" > /dev/null
+ eautoreconf
+ popd > /dev/null
+ done
+}
+
+src_configure() {
+ econf \
+ --config-cache \
+ --disable-ttcp \
+ $(use_enable http) \
+ $(use_enable icp) \
+ $(use_with idn libidn) \
+ $(use_enable smtp) \
+ $(use_enable tos) \
+ $(use_enable priority) \
+ $(usex gnutls $(use_with gnutls) $(use_with ssl))
+}