summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-03-15 13:42:30 +0000
committerJeroen Roovers <jer@gentoo.org>2014-03-15 13:42:30 +0000
commit84ad1f45a5af1e53e65405fd16be12248195818c (patch)
tree76731d957835ec4c468937564327555f8548e4b9 /net-analyzer/fail2ban
parentold (diff)
downloadgentoo-2-84ad1f45a5af1e53e65405fd16be12248195818c.tar.gz
gentoo-2-84ad1f45a5af1e53e65405fd16be12248195818c.tar.bz2
gentoo-2-84ad1f45a5af1e53e65405fd16be12248195818c.zip
Version bump (bug #497334).
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/fail2ban')
-rw-r--r--net-analyzer/fail2ban/ChangeLog8
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.9.0.ebuild84
-rw-r--r--net-analyzer/fail2ban/files/fail2ban-0.9.0-empty-run-dir.patch12
3 files changed, 103 insertions, 1 deletions
diff --git a/net-analyzer/fail2ban/ChangeLog b/net-analyzer/fail2ban/ChangeLog
index 481827ba5ba5..94e03bb25e4b 100644
--- a/net-analyzer/fail2ban/ChangeLog
+++ b/net-analyzer/fail2ban/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/fail2ban
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.127 2014/02/13 01:17:28 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.128 2014/03/15 13:42:30 jer Exp $
+
+*fail2ban-0.9.0 (15 Mar 2014)
+
+ 15 Mar 2014; Jeroen Roovers <jer@gentoo.org> +fail2ban-0.9.0.ebuild,
+ +files/fail2ban-0.9.0-empty-run-dir.patch:
+ Version bump (bug #497334).
*fail2ban-0.8.12-r1 (13 Feb 2014)
diff --git a/net-analyzer/fail2ban/fail2ban-0.9.0.ebuild b/net-analyzer/fail2ban/fail2ban-0.9.0.ebuild
new file mode 100644
index 000000000000..4dd1ff0c31b5
--- /dev/null
+++ b/net-analyzer/fail2ban/fail2ban-0.9.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.9.0.ebuild,v 1.1 2014/03/15 13:42:30 jer Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1 systemd vcs-snapshot
+
+DESCRIPTION="scans log files and bans IPs that show malicious signs"
+HOMEPAGE="http://www.fail2ban.org/"
+SRC_URI="https://github.com/${PN}/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="selinux"
+
+DEPEND="selinux? ( sec-policy/selinux-fail2ban )"
+RDEPEND="net-misc/whois
+ virtual/mta
+ virtual/logger
+ net-firewall/iptables
+ selinux? ( sec-policy/selinux-fail2ban )"
+
+DOCS=( ChangeLog DEVELOP README.md THANKS TODO doc/run-rootless.txt )
+
+src_prepare() {
+ # Replace /var/run with /run, but not in the top source directory
+ sed -i -e 's|/var\(/run/fail2ban\)|\1|g' $( find . -type f -mindepth 2 ) || die
+
+ # Do not install /run/fail2ban
+ epatch "${FILESDIR}"/${P}-empty-run-dir.patch
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ ${EPYTHON} bin/${PN}-testcases
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ rm -rf "${D}"/usr/share/doc/${PN}
+
+ # not FILESDIR
+ newconfd files/gentoo-confd ${PN}
+ newinitd files/gentoo-initd ${PN}
+ systemd_dounit files/${PN}.service
+ systemd_dotmpfilesd files/${PN}-tmpfiles.conf
+ doman man/*.{1,5}
+
+ # Use INSTALL_MASK if you do not want to touch /etc/logrotate.d.
+ # See http://thread.gmane.org/gmane.linux.gentoo.devel/35675
+ insinto /etc/logrotate.d
+ newins files/${PN}-logrotate ${PN}
+}
+
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.7"
+ previous_less_than_0_7=$?
+}
+
+pkg_postinst() {
+ if [[ $previous_less_than_0_7 = 0 ]] ; then
+ elog
+ elog "Configuration files are now in /etc/fail2ban/"
+ elog "You probably have to manually update your configuration"
+ elog "files before restarting Fail2ban!"
+ elog
+ elog "Fail2ban is not installed under /usr/lib anymore. The"
+ elog "new location is under /usr/share."
+ elog
+ elog "You are upgrading from version 0.6.x, please see:"
+ elog "http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
+ fi
+ if ! has_version ${CATEGORY}/${PN} && \
+ ! has_version dev-python/pyinotify && ! has_version app-admin/gamin; then
+ elog "For most jail.conf configurations, it is recommended you install either"
+ elog "dev-python/pyinotify or app-admin/gamin (in order of preference)"
+ elog "to control how log file modifications are detected"
+ fi
+}
diff --git a/net-analyzer/fail2ban/files/fail2ban-0.9.0-empty-run-dir.patch b/net-analyzer/fail2ban/files/fail2ban-0.9.0-empty-run-dir.patch
new file mode 100644
index 000000000000..ffefb4fd9bb4
--- /dev/null
+++ b/net-analyzer/fail2ban/files/fail2ban-0.9.0-empty-run-dir.patch
@@ -0,0 +1,12 @@
+--- setup.py.orig 2014-03-15 13:54:02.423214751 +0100
++++ setup.py 2014-03-15 14:00:37.008932705 +0100
+@@ -136,9 +136,6 @@
+ ('/etc/fail2ban/jail.d',
+ ''
+ ),
+- ('/var/run/fail2ban',
+- ''
+- ),
+ ('/var/lib/fail2ban',
+ ''
+ ),