summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-12-07 16:24:58 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-12-07 16:24:58 +0000
commitabbf95f28de7814abf40697c0f8ce57deea6c176 (patch)
treef2810ba5c6ada55a2fe19aa0f9ad7cd14083d763 /net-analyzer/fragroute
parentStable for ppc, wrt bug #421351 (diff)
downloadgentoo-2-abbf95f28de7814abf40697c0f8ce57deea6c176.tar.gz
gentoo-2-abbf95f28de7814abf40697c0f8ce57deea6c176.tar.bz2
gentoo-2-abbf95f28de7814abf40697c0f8ce57deea6c176.zip
Version bump
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-analyzer/fragroute')
-rw-r--r--net-analyzer/fragroute/ChangeLog7
-rw-r--r--net-analyzer/fragroute/fragroute-1.2.6.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/net-analyzer/fragroute/ChangeLog b/net-analyzer/fragroute/ChangeLog
index 550184da1a4a..045817d0e56c 100644
--- a/net-analyzer/fragroute/ChangeLog
+++ b/net-analyzer/fragroute/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/fragroute
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fragroute/ChangeLog,v 1.26 2012/10/16 12:17:14 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fragroute/ChangeLog,v 1.27 2012/12/07 16:24:58 pinkbyte Exp $
+
+*fragroute-1.2.6 (07 Dec 2012)
+
+ 07 Dec 2012; Sergey Popov <pinkbyte@gentoo.org> +fragroute-1.2.6.ebuild:
+ Version bump
16 Oct 2012; Anthony G. Basile <blueness@gentoo.org> fragroute-1.2.5.ebuild:
Keyword ~ppc ~ppc64, request by Pinkbyte
diff --git a/net-analyzer/fragroute/fragroute-1.2.6.ebuild b/net-analyzer/fragroute/fragroute-1.2.6.ebuild
new file mode 100644
index 000000000000..87a960a37a8d
--- /dev/null
+++ b/net-analyzer/fragroute/fragroute-1.2.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fragroute/fragroute-1.2.6.ebuild,v 1.1 2012/12/07 16:24:58 pinkbyte Exp $
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+MY_P="${P}-ipv6"
+
+inherit autotools-utils
+
+DESCRIPTION="Testing of network intrusion detection systems, firewalls and TCP/IP stacks"
+HOMEPAGE="http://code.google.com/p/fragroute-ipv6/"
+SRC_URI="http://fragroute-ipv6.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libevent
+ net-libs/libpcap
+ >=dev-libs/libdnet-1.12[ipv6]
+"
+DEPEND="${RDEPEND}
+ virtual/awk"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( INSTALL README TODO )
+
+src_prepare() {
+ # Remove broken and old files, autotools will regen needed files
+ rm *.m4 acconfig.h missing Makefile.in || die 'removing of old stuff failed'
+ # Add missing includes
+ sed -i -e "/#define IPUTIL_H/a#include <stdio.h>\n#include <stdint.h>" iputil.h || die 'sed on iputil.h failed'
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-libevent="${EPREFIX}"/usr \
+ --with-libdnet="${EPREFIX}"/usr \
+ --with-libpcap="${EPREFIX}"/usr
+ )
+ autotools-utils_src_configure
+}