summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2013-07-01 10:26:55 +0000
committerHanno Böck <hanno@gentoo.org>2013-07-01 10:26:55 +0000
commitd991367064b8f931b11d49dfcb8cdc297e7e0b17 (patch)
tree75f3282ed4b83df325e5eced02cac02906f5ded4 /net-analyzer/greenbone-security-assistant
parentopenvas-administrator: Bump, EAPI 5 port, remove old workarounds. (diff)
downloadgentoo-2-d991367064b8f931b11d49dfcb8cdc297e7e0b17.tar.gz
gentoo-2-d991367064b8f931b11d49dfcb8cdc297e7e0b17.tar.bz2
gentoo-2-d991367064b8f931b11d49dfcb8cdc297e7e0b17.zip
greenbone-security-assistant: Bump, EAPI 5 port, remove old workarounds.
(Portage version: 2.1.12.11/cvs/Linux x86_64, signed Manifest commit with key 0xA5880072BBB51E42)
Diffstat (limited to 'net-analyzer/greenbone-security-assistant')
-rw-r--r--net-analyzer/greenbone-security-assistant/ChangeLog10
-rw-r--r--net-analyzer/greenbone-security-assistant/greenbone-security-assistant-4.0.1.ebuild37
2 files changed, 45 insertions, 2 deletions
diff --git a/net-analyzer/greenbone-security-assistant/ChangeLog b/net-analyzer/greenbone-security-assistant/ChangeLog
index a80a8f26619a..a38c345bc250 100644
--- a/net-analyzer/greenbone-security-assistant/ChangeLog
+++ b/net-analyzer/greenbone-security-assistant/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/greenbone-security-assistant
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/greenbone-security-assistant/ChangeLog,v 1.3 2012/05/04 06:08:09 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/greenbone-security-assistant/ChangeLog,v 1.4 2013/07/01 10:26:55 hanno Exp $
+
+*greenbone-security-assistant-4.0.1 (01 Jul 2013)
+
+ 01 Jul 2013; Hanno Boeck <hanno@gentoo.org>
+ +greenbone-security-assistant-4.0.1.ebuild:
+ Bump, EAPI 5 port, remove old workarounds.
04 May 2012; Jeff Horelick <jdhore@gentoo.org>
greenbone-security-assistant-2.0.1.ebuild:
diff --git a/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-4.0.1.ebuild b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-4.0.1.ebuild
new file mode 100644
index 000000000000..67184072a5b9
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-4.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-4.0.1.ebuild,v 1.1 2013/07/01 10:26:55 hanno Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Greenbone Security Assistant for openvas"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="http://wald.intevation.org/frs/download.php/1335/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=net-analyzer/openvas-libraries-6.0.0
+ dev-libs/libxslt
+ net-libs/libmicrohttpd[messages]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="ChangeLog CHANGES README"
+
+src_configure() {
+ local mycmakeargs=(
+ "-DLOCALSTATEDIR=${EPREFIX}/var"
+ "-DSYSCONFDIR=${EPREFIX}/etc"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doinitd "${FILESDIR}"/gsad
+}