summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-06-10 18:45:52 +0000
committerJeroen Roovers <jer@gentoo.org>2013-06-10 18:45:52 +0000
commitef8737f50c7052cf539eddc3740d14e6fcfc4b69 (patch)
treebda930af3d37b5317331c5c18321b84e605f06e8 /net-analyzer/httping
parentDrop qt4 default enabled wrt bug #472876. (diff)
downloadgentoo-2-ef8737f50c7052cf539eddc3740d14e6fcfc4b69.tar.gz
gentoo-2-ef8737f50c7052cf539eddc3740d14e6fcfc4b69.tar.bz2
gentoo-2-ef8737f50c7052cf539eddc3740d14e6fcfc4b69.zip
Version bump.
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/httping')
-rw-r--r--net-analyzer/httping/ChangeLog7
-rw-r--r--net-analyzer/httping/httping-2.3.3.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/net-analyzer/httping/ChangeLog b/net-analyzer/httping/ChangeLog
index 355df905ae5b..76a7d719b2be 100644
--- a/net-analyzer/httping/ChangeLog
+++ b/net-analyzer/httping/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/httping
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.108 2013/05/16 15:47:01 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.109 2013/06/10 18:45:52 jer Exp $
+
+*httping-2.3.3 (10 Jun 2013)
+
+ 10 Jun 2013; Jeroen Roovers <jer@gentoo.org> +httping-2.3.3.ebuild:
+ Version bump.
16 May 2013; Jeroen Roovers <jer@gentoo.org> -httping-1.5.5.ebuild,
-httping-1.5.8.ebuild, -httping-2.0.ebuild, -httping-2.1.ebuild,
diff --git a/net-analyzer/httping/httping-2.3.3.ebuild b/net-analyzer/httping/httping-2.3.3.ebuild
new file mode 100644
index 000000000000..dbe5edc80379
--- /dev/null
+++ b/net-analyzer/httping/httping-2.3.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-2.3.3.ebuild,v 1.1 2013/06/10 18:45:52 jer Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="http protocol ping-like program"
+HOMEPAGE="http://www.vanheusden.com/httping/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug fftw ncurses ssl tfo"
+
+RDEPEND="
+ fftw? ( sci-libs/fftw:3.0 )
+ ncurses? ( >=sys-libs/ncurses-5 )
+ ssl? ( dev-libs/openssl )
+"
+DEPEND="${RDEPEND}"
+
+# This would bring in test? ( dev-util/cppcheck ) but unlike
+# upstream we should only care about compile/run time testing
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.2.1-flags.patch
+}
+
+src_configure() {
+ # not an autotools script
+ echo > makefile.inc || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ FW=$(usex fftw) \
+ DEBUG=$(usex debug) \
+ NC=$(usex ncurses) \
+ SSL=$(usex ssl) \
+ TFO=$(usex tfo)
+}
+
+src_install() {
+ dobin httping
+ doman httping.1
+}