summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-07-17 03:05:42 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-07-17 03:05:42 +0000
commitae0115c8b72323369fb5a8c3ee221cdcb4e1f0d4 (patch)
tree8a26ed0c31559069366bb054d65d741ae75fff89 /net-analyzer/icinga2
parentbump; add optional deps pyro:4, pyzmq (diff)
downloadgentoo-2-ae0115c8b72323369fb5a8c3ee221cdcb4e1f0d4.tar.gz
gentoo-2-ae0115c8b72323369fb5a8c3ee221cdcb4e1f0d4.tar.bz2
gentoo-2-ae0115c8b72323369fb5a8c3ee221cdcb4e1f0d4.zip
bup
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'net-analyzer/icinga2')
-rw-r--r--net-analyzer/icinga2/ChangeLog7
-rw-r--r--net-analyzer/icinga2/icinga2-2.0.1.ebuild109
2 files changed, 115 insertions, 1 deletions
diff --git a/net-analyzer/icinga2/ChangeLog b/net-analyzer/icinga2/ChangeLog
index 44abaf231507..1f362e5bc836 100644
--- a/net-analyzer/icinga2/ChangeLog
+++ b/net-analyzer/icinga2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/icinga2
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga2/ChangeLog,v 1.2 2014/06/16 15:35:03 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga2/ChangeLog,v 1.3 2014/07/17 03:05:42 prometheanfire Exp $
+
+*icinga2-2.0.1 (17 Jul 2014)
+
+ 17 Jul 2014; Matthew Thode <prometheanfire@gentoo.org> +icinga2-2.0.1.ebuild:
+ bup
*icinga2-2.0.0 (16 Jun 2014)
diff --git a/net-analyzer/icinga2/icinga2-2.0.1.ebuild b/net-analyzer/icinga2/icinga2-2.0.1.ebuild
new file mode 100644
index 000000000000..295f024347dc
--- /dev/null
+++ b/net-analyzer/icinga2/icinga2-2.0.1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga2/icinga2-2.0.1.ebuild,v 1.1 2014/07/17 03:05:42 prometheanfire Exp $
+
+EAPI=5
+inherit depend.apache eutils cmake-utils toolchain-funcs user versionator systemd
+
+DESCRIPTION="Nagios Fork - Check daemon, CGIs, docs, IDOutils. Reloaded"
+HOMEPAGE="http://icinga.org/icinga2"
+#PV=$(replace_version_separator 3 '-')
+SRC_URI="http://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+#S="${WORKDIR}/${PN}-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres classicui +plugins"
+
+DEPEND="dev-util/cmake
+ dev-libs/openssl
+ dev-libs/boost
+ sys-devel/bison
+ sys-devel/flex
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql-base )"
+
+RDEPEND="${DEPEND}
+ plugins? ( net-analyzer/nagios-plugins )
+ classicui? ( net-analyzer/icinga[web] )"
+
+REQUIRED_USE="|| ( mysql postgres )"
+
+want_apache2
+
+pkg_setup() {
+ enewgroup icinga
+ enewgroup icingacmd
+ enewuser icinga -1 -1 /var/lib/icinga2 "icinga,icingacmd"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ -DCMAKE_BUILD_TYPE=None
+ -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc
+ -DCMAKE_INSTALL_LOCALSTATEDIR=/var
+ -DICINGA2_SYSCONFIGFILE=/etc/conf.d/icinga2
+ -DICINGA2_USER=icinga
+ -DICINGA2_GROUP=icingacmd
+ -DICINGA2_COMMAND_USER=icinga
+ -DICINGA2_COMMAND_GROUP=icingacmd
+ -DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=yes
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ BUILDDIR="${WORKDIR}"/icinga2-${PV}_build
+ cd $BUILDDIR
+
+ #if [[ -f Makefile ]] || [[ -f GNUmakefile ]] || [[ -f makefile ]] ; then
+
+ emake DESTDIR="${D}" install
+ #fi
+
+ cd "${WORKDIR}"/icinga2-${PV}
+ if ! declare -p DOCS >/dev/null 2>&1 ; then
+ local d
+ for d in README* ChangeLog AUTHORS NEWS TODO CHANGES THANKS BUGS \
+ FAQ CREDITS CHANGELOG ; do
+ [[ -s "${d}" ]] && dodoc "${d}"
+ done
+ elif declare -p DOCS | grep -q "^declare -a " ; then
+ dodoc "${DOCS[@]}"
+ else
+ dodoc ${DOCS}
+ fi
+
+ if use mysql ; then
+ docinto schema
+ newdoc "${WORKDIR}"/icinga2-${PV}/components/db_ido_mysql/schema/mysql.sql mysql.sql
+ docinto schema/upgrade
+ #newdoc "${WORKDIR}"/icinga2-${PV}/components/db_ido_mysql/schema/upgrade/0.0.11.sql mysql-upgrade-1.12.0.sql
+ elif use postgres ; then
+ docinto schema
+ newdoc "${WORKDIR}"/icinga2-${PV}/components/db_ido_pgsql/schema/pgsql.sql pgsql.sql
+ docinto schema/upgrade
+ #newdoc "${WORKDIR}"/icinga2-${PV}/components/db_ido_pgsql/schema/upgrade/0.0.11.sql pgsql-upgrade-1.12.0.sql
+ fi
+
+ keepdir /etc/icinga2
+ keepdir /var/lib/icinga
+ keepdir /var/lib/icinga/archives
+ keepdir /var/lib/icinga/rw
+ keepdir /var/lib/icinga/spool/checkresults
+
+ #remove dirs that shouldn't be installed
+ rm -r "${D}var/run" || die "failed to remove /var/run"
+ rm -r "${D}var/cache" || die "failed to remove /var/cache"
+
+ fowners icinga:icinga /var/lib/icinga || die "Failed chown of /var/lib/icinga"
+ fowners icinga:icinga /var/lib/icinga2 || die "Failed chown of /var/lib/icinga2"
+}
+
+pkg_postinst() {
+ elog "DB IDO schema upgrade required. http://docs.icinga.org/icinga2/snapshot/chapter-2.html#upgrading-the-mysql-database"
+ elog "You will need to update your configuration files, see https://dev.icinga.org/issues/5909"
+}