summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-07-12 17:00:00 +0000
committerJeroen Roovers <jer@gentoo.org>2014-07-12 17:00:00 +0000
commit1cc7082a11e6ba58e7fc4d3a67d2c97aa4d9d12d (patch)
treeb3233994f82024882139f70adc923954e6ee447b /net-analyzer/ifmetric
parentAdd 5.20 version of Safe to perl-5.20 mask (diff)
downloadgentoo-2-1cc7082a11e6ba58e7fc4d3a67d2c97aa4d9d12d.tar.gz
gentoo-2-1cc7082a11e6ba58e7fc4d3a67d2c97aa4d9d12d.tar.bz2
gentoo-2-1cc7082a11e6ba58e7fc4d3a67d2c97aa4d9d12d.zip
EAPI bump. Fix fprintf format warning.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/ifmetric')
-rw-r--r--net-analyzer/ifmetric/ChangeLog14
-rw-r--r--net-analyzer/ifmetric/files/ifmetric-0.3-ul.patch11
-rw-r--r--net-analyzer/ifmetric/ifmetric-0.3-r1.ebuild34
3 files changed, 57 insertions, 2 deletions
diff --git a/net-analyzer/ifmetric/ChangeLog b/net-analyzer/ifmetric/ChangeLog
index 23759751523f..9813609e78da 100644
--- a/net-analyzer/ifmetric/ChangeLog
+++ b/net-analyzer/ifmetric/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-analyzer/ifmetric
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ifmetric/ChangeLog,v 1.8 2013/11/06 04:05:13 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ifmetric/ChangeLog,v 1.9 2014/07/12 17:00:00 jer Exp $
+
+ 12 Jul 2014; Jeroen Roovers <jer@gentoo.org> +ifmetric-0.3-r1.ebuild,
+ +files/ifmetric-0.3-ul.patch:
+ EAPI bump. Fix fprintf format warning.
+
+*ifmetric-0.3-r1 (12 Jul 2014)
+
+ 12 Jul 2014; Jeroen Roovers <jer@gentoo.org> +ifmetric-0.3-r1.ebuild,
+ +files/ifmetric-0.3-ul.patch:
+ EAPI bump. Fix fprintf format warning.
06 Nov 2013; Patrick Lauer <patrick@gentoo.org> ifmetric-0.3.ebuild:
Shorten description, make repoman happier
diff --git a/net-analyzer/ifmetric/files/ifmetric-0.3-ul.patch b/net-analyzer/ifmetric/files/ifmetric-0.3-ul.patch
new file mode 100644
index 000000000000..eb432dc29c0e
--- /dev/null
+++ b/net-analyzer/ifmetric/files/ifmetric-0.3-ul.patch
@@ -0,0 +1,11 @@
+--- a/src/nlrequest.c
++++ b/src/nlrequest.c
+@@ -56,7 +56,7 @@
+ int ret;
+
+ if (!NLMSG_OK(p, bytes) || bytes < sizeof(struct nlmsghdr) || bytes < p->nlmsg_len) {
+- fprintf(stderr, "NETLINK: Packet too small or truncated! %u!=%u!=%u\n", bytes, sizeof(struct nlmsghdr), p->nlmsg_len);
++ fprintf(stderr, "NETLINK: Packet too small or truncated! %u!=%lu!=%u\n", bytes, sizeof(struct nlmsghdr), p->nlmsg_len);
+ return -1;
+ }
+
diff --git a/net-analyzer/ifmetric/ifmetric-0.3-r1.ebuild b/net-analyzer/ifmetric/ifmetric-0.3-r1.ebuild
new file mode 100644
index 000000000000..8d13450ab601
--- /dev/null
+++ b/net-analyzer/ifmetric/ifmetric-0.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ifmetric/ifmetric-0.3-r1.ebuild,v 1.1 2014/07/12 17:00:00 jer Exp $
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Linux tool for setting metrics of all IPv4 routes attached to a given network interface at once"
+HOMEPAGE="http://0pointer.de/lennart/projects/ifmetric/"
+SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="sys-kernel/linux-headers"
+
+DOCS=( README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ul.patch
+}
+
+src_configure() {
+ # man page and HTML are already generated
+ econf \
+ --disable-xmltoman \
+ --disable-lynx
+}
+
+src_install() {
+ default
+ dohtml doc/README.html
+}