summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2003-08-03 21:56:42 +0000
committerGuy Martin <gmsoft@gentoo.org>2003-08-03 21:56:42 +0000
commit4dcbe2c6338b5088439462857e1a857b5e721a7d (patch)
tree20433aeaf98446ffaa8b196c82ecacc863a6b5fb /net-analyzer/iptraf
parentAdded ipv6 support. Fixed a small bug with path. Marked unstable. (diff)
downloadgentoo-2-4dcbe2c6338b5088439462857e1a857b5e721a7d.tar.gz
gentoo-2-4dcbe2c6338b5088439462857e1a857b5e721a7d.tar.bz2
gentoo-2-4dcbe2c6338b5088439462857e1a857b5e721a7d.zip
Added ipv6 support. Fixed a small bug with path. Marked unstable.
Diffstat (limited to 'net-analyzer/iptraf')
-rw-r--r--net-analyzer/iptraf/ChangeLog7
-rw-r--r--net-analyzer/iptraf/Manifest4
-rw-r--r--net-analyzer/iptraf/files/digest-iptraf-2.7.0-r12
-rw-r--r--net-analyzer/iptraf/iptraf-2.7.0-r1.ebuild38
4 files changed, 48 insertions, 3 deletions
diff --git a/net-analyzer/iptraf/ChangeLog b/net-analyzer/iptraf/ChangeLog
index 977fcabd616f..c74575eb45e1 100644
--- a/net-analyzer/iptraf/ChangeLog
+++ b/net-analyzer/iptraf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/iptraf
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptraf/ChangeLog,v 1.12 2003/08/01 14:37:29 tuxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptraf/ChangeLog,v 1.13 2003/08/03 21:56:31 gmsoft Exp $
+
+*iptraf-2.7.0-r1 (03 Aug 2003)
+
+ 03 Aug 2003; Guy Martin <gmsoft@gentoo.org> iptraf-2.7.0-r1.ebuild :
+ Added ipv6 support. Fixed a small bug with path. Marked unstable.
*iptraf-2.7.0 (30 Aug 2002)
diff --git a/net-analyzer/iptraf/Manifest b/net-analyzer/iptraf/Manifest
index 697c531979b7..344290511e12 100644
--- a/net-analyzer/iptraf/Manifest
+++ b/net-analyzer/iptraf/Manifest
@@ -1,5 +1,5 @@
-MD5 153eb27ecc91ae6fd69d6b889d8187be ChangeLog 1753
+MD5 7d9283d7d5ef91d89a367660743eb6d9 ChangeLog 1754
MD5 35b69f04d2b764d74807c5565e46867f iptraf-2.7.0.ebuild 859
-MD5 629524617913b27a6a9f2a9f9e688ddb iptraf-2.7.0-r1.ebuild 1212
+MD5 251c76255c2d4e6cbd4284d7257ad606 iptraf-2.7.0-r1.ebuild 1213
MD5 68d035b52bb75c049cc9a59f51ce2a07 files/digest-iptraf-2.7.0 64
MD5 915f3f0dba9cd9abf434d80ad5e0c0cc files/digest-iptraf-2.7.0-r1 138
diff --git a/net-analyzer/iptraf/files/digest-iptraf-2.7.0-r1 b/net-analyzer/iptraf/files/digest-iptraf-2.7.0-r1
new file mode 100644
index 000000000000..d67c3eabb587
--- /dev/null
+++ b/net-analyzer/iptraf/files/digest-iptraf-2.7.0-r1
@@ -0,0 +1,2 @@
+MD5 7ff0bc933a0a57a4ca9e2b0443307539 iptraf-2.7.0.tar.gz 363496
+MD5 b42690cef651e1a6b4e3f2b641c2e530 iptraf-2.7.0-ipv6-alpha10.diff 46452
diff --git a/net-analyzer/iptraf/iptraf-2.7.0-r1.ebuild b/net-analyzer/iptraf/iptraf-2.7.0-r1.ebuild
new file mode 100644
index 000000000000..afe04d400591
--- /dev/null
+++ b/net-analyzer/iptraf/iptraf-2.7.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptraf/iptraf-2.7.0-r1.ebuild,v 1.1 2003/08/03 21:56:31 gmsoft Exp $
+
+S=${WORKDIR}/${P}
+V6PATCH_LEVEL=alpha10
+DESCRIPTION="IPTraf is an ncurses-based IP LAN monitor"
+SRC_URI="ftp://ftp.cebu.mozcom.com/pub/linux/net/${P}.tar.gz http://dev.gentoo.org/~gmsoft/${P}-ipv6-${V6PATCH_LEVEL}.diff"
+HOMEPAGE="http://cebu.mozcom.com/riker/iptraf/"
+IUSE="ipv6"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
+
+DEPEND=">=sys-libs/ncurses-5.2-r1"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ [ -n "`use ipv6`" ] && patch -p 0 < ${DISTDIR}/${P}-ipv6-${V6PATCH_LEVEL}.diff
+ cd src
+ cp dirs.h dirs.h.orig
+ sed -e s:/var/local/iptraf:/var/lib/iptraf: -e s:/usr/local/bin:/usr/sbin: dirs.h.orig > dirs.h
+}
+
+src_compile() {
+ cd src
+ emake CFLAGS="$CFLAGS" DEBUG="" TARGET="/usr/sbin" WORKDIR="/var/lib/iptraf" \
+ clean all || die "emake failed"
+}
+src_install() {
+ dosbin src/{iptraf,cfconv,rvnamed}
+ dodoc FAQ README* CHANGES RELEASE-NOTES LICENSE INSTALL
+ doman Documentation/*.8
+ dohtml Documentation/*.html
+ keepdir /var/{lib,run,log}/iptraf
+}