summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2007-12-28 10:48:14 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2007-12-28 10:48:14 +0000
commitbf3389de32e1115c5cc815ae75c3bdbcf0727dcb (patch)
treee95080514a4486fd4a406a45938ef515625fc3ec /net-analyzer/nikto/nikto-2.01.ebuild
parentx86 stable, bug #203554 (diff)
downloadgentoo-2-bf3389de32e1115c5cc815ae75c3bdbcf0727dcb.tar.gz
gentoo-2-bf3389de32e1115c5cc815ae75c3bdbcf0727dcb.tar.bz2
gentoo-2-bf3389de32e1115c5cc815ae75c3bdbcf0727dcb.zip
Version bump as per #199020, thanks to Frank Breedijk and Anton Bolshakov
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'net-analyzer/nikto/nikto-2.01.ebuild')
-rw-r--r--net-analyzer/nikto/nikto-2.01.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-analyzer/nikto/nikto-2.01.ebuild b/net-analyzer/nikto/nikto-2.01.ebuild
new file mode 100644
index 000000000000..e407f9ca6f0a
--- /dev/null
+++ b/net-analyzer/nikto/nikto-2.01.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nikto/nikto-2.01.ebuild,v 1.1 2007/12/28 10:48:14 dertobi123 Exp $
+
+DESCRIPTION="Web Server vulnerability scanner."
+HOMEPAGE="http://www.cirt.net/code/nikto.shtml"
+SRC_URI="http://www.cirt.net/source/nikto/ARCHIVE/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="ssl"
+
+RDEPEND="dev-lang/perl
+ >=net-analyzer/nmap-3.00
+ ssl? (
+ dev-libs/openssl
+ dev-perl/Net-SSLeay
+ )"
+
+src_compile() {
+ sed -i -e 's:config.txt:nikto.conf:' \
+ -i -e 's:"\$NIKTO{execdir}/kbase/nikto.kbase":"/var/nikto/kbase/nikto.kbase":' \
+ -i -e 's:\$NIKTO{configfile} = "nikto.conf":\$NIKTO{configfile} = "/etc/nikto/nikto.conf":' \
+ nikto.pl
+
+ mv config.txt nikto.conf
+
+ sed -i -e 's:/usr/local/bin/nmap:/usr/bin/nmap:' \
+ -i -e 's:# EXECDIR=/usr/local/nikto:EXECDIR=/usr/share/nikto:' \
+ nikto.conf
+}
+
+src_install() {
+ insinto /etc/nikto
+ doins nikto.conf
+
+ dodir /usr/bin
+ dobin nikto.pl
+ dosym /usr/bin/nikto.pl /usr/bin/nikto
+
+ dodir /usr/share/nikto/plugins
+ insinto /usr/share/nikto/plugins
+ doins plugins/*
+
+ dodir /usr/share/nikto/templates
+ insinto /usr/share/nikto/templates
+ doins templates/*
+
+ dodir /var/nikto/kbase
+
+ dodoc plugins/nikto_plugin_order.txt
+ cd docs
+ dodoc CHANGES.txt LICENSE.txt
+ dohtml nikto_manual.html
+}