summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-11-18 14:45:56 +0000
committerJeroen Roovers <jer@gentoo.org>2014-11-18 14:45:56 +0000
commitcbdbb3730dcc4cda2a76fee03e00b449b78cad49 (patch)
tree68aa61076f65c71af22ea13e44bb2bcdbbfa2f79 /net-analyzer/nmap/files
parentRemove unneeded libnl linkage (bug #529244). Do not set FORTIFY_SOURCE. (diff)
downloadgentoo-2-cbdbb3730dcc4cda2a76fee03e00b449b78cad49.tar.gz
gentoo-2-cbdbb3730dcc4cda2a76fee03e00b449b78cad49.tar.bz2
gentoo-2-cbdbb3730dcc4cda2a76fee03e00b449b78cad49.zip
Do not set FORTIFY_SOURCE anywhere else either.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/nmap/files')
-rw-r--r--net-analyzer/nmap/files/nmap-6.47-no-FORTIFY_SOURCE.patch66
1 files changed, 66 insertions, 0 deletions
diff --git a/net-analyzer/nmap/files/nmap-6.47-no-FORTIFY_SOURCE.patch b/net-analyzer/nmap/files/nmap-6.47-no-FORTIFY_SOURCE.patch
index b1c0d31bab73..d61ce2f7f2c0 100644
--- a/net-analyzer/nmap/files/nmap-6.47-no-FORTIFY_SOURCE.patch
+++ b/net-analyzer/nmap/files/nmap-6.47-no-FORTIFY_SOURCE.patch
@@ -9,3 +9,69 @@
# For mtrace debugging -- see MTRACE define in main.cc for instructions
# Should only be enabled during debugging and not in any real release.
# DEFS += -DMTRACE=1
+--- a/nsock/src/Makefile.in
++++ b/nsock/src/Makefile.in
+@@ -13,7 +13,7 @@
+ CCOPT =
+ DEFS = @DEFS@ -DNSOCK_VERSION=\"$(NSOCK_VERSION)\"
+ # With GCC, add extra security checks to source code.
+-DEFS += -D_FORTIFY_SOURCE=2
++#DEFS += -D_FORTIFY_SOURCE=2
+ INCLS = -I../include
+ CFLAGS = @CFLAGS@ $(CCOPT)
+ # CFLAGS = -g -Wall $(DEFS) $(INCLS)
+--- a/nping/Makefile.in
++++ b/nping/Makefile.in
+@@ -37,7 +37,7 @@
+ # http://gcc.gnu.org/ml/gcc-patches/2004-09/msg02055.html
+ # Level 1 only makes changes that don't affect "conforming" programs,
+ # while level 2 enforces additional restrictions.
+-DEFS += -D_FORTIFY_SOURCE=2
++#DEFS += -D_FORTIFY_SOURCE=2
+ # For mtrace debugging -- see MTRACE define in main.cc for instructions
+ # Should only be enabled during debugging and not in any real release.
+ # DEFS += -DMTRACE=1
+--- a/libnetutil/Makefile.in
++++ b/libnetutil/Makefile.in
+@@ -5,7 +5,7 @@
+ CXXFLAGS = @CXXFLAGS@
+ CPPFLAGS = @CPPFLAGS@ $(DEFS)
+ DEFS = @DEFS@
+-DEFS += -D_FORTIFY_SOURCE=2
++#DEFS += -D_FORTIFY_SOURCE=2
+ AR = ar
+ RANLIB = @RANLIB@
+
+--- a/ncat/Makefile.in
++++ b/ncat/Makefile.in
+@@ -52,7 +52,7 @@
+ LIBS = @LIBS@
+ DEFS = @DEFS@ -DNCAT_DATADIR="\"$(pkgdatadir)\""
+ # With GCC, add extra security checks to source code.
+-DEFS += -D_FORTIFY_SOURCE=2
++#DEFS += -D_FORTIFY_SOURCE=2
+ INCLS = -I. -I.. -I../nsock/include/ -I$(NBASEDIR)
+ RM = rm -f
+ STRIP = @STRIP@
+--- a/nbase/Makefile.in
++++ b/nbase/Makefile.in
+@@ -11,7 +11,7 @@
+ CCOPT =
+ DEFS = @DEFS@
+ # With GCC, add extra security checks to source code.
+-DEFS += -D_FORTIFY_SOURCE=2
++#DEFS += -D_FORTIFY_SOURCE=2
+ CPPFLAGS = @CPPFLAGS@
+ CFLAGS = @CFLAGS@ $(CCOPT) $(GLIB_CFLAGS) $(DEFS) $(INCLS)
+ STATIC =
+--- a/nmap-update/Makefile.in
++++ b/nmap-update/Makefile.in
+@@ -10,7 +10,7 @@
+ CPPFLAGS = @CPPFLAGS@ $(DEFS) -I$(NBASEDIR)
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@ $(NBASELIB)
+-DEFS = @DEFS@ -D_FORTIFY_SOURCE=2
++#DEFS = @DEFS@ -D_FORTIFY_SOURCE=2
+
+ INSTALL = @INSTALL@
+ STRIP = @STRIP@