summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-01-06 14:41:31 +0000
committerMichael Januszewski <spock@gentoo.org>2008-01-06 14:41:31 +0000
commit1ebe9814f9ea796fe3d52fc3af6fd92d377a03cb (patch)
tree0a5dd3696451bd2143907abcf18b7a3c52285aaf /net-analyzer/nmap
parentAdded an upstream patch provided by Vanya to fix bug 204289. Thanks, Vanya! (diff)
downloadgentoo-2-1ebe9814f9ea796fe3d52fc3af6fd92d377a03cb.tar.gz
gentoo-2-1ebe9814f9ea796fe3d52fc3af6fd92d377a03cb.tar.bz2
gentoo-2-1ebe9814f9ea796fe3d52fc3af6fd92d377a03cb.zip
Version bump (bug #204555).
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'net-analyzer/nmap')
-rw-r--r--net-analyzer/nmap/ChangeLog9
-rw-r--r--net-analyzer/nmap/files/digest-nmap-4.523
-rw-r--r--net-analyzer/nmap/nmap-4.52.ebuild49
3 files changed, 59 insertions, 2 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index 086f4bb4a1da..effeafbf3d07 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nmap
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.150 2007/12/16 10:00:11 spock Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.151 2008/01/06 14:41:30 spock Exp $
+
+*nmap-4.52 (06 Jan 2008)
+
+ 06 Jan 2008; Michał Januszewski <spock@gentoo.org> +nmap-4.52.ebuild:
+ Version bump (bug #204555).
16 Dec 2007; Michał Januszewski <spock@gentoo.org> nmap-4.50.ebuild:
Update dependencies as suggested in bug #202424 and restore the hppa keyword.
diff --git a/net-analyzer/nmap/files/digest-nmap-4.52 b/net-analyzer/nmap/files/digest-nmap-4.52
new file mode 100644
index 000000000000..a0025348f8e4
--- /dev/null
+++ b/net-analyzer/nmap/files/digest-nmap-4.52
@@ -0,0 +1,3 @@
+MD5 4f965a89e4e724d266dd9235c485633f nmap-4.52.tar.bz2 3147364
+RMD160 df309ebecc0fe04f9cf59ebff39ee011dadd6256 nmap-4.52.tar.bz2 3147364
+SHA256 ec44e89f12bb1c140e9e580f2ceee8950caa03537cf74f5718b25b19a476589a nmap-4.52.tar.bz2 3147364
diff --git a/net-analyzer/nmap/nmap-4.52.ebuild b/net-analyzer/nmap/nmap-4.52.ebuild
new file mode 100644
index 000000000000..1ce6ee827825
--- /dev/null
+++ b/net-analyzer/nmap/nmap-4.52.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-4.52.ebuild,v 1.1 2008/01/06 14:41:30 spock Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A utility for network exploration or security auditing"
+HOMEPAGE="http://www.insecure.org/nmap/"
+SRC_URI="http://download.insecure.org/nmap/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk ssl"
+
+DEPEND="dev-libs/libpcre
+ net-libs/libpcap
+ gtk? ( >=x11-libs/gtk+-2.6
+ >=dev-python/pygtk-2.6
+ || ( >=dev-lang/python-2.5
+ >=dev-python/pysqlite-2 )
+ )
+ ssl? ( dev-libs/openssl )"
+
+pkg_setup() {
+ if use gtk && has_version ">=dev-lang/python-2.5" &&
+ ! has_version ">=dev-python/pysqlite-2" &&
+ ! built_with_use dev-lang/python sqlite ; then
+ eerror "In order to use the nmap GUI you have to either emerge dev-lang/python"
+ eerror "with the 'sqlite' USE flag, or install dev-python/pysqlite-2*."
+ die "sqlite support missing"
+ fi
+}
+
+src_compile() {
+ use ppc-macos && filter-flags -fstrict-aliasing -O2
+ econf \
+ --with-libdnet=included \
+ $(use_with gtk zenmap) \
+ $(use_with ssl openssl) || die
+ emake -j1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" -j1 nmapdatadir=/usr/share/nmap install || die
+ dodoc CHANGELOG HACKING docs/README docs/*.txt || die
+
+ use gtk && doicon "${FILESDIR}/nmap-logo-64.png"
+}