summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-09-26 07:20:51 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-09-26 07:20:51 +0000
commit4c91fc2fc4ccf0791b01c48c363cd91613734f25 (patch)
treee08f0ed0963b2085c39d30870817431927c58de6 /net-analyzer/nsat
parentMake amd64-compatibility patch applies only on amd64 systems (diff)
downloadgentoo-2-4c91fc2fc4ccf0791b01c48c363cd91613734f25.tar.gz
gentoo-2-4c91fc2fc4ccf0791b01c48c363cd91613734f25.tar.bz2
gentoo-2-4c91fc2fc4ccf0791b01c48c363cd91613734f25.zip
Bump ebuild's EAPI to 2, add some QA fixes wrt bug #335951
(Portage version: 2.2.0_alpha132/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/nsat')
-rw-r--r--net-analyzer/nsat/ChangeLog5
-rw-r--r--net-analyzer/nsat/nsat-1.5-r1.ebuild25
2 files changed, 16 insertions, 14 deletions
diff --git a/net-analyzer/nsat/ChangeLog b/net-analyzer/nsat/ChangeLog
index 18d48837fa72..f9be4d08ba64 100644
--- a/net-analyzer/nsat/ChangeLog
+++ b/net-analyzer/nsat/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/nsat
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nsat/ChangeLog,v 1.19 2012/09/26 07:14:40 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nsat/ChangeLog,v 1.20 2012/09/26 07:20:51 pinkbyte Exp $
+
+ 26 Sep 2012; Sergey Popov <pinkbyte@gentoo.org> nsat-1.5-r1.ebuild:
+ Bump ebuild's EAPI to 2, add some QA fixes wrt bug #335951
26 Sep 2012; Sergey Popov <pinkbyte@gentoo.org> nsat-1.5-r1.ebuild:
Make amd64-compatibility patch applies only on amd64 systems
diff --git a/net-analyzer/nsat/nsat-1.5-r1.ebuild b/net-analyzer/nsat/nsat-1.5-r1.ebuild
index eb68ec5814e7..e4445d9a4966 100644
--- a/net-analyzer/nsat/nsat-1.5-r1.ebuild
+++ b/net-analyzer/nsat/nsat-1.5-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nsat/nsat-1.5-r1.ebuild,v 1.2 2012/09/26 07:14:40 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nsat/nsat-1.5-r1.ebuild,v 1.3 2012/09/26 07:20:51 pinkbyte Exp $
-inherit eutils autotools
+EAPI=2
-WANT_AUTOCONF=2.5
+inherit eutils autotools
DESCRIPTION="Network Security Analysis Tool, an application-level network security scanner"
HOMEPAGE="http://nsat.sourceforge.net/"
@@ -23,10 +23,7 @@ DEPEND="$RDEPEND >=sys-devel/autoconf-2.58"
S="${WORKDIR}/${PN}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- cp -va configure.in{,.orig}
+src_prepare() {
epatch "${FILESDIR}"/${P}-configure.patch
# bug 128204
epatch "${FILESDIR}"/${P}-lvalue-gcc4.patch
@@ -35,19 +32,21 @@ src_unpack() {
use amd64 && epatch "${FILESDIR}"/${P}-amd64-compat.patch
sed -i "s:^#CGIFile /usr/local/share/nsat/nsat.cgi$:#CGIFile /usr/share/nsat/nsat.cgi:g" \
- nsat.conf
- sed -i "s:/usr/local:/usr:g" Makefile.in
- sed -i "s:/usr/local:/usr:g" tools/xnsat
+ nsat.conf || die "sed on nsat.conf failed"
+ sed -i "s:/usr/local:/usr:g" Makefile.in || die "sed on Makefile.in failed"
+ sed -i "s:/usr/local:/usr:g" tools/xnsat || die "sed on tools/xnsat failed"
sed -i -e "s:/usr/local/share/nsat/nsat.conf:/etc/nsat/nsat.conf:g" \
-e "s:/usr/local/share/nsat/nsat.cgi:/usr/share/nsat/nsat.cgi:g" \
- src/lang.h
+ src/lang.h || die "sed on src/lang.h failed"
eautoreconf
}
-src_compile() {
- econf $( use_with X x ) || die
+src_configure() {
+ econf $(use_with X x) || die "configuration failed"
+}
+src_compile() {
make|| die "compile problem"
}