summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-04-22 08:44:14 +0000
committerPeter Volkov <pva@gentoo.org>2007-04-22 08:44:14 +0000
commit373e986b4d0e715fd333e53b47f9313c52d9cb13 (patch)
tree38713233049ce45b63fdf846779667632f52df96 /net-analyzer/ntop
parentStable on Alpha, bug 174559. (diff)
downloadgentoo-2-373e986b4d0e715fd333e53b47f9313c52d9cb13.tar.gz
gentoo-2-373e986b4d0e715fd333e53b47f9313c52d9cb13.tar.bz2
gentoo-2-373e986b4d0e715fd333e53b47f9313c52d9cb13.zip
Use do{conf,init}d, bug #174266.
(Portage version: 2.1.2.2)
Diffstat (limited to 'net-analyzer/ntop')
-rw-r--r--net-analyzer/ntop/ChangeLog5
-rw-r--r--net-analyzer/ntop/ntop-3.0.ebuild10
-rw-r--r--net-analyzer/ntop/ntop-3.1.ebuild20
3 files changed, 19 insertions, 16 deletions
diff --git a/net-analyzer/ntop/ChangeLog b/net-analyzer/ntop/ChangeLog
index 0473ed3a6298..8cd80787f694 100644
--- a/net-analyzer/ntop/ChangeLog
+++ b/net-analyzer/ntop/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/ntop
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.50 2007/03/27 20:55:11 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ChangeLog,v 1.51 2007/04/22 08:44:14 pva Exp $
+
+ 22 Apr 2007; <pva@gentoo.org> ntop-3.0.ebuild, ntop-3.1.ebuild:
+ Use do{conf,init}d, bug #174266.
*ntop-3.2-r3 (27 Mar 2007)
diff --git a/net-analyzer/ntop/ntop-3.0.ebuild b/net-analyzer/ntop/ntop-3.0.ebuild
index 7a872d43c386..66e22fea8113 100644
--- a/net-analyzer/ntop/ntop-3.0.ebuild
+++ b/net-analyzer/ntop/ntop-3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-3.0.ebuild,v 1.20 2007/01/05 08:39:00 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-3.0.ebuild,v 1.21 2007/04/22 08:44:14 pva Exp $
DESCRIPTION="tool that shows network usage like top"
@@ -32,7 +32,7 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die "install problem"
+ make DESTDIR="${D}" install || die "install problem"
# fixme: bad handling of plugins (in /usr/lib with unsuggestive names)
# (don't know if there is a clean way to handle it)
@@ -45,10 +45,10 @@ src_install() {
dohtml ntop.html
keepdir /var/lib/ntop
- chown -R nobody:nobody ${D}/var/lib/ntop
+ chown -R nobody:nobody "${D}"/var/lib/ntop
- exeinto /etc/init.d ; newexe ${FILESDIR}/ntop-init ntop
- insinto /etc/conf.d ; newins ${FILESDIR}/ntop-confd ntop
+ newinitd "${FILESDIR}"/ntop-init ntop
+ newconfd "${FILESDIR}"/ntop-confd ntop
}
pkg_postinst() {
diff --git a/net-analyzer/ntop/ntop-3.1.ebuild b/net-analyzer/ntop/ntop-3.1.ebuild
index ad37c5061ccb..33a60f32cee3 100644
--- a/net-analyzer/ntop/ntop-3.1.ebuild
+++ b/net-analyzer/ntop/ntop-3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-3.1.ebuild,v 1.10 2007/01/05 08:39:00 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-3.1.ebuild,v 1.11 2007/04/22 08:44:14 pva Exp $
inherit eutils
@@ -35,9 +35,9 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- mv ${WORKDIR}/ntop ${WORKDIR}/ntop-3.1
- cd ${S}
- epatch ${FILESDIR}/globals-core.c.diff
+ mv "${WORKDIR}"/ntop "${WORKDIR}"/ntop-3.1
+ cd "${S}"
+ epatch "${FILESDIR}"/globals-core.c.diff
}
src_compile() {
@@ -63,7 +63,7 @@ src_compile() {
src_install() {
sed -i Makefile -e 's;mkdir -p $(CFG_DBFILE_DIR);mkdir -p $(DESTDIR)$(CFG_DBFILE_DIR);'
- make DESTDIR=${D} install || die "install problem"
+ make DESTDIR="${D}" install || die "install problem"
# fixme: bad handling of plugins (in /usr/lib with unsuggestive names)
# (don't know if there is a clean way to handle it)
@@ -73,8 +73,8 @@ src_install() {
dodoc AUTHORS CONTENTS ChangeLog MANIFESTO NEWS
dodoc PORTING README SUPPORT_NTOP.txt THANKS docs/*
- chown -R root:0 ${D}/etc/ntop ${D}/usr/share/${PN}/html \
- ${D}/usr/lib/ntop
+ chown -R root:0 "${D}"/etc/ntop "${D}"/usr/share/${PN}/html \
+ "${D}"/usr/lib/ntop
dohtml ntop.html
@@ -82,9 +82,9 @@ src_install() {
fowner ntop:ntop /var/lib/ntop
fperms 750 /var/lib/ntop
- exeinto /etc/init.d ; newexe ${FILESDIR}/ntop-init ntop
- insinto /etc/conf.d ; newins ${FILESDIR}/ntop-confd ntop
+ newinitd "${FILESDIR}"/ntop-init ntop
+ newconfd "${FILESDIR}"/ntop-confd ntop
- echo 'NTOP_OPTS="-u ntop -P /var/lib/ntop"' >> ${D}/etc/conf.d/ntop
+ echo 'NTOP_OPTS="-u ntop -P /var/lib/ntop"' >> "${D}"/etc/conf.d/ntop
}