summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-10-02 12:17:00 +0000
committerJeroen Roovers <jer@gentoo.org>2014-10-02 12:17:00 +0000
commit331f2bb32c4da0ac6673eab19d9bb4f296f8527a (patch)
treedbafd736204b4f6e6ee17490c01e867451884996 /net-analyzer/wireshark
parentVersion bump (diff)
downloadgentoo-2-331f2bb32c4da0ac6673eab19d9bb4f296f8527a.tar.gz
gentoo-2-331f2bb32c4da0ac6673eab19d9bb4f296f8527a.tar.bz2
gentoo-2-331f2bb32c4da0ac6673eab19d9bb4f296f8527a.zip
Version bump.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/wireshark')
-rw-r--r--net-analyzer/wireshark/ChangeLog9
-rw-r--r--net-analyzer/wireshark/files/wireshark-1.99.0.1975-gcc_option.patch82
-rw-r--r--net-analyzer/wireshark/files/wireshark-1.99.0.1975-sse4_2.patch20
-rw-r--r--net-analyzer/wireshark/metadata.xml1
-rw-r--r--net-analyzer/wireshark/wireshark-1.99.0.1975.ebuild231
5 files changed, 342 insertions, 1 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index 20ebd0dc7f09..540f30f0f98f 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.656 2014/09/27 10:58:51 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.657 2014/10/02 12:17:00 jer Exp $
+
+*wireshark-1.99.0.1975 (02 Oct 2014)
+
+ 02 Oct 2014; Jeroen Roovers <jer@gentoo.org> +wireshark-1.99.0.1975.ebuild,
+ +files/wireshark-1.99.0.1975-gcc_option.patch,
+ +files/wireshark-1.99.0.1975-sse4_2.patch, metadata.xml:
+ Version bump.
27 Sep 2014; Jeroen Roovers <jer@gentoo.org> -wireshark-1.10.9.ebuild,
-files/wireshark-1.10.1-oldlibs.patch,
diff --git a/net-analyzer/wireshark/files/wireshark-1.99.0.1975-gcc_option.patch b/net-analyzer/wireshark/files/wireshark-1.99.0.1975-gcc_option.patch
new file mode 100644
index 000000000000..3106ee31988e
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-1.99.0.1975-gcc_option.patch
@@ -0,0 +1,82 @@
+When testing for and adding options to CFLAGS/CXXFLAGS, add them at the start
+so that local C*FLAGS override them.
+
+
+--- a/acinclude.m4
++++ b/acinclude.m4
+@@ -1728,15 +1728,15 @@
+ CFLAGS_saved="$CFLAGS"
+ if expr "x$GCC_OPTION" : "x-W.*" >/dev/null
+ then
+- CFLAGS="$CFLAGS $ac_wireshark_unknown_warning_option_error $GCC_OPTION"
++ CFLAGS="$GCC_OPTION $CFLAGS $ac_wireshark_unknown_warning_option_error"
+ elif expr "x$GCC_OPTION" : "x-f.*" >/dev/null
+ then
+- CFLAGS="$CFLAGS -Werror $GCC_OPTION"
++ CFLAGS="$GCC_OPTION $CFLAGS -Werror"
+ elif expr "x$GCC_OPTION" : "x-m.*" >/dev/null
+ then
+- CFLAGS="$CFLAGS -Werror $GCC_OPTION"
++ CFLAGS="$GCC_OPTION $CFLAGS -Werror"
+ else
+- CFLAGS="$CFLAGS $GCC_OPTION"
++ CFLAGS="$GCC_OPTION $CFLAGS"
+ fi
+ AC_COMPILE_IFELSE(
+ [
+@@ -1765,7 +1765,7 @@
+ # added them, by setting CFLAGS to the saved value plus
+ # just the new option.
+ #
+- CFLAGS="$CFLAGS_saved $GCC_OPTION"
++ CFLAGS="$GCC_OPTION $CFLAGS_saved"
+ #
+ # Add it to the flags we use when building build tools.
+ #
+@@ -1781,7 +1781,7 @@
+ # added them, by setting CFLAGS to the saved value plus
+ # just the new option.
+ #
+- CFLAGS="$CFLAGS_saved $GCC_OPTION"
++ CFLAGS="$GCC_OPTION $CFLAGS_saved"
+ #
+ # Add it to the flags we use when building build tools.
+ #
+@@ -1818,15 +1818,15 @@
+ CXXFLAGS_saved="$CXXFLAGS"
+ if expr "x$GCC_OPTION" : "x-W.*" >/dev/null
+ then
+- CXXFLAGS="$CXXFLAGS $ac_wireshark_unknown_warning_option_error $ac_wireshark_non_cxx_warning_option_error $GCC_OPTION"
++ CXXFLAGS="$GCC_OPTION $CXXFLAGS $ac_wireshark_unknown_warning_option_error $ac_wireshark_non_cxx_warning_option_error"
+ elif expr "x$GCC_OPTION" : "x-f.*" >/dev/null
+ then
+- CXXFLAGS="$CXXFLAGS -Werror $GCC_OPTION"
++ CXXFLAGS="$GCC_OPTION $CXXFLAGS -Werror"
+ elif expr "x$GCC_OPTION" : "x-m.*" >/dev/null
+ then
+- CXXFLAGS="$CXXFLAGS -Werror $GCC_OPTION"
++ CXXFLAGS="$GCC_OPTION $CXXFLAGS -Werror"
+ else
+- CXXFLAGS="$CXXFLAGS $GCC_OPTION"
++ CXXFLAGS="$GCC_OPTION $CXXFLAGS"
+ fi
+ AC_LANG_PUSH([C++])
+ AC_COMPILE_IFELSE(
+@@ -1856,7 +1856,7 @@
+ # added them, by setting CXXFLAGS to the saved value plus
+ # just the new option.
+ #
+- CXXFLAGS="$CXXFLAGS_saved $GCC_OPTION"
++ CXXFLAGS="$GCC_OPTION $CXXFLAGS_saved"
+ ],
+ [
+ AC_MSG_RESULT(yes)
+@@ -1868,7 +1868,7 @@
+ # added them, by setting CXXFLAGS to the saved value plus
+ # just the new option.
+ #
+- CXXFLAGS="$CXXFLAGS_saved $GCC_OPTION"
++ CXXFLAGS="$GCC_OPTION $CXXFLAGS_saved"
+ fi
+ ],
+ [
diff --git a/net-analyzer/wireshark/files/wireshark-1.99.0.1975-sse4_2.patch b/net-analyzer/wireshark/files/wireshark-1.99.0.1975-sse4_2.patch
new file mode 100644
index 000000000000..ba61de645354
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-1.99.0.1975-sse4_2.patch
@@ -0,0 +1,20 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -985,6 +985,7 @@
+ AC_SUBST(PIE_CFLAGS)
+ AC_SUBST(PIE_LDFLAGS)
+
++AC_ARG_ENABLE(sse4_2,[ --enable-sse4_2 Support SSE4.2 (Streaming SIMD Extensions 4.2) instructions],[
+ CFLAGS_before_simd="$CFLAGS"
+ AC_WIRESHARK_COMPILER_FLAGS_CHECK(-msse4.2, C)
+ if test "x$CFLAGS" != "x$CFLAGS_before_simd"
+@@ -1011,6 +1012,9 @@
+ else
+ have_sse42=no
+ fi
++],[
++AC_MSG_RESULT(no)
++])
+ dnl build libwsutil_sse42 only if there is SSE4.2
+ AM_CONDITIONAL(SSE42_SUPPORTED, test "x$have_sse42" = "xyes")
+ AC_SUBST(CFLAGS_SSE42)
diff --git a/net-analyzer/wireshark/metadata.xml b/net-analyzer/wireshark/metadata.xml
index ae417f282724..175c77b79275 100644
--- a/net-analyzer/wireshark/metadata.xml
+++ b/net-analyzer/wireshark/metadata.xml
@@ -33,5 +33,6 @@
<flag name='pcap'>Use <pkg>net-libs/libpcap</pkg> for network packet capturing (build dumpcap, rawshark)</flag>
<flag name='qt4'>Build the wireshark executable with an experimental Qt UI instead of GTK+.</flag>
<flag name='smi'>Use <pkg>net-libs/libsmi</pkg> to resolve numeric OIDs into human readable format</flag>
+<flag name='sse4_2'> Support SSE4.2 (Streaming SIMD Extensions 4.2) instructions</flag>
</use>
</pkgmetadata>
diff --git a/net-analyzer/wireshark/wireshark-1.99.0.1975.ebuild b/net-analyzer/wireshark/wireshark-1.99.0.1975.ebuild
new file mode 100644
index 000000000000..b5cfdd7c696a
--- /dev/null
+++ b/net-analyzer/wireshark/wireshark-1.99.0.1975.ebuild
@@ -0,0 +1,231 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.99.0.1975.ebuild,v 1.1 2014/10/02 12:17:00 jer Exp $
+
+EAPI=5
+inherit autotools eutils fcaps qt4-r2 user versionator
+
+DESCRIPTION="A network protocol analyzer formerly known as ethereal"
+HOMEPAGE="http://www.wireshark.org/"
+
+WS_GIT="0efa992"
+WS_PV="$(version_format_string '$1.$2.$3-$4-g${WS_GIT}')"
+SRC_URI="${HOMEPAGE}download/automated/src/${PN}-${WS_PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS=""
+IUSE="
+ adns +caps crypt doc doc-pdf geoip +gtk3 ipv6 kerberos lua +netlink +pcap
+ portaudio +qt4 selinux smi sse4_2 ssl zlib
+"
+REQUIRED_USE="
+ ssl? ( crypt )
+"
+
+GTK_COMMON_DEPEND="
+ x11-libs/gdk-pixbuf
+ x11-libs/pango
+ x11-misc/xdg-utils
+"
+RDEPEND="
+ >=dev-libs/glib-2.14:2
+ netlink? ( dev-libs/libnl:3 )
+ adns? ( >=net-dns/c-ares-1.5 )
+ crypt? ( dev-libs/libgcrypt:0 )
+ caps? ( sys-libs/libcap )
+ geoip? ( dev-libs/geoip )
+ gtk3? (
+ ${GTK_COMMON_DEPEND}
+ x11-libs/gtk+:3
+ )
+ kerberos? ( virtual/krb5 )
+ lua? ( >=dev-lang/lua-5.1 )
+ pcap? ( net-libs/libpcap )
+ portaudio? ( media-libs/portaudio )
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ x11-misc/xdg-utils
+ )
+ selinux? ( sec-policy/selinux-wireshark )
+ smi? ( net-libs/libsmi )
+ ssl? ( net-libs/gnutls )
+ zlib? ( sys-libs/zlib !=sys-libs/zlib-1.2.4 )
+"
+
+DEPEND="
+ ${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ app-text/asciidoc
+ dev-libs/libxml2
+ dev-libs/libxslt
+ doc-pdf? ( dev-java/fop )
+ www-client/lynx
+ )
+ >=virtual/perl-Pod-Simple-3.170.0
+ sys-devel/bison
+ sys-devel/flex
+ virtual/perl-Getopt-Long
+ virtual/perl-Time-Local
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${PN}-${WS_PV}
+
+pkg_setup() {
+ enewgroup wireshark
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.6.13-ldflags.patch \
+ "${FILESDIR}"/${PN}-1.11.0-oldlibs.patch \
+ "${FILESDIR}"/${PN}-1.11.3-gtk-deprecated-warnings.patch \
+ "${FILESDIR}"/${P}-gcc_option.patch \
+ "${FILESDIR}"/${P}-sse4_2.patch
+
+ # Qt5 support is broken since the build system does not determine
+ # properly which `moc' it ought to use
+ sed -i -e 's|Qt5||g' acinclude.m4 || die
+
+ epatch_user
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # Workaround bug #213705. If krb5-config --libs has -lcrypto then pass
+ # --with-ssl to ./configure. (Mimics code from acinclude.m4).
+ if use kerberos; then
+ case $(krb5-config --libs) in
+ *-lcrypto*)
+ ewarn "Kerberos was built with ssl support: linkage with openssl is enabled."
+ ewarn "Note there are annoying license incompatibilities between the OpenSSL"
+ ewarn "license and the GPL, so do your check before distributing such package."
+ myconf+=( "--with-ssl" )
+ ;;
+ esac
+ fi
+
+ # Enable wireshark binary with any supported GUI toolkit (bug #473188)
+ if use gtk3 || use qt4 ; then
+ myconf+=( "--enable-wireshark" )
+ else
+ myconf+=( "--disable-wireshark" )
+ fi
+
+ # Hack around inability to disable doxygen/fop doc generation
+ use doc || export ac_cv_prog_HAVE_DOXYGEN=false
+ use doc-pdf || export ac_cv_prog_HAVE_FOP=false
+
+ # dumpcap requires libcap
+ # --disable-profile-build bugs #215806, #292991, #479602
+ econf \
+ $(use_enable ipv6) \
+ $(use_with adns c-ares) \
+ $(use_with caps libcap) \
+ $(use_with crypt gcrypt) \
+ $(use_with geoip) \
+ $(use_with gtk3) \
+ $(use_with kerberos krb5) \
+ $(use_with lua) \
+ $(use_with pcap dumpcap-group wireshark) \
+ $(use_with pcap) \
+ $(use_with portaudio) \
+ $(use_with qt4 qt) \
+ $(use_with smi libsmi) \
+ $(use_with ssl gnutls) \
+ $(use_with zlib) \
+ $(usex netlink --with-libnl=3 --without-libnl) \
+ $(usex sse4_2 --enable-sse4_2 '') \
+ --disable-profile-build \
+ --disable-usr-local \
+ --disable-warnings-as-errors \
+ --sysconfdir="${EPREFIX}"/etc/wireshark \
+ --without-adns \
+ ${myconf[@]}
+}
+
+src_compile() {
+ default
+ use doc && emake -j1 -C docbook
+}
+
+src_install() {
+ default
+ if use doc; then
+ dohtml -r docbook/{release-notes.html,ws{d,u}g_html{,_chunked}}
+ if use doc-pdf; then
+ insinto /usr/share/doc/${PF}/pdf/
+ doins docbook/{{developer,user}-guide,release-notes}-{a4,us}.pdf
+ fi
+ fi
+
+ # FAQ is not required as is installed from help/faq.txt
+ dodoc AUTHORS ChangeLog NEWS README{,.bsd,.linux,.macos,.vmware} \
+ doc/{randpkt.txt,README*}
+
+ # install headers
+ local wsheader
+ for wsheader in \
+ color.h \
+ config.h \
+ epan/*.h \
+ epan/crypt/*.h \
+ epan/dfilter/*.h \
+ epan/dissectors/*.h \
+ epan/ftypes/*.h \
+ epan/wmem/*.h \
+ register.h \
+ wiretap/*.h \
+ ws_symbol_export.h \
+ wsutil/*.h
+ do
+ insinto /usr/include/wireshark/$( dirname ${wsheader} )
+ doins ${wsheader}
+ done
+
+ #with the above this really shouldn't be needed, but things may be looking in wiretap/ instead of wireshark/wiretap/
+ insinto /usr/include/wiretap
+ doins wiretap/wtap.h
+
+ if use gtk3 || use qt4; then
+ local c d
+ for c in hi lo; do
+ for d in 16 32 48; do
+ insinto /usr/share/icons/${c}color/${d}x${d}/apps
+ newins image/${c}${d}-app-wireshark.png wireshark.png
+ done
+ done
+ fi
+
+ if use gtk3; then
+ domenu wireshark.desktop
+ fi
+
+ if use qt4; then
+ sed -e '/Exec=/s|wireshark|&-qt|g' wireshark.desktop > wireshark-qt.desktop || die
+ domenu wireshark-qt.desktop
+ fi
+
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ # Add group for users allowed to sniff.
+ enewgroup wireshark
+
+ if use pcap; then
+ fcaps -o 0 -g wireshark -m 4710 -M 0710 \
+ cap_dac_read_search,cap_net_raw,cap_net_admin \
+ "${EROOT}"/usr/bin/dumpcap
+ fi
+
+ ewarn "NOTE: To run wireshark as normal user you have to add yourself to"
+ ewarn "the wireshark group. This security measure ensures that only trusted"
+ ewarn "users are allowed to sniff your traffic."
+}