summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-06-11 23:39:29 +0000
committerJeroen Roovers <jer@gentoo.org>2013-06-11 23:39:29 +0000
commit467e8545b9d1b90b6b102053a31666f19257d00f (patch)
tree89ca087dc32780a5b6272d130fc40372ddea6eee /net-analyzer/wireshark
parentuse bigger icons (bug #472994) (diff)
downloadgentoo-2-467e8545b9d1b90b6b102053a31666f19257d00f.tar.gz
gentoo-2-467e8545b9d1b90b6b102053a31666f19257d00f.tar.bz2
gentoo-2-467e8545b9d1b90b6b102053a31666f19257d00f.zip
Remove broken python support. Remove ewarn messages in favour of local USE flag descriptions. Add Qt4 support by Andrei Slavoiu (bug #472992).
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/wireshark')
-rw-r--r--net-analyzer/wireshark/ChangeLog9
-rw-r--r--net-analyzer/wireshark/metadata.xml2
-rw-r--r--net-analyzer/wireshark/wireshark-1.10.0-r1.ebuild206
3 files changed, 216 insertions, 1 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index 0c2d0a874e82..b46f07c85b83 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.514 2013/06/10 03:38:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.515 2013/06/11 23:39:29 jer Exp $
+
+*wireshark-1.10.0-r1 (11 Jun 2013)
+
+ 11 Jun 2013; Jeroen Roovers <jer@gentoo.org> +wireshark-1.10.0-r1.ebuild,
+ metadata.xml:
+ Remove broken python support. Remove ewarn messages in favour of local USE
+ flag descriptions. Add Qt4 support by Andrei Slavoiu (bug #472992).
10 Jun 2013; Jeroen Roovers <jer@gentoo.org> wireshark-1.6.16.ebuild,
wireshark-1.8.8.ebuild, wireshark-1.10.0.ebuild:
diff --git a/net-analyzer/wireshark/metadata.xml b/net-analyzer/wireshark/metadata.xml
index d971e8a7280e..fb29035288a1 100644
--- a/net-analyzer/wireshark/metadata.xml
+++ b/net-analyzer/wireshark/metadata.xml
@@ -28,9 +28,11 @@
<flag name='adns'>Use the GNU <pkg>net-dns/c-ares</pkg> library to resolve DNS names</flag>
<flag name='crypt'>Use <pkg>dev-libs/libgcrypt</pkg> to decrypt traffic</flag>
<flag name='doc-pdf'>Build documentation in pdf format (US and a4 paper sizes)</flag>
+<flag name='gtk'>Build the wireshark executable with a GTK+ UI.</flag>
<flag name='libadns'>Use <pkg>net-lib/adns</pkg> (DEPRECATED) instead of <pkg>net-dns/c-ares</pkg> to resolve DNS names</flag>
<flag name='netlink'>Use <pkg>dev-libs/libnl</pkg></flag>
<flag name='pcap'>Use <pkg>net-libs/libpcap</pkg> for network packet capturing (build dumpcap, rawshark)</flag>
+<flag name='qt4'>Build the wireshark executable with a Qt UI.</flag>
<flag name='smi'>Use <pkg>net-libs/libsmi</pkg> to resolve numeric OIDs into human readable format</flag>
</use>
</pkgmetadata>
diff --git a/net-analyzer/wireshark/wireshark-1.10.0-r1.ebuild b/net-analyzer/wireshark/wireshark-1.10.0-r1.ebuild
new file mode 100644
index 000000000000..dc73a94ee664
--- /dev/null
+++ b/net-analyzer/wireshark/wireshark-1.10.0-r1.ebuild
@@ -0,0 +1,206 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.10.0-r1.ebuild,v 1.1 2013/06/11 23:39:29 jer Exp $
+
+EAPI=5
+inherit autotools eutils fcaps flag-o-matic user
+
+[[ -n ${PV#*_rc} && ${PV#*_rc} != ${PV} ]] && MY_P=${PN}-${PV/_} || MY_P=${P}
+DESCRIPTION="A network protocol analyzer formerly known as ethereal"
+HOMEPAGE="http://www.wireshark.org/"
+SRC_URI="http://www.wireshark.org/download/src/all-versions/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="
+ adns +caps crypt doc doc-pdf geoip +gtk ipv6 kerberos libadns lua
+ +netlink +pcap portaudio profile qt4 selinux smi ssl zlib
+"
+REQUIRED_USE="
+ ssl? ( crypt )
+ gtk? ( !qt4 )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.14:2
+ netlink? ( dev-libs/libnl )
+ adns? ( !libadns? ( >=net-dns/c-ares-1.5 ) )
+ crypt? ( dev-libs/libgcrypt )
+ caps? ( sys-libs/libcap )
+ geoip? ( dev-libs/geoip )
+ gtk? (
+ >=x11-libs/gtk+-2.4.0:2
+ dev-libs/atk
+ x11-libs/pango
+ x11-misc/xdg-utils
+ )
+ kerberos? ( virtual/krb5 )
+ libadns? ( net-libs/adns )
+ lua? ( >=dev-lang/lua-5.1 )
+ pcap? ( net-libs/libpcap[-netlink] )
+ portaudio? ( media-libs/portaudio )
+ qt4? ( dev-qt/qtcore:4 dev-qt/qtgui:4 )
+ selinux? ( sec-policy/selinux-wireshark )
+ smi? ( net-libs/libsmi )
+ ssl? ( net-libs/gnutls )
+ zlib? ( sys-libs/zlib !=sys-libs/zlib-1.2.4 )
+"
+
+DEPEND="
+ ${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ app-text/asciidoc
+ dev-libs/libxml2
+ dev-libs/libxslt
+ doc-pdf? ( dev-java/fop )
+ www-client/lynx
+ )
+ >=virtual/perl-Pod-Simple-3.170.0
+ sys-devel/bison
+ sys-devel/flex
+ virtual/perl-Getopt-Long
+ virtual/perl-Time-Local
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ # Add group for users allowed to sniff.
+ enewgroup wireshark
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.6.13-ldflags.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # profile and pie are incompatible #215806, #292991
+ if use profile; then
+ ewarn "You've enabled the 'profile' USE flag, building PIE binaries is disabled."
+ ewarn "Also ignore \"unrecognized option '-nopie'\" gcc warning #358101."
+ append-flags $(test-flags-CC -nopie)
+ fi
+
+ if use adns; then
+ if use libadns; then
+ myconf+=( "--with-adns --without-c-ares" )
+ else
+ myconf+=( "--without-adns --with-c-ares" )
+ fi
+ else
+ if use libadns; then
+ myconf+=( "--with-adns --without-c-ares" )
+ else
+ myconf+=( "--without-adns --without-c-ares" )
+ fi
+ fi
+
+ # Workaround bug #213705. If krb5-config --libs has -lcrypto then pass
+ # --with-ssl to ./configure. (Mimics code from acinclude.m4).
+ if use kerberos; then
+ case $(krb5-config --libs) in
+ *-lcrypto*)
+ ewarn "Kerberos was built with ssl support: linkage with openssl is enabled."
+ ewarn "Note there are annoying license incompatibilities between the OpenSSL"
+ ewarn "license and the GPL, so do your check before distributing such package."
+ myconf+=( "--with-ssl" )
+ ;;
+ esac
+ fi
+
+ # Hack around inability to disable doxygen/fop doc generation
+ use doc || export ac_cv_prog_HAVE_DOXYGEN=false
+ use doc-pdf || export ac_cv_prog_HAVE_FOP=false
+
+ # dumpcap requires libcap, setuid-install requires dumpcap
+ econf \
+ $(use pcap && use_enable !caps setuid-install) \
+ $(use pcap && use_enable caps setcap-install) \
+ $(use_enable gtk wireshark) \
+ $(use_enable ipv6) \
+ $(use_enable profile profile-build) \
+ $(use_enable qt4 wireshark) \
+ $(use_with caps libcap) \
+ $(use_with crypt gcrypt) \
+ $(use_with geoip) \
+ $(use_with kerberos krb5) \
+ $(use_with lua) \
+ $(use_with netlink libnl) \
+ $(use_with pcap dumpcap-group wireshark) \
+ $(use_with pcap) \
+ $(use_with portaudio) \
+ $(use_with qt4 qt) \
+ $(use_with smi libsmi) \
+ $(use_with ssl gnutls) \
+ $(use_with zlib) \
+ --disable-extra-gcc-checks \
+ --disable-usr-local \
+ --sysconfdir="${EPREFIX}"/etc/wireshark \
+ ${myconf[@]}
+}
+
+src_compile() {
+ default
+ use doc && emake -j1 -C docbook
+}
+
+src_install() {
+ default
+ if use doc; then
+ dohtml -r docbook/{release-notes.html,ws{d,u}g_html{,_chunked}}
+ if use doc-pdf; then
+ insinto /usr/share/doc/${PF}/pdf/
+ doins docbook/{{developer,user}-guide,release-notes}-{a4,us}.pdf
+ fi
+ fi
+
+ # FAQ is not required as is installed from help/faq.txt
+ dodoc AUTHORS ChangeLog NEWS README{,.bsd,.linux,.macos,.vmware} \
+ doc/{randpkt.txt,README*}
+
+ # install headers
+ local wsheader
+ for wsheader in $( echo $(< debian/wireshark-dev.header-files ) ); do
+ insinto /usr/include/wireshark/$( dirname ${wsheader} )
+ doins ${wsheader}
+ done
+
+ #with the above this really shouldn't be needed, but things may be looking in wiretap/ instead of wireshark/wiretap/
+ insinto /usr/include/wiretap
+ doins wiretap/wtap.h
+
+ if use gtk; then
+ for c in hi lo; do
+ for d in 16 32 48; do
+ insinto /usr/share/icons/${c}color/${d}x${d}/apps
+ newins image/${c}${d}-app-wireshark.png wireshark.png
+ done
+ done
+ domenu wireshark.desktop
+ fi
+
+ use pcap && chmod o-x "${ED}"/usr/bin/dumpcap #357237
+}
+
+pkg_postinst() {
+ # Add group for users allowed to sniff.
+ enewgroup wireshark
+
+ if use pcap; then
+ fcaps -o 0 -g wireshark -m 4550 -M 0750 \
+ cap_dac_read_search,cap_net_raw,cap_net_admin \
+ "${EROOT}"/usr/bin/dumpcap
+ fi
+
+ ewarn "NOTE: To run wireshark as normal user you have to add yourself to"
+ ewarn "the wireshark group. This security measure ensures that only trusted"
+ ewarn "users are allowed to sniff your traffic."
+}